Jump to content

A19/A18 CreaturePacks - A community entity project


Recommended Posts

6 hours ago, xyth said:

Its not needed for either.  It adds additional walktypes and the infection process to humans.

Wait, so does it mean that human NPCs can now turn into zombies? Yesterday I saw some weird zombie-like walk type of an NPC, I thought it was a bug, but with what you said here, it actually makes sense that an infected human NPC would start walking like zombie and eventually turn into one, so is that what happened to him? Oh and he attacked me too. I thought only bandits do that, but I guess if he was turning into a zombie, that would make sense too lol

Link to post
Share on other sites

Yup, working as intended.  Highly experimental but seems stable.  I have the reverse process working too but there is no quest yet for testing.

 

The NPCs if hit by a zombie can become infected.  Right now they turn really fast into zombies, like in a minute, but thats configurable.  I will change it to longer once someone besides me tests it for bugs.  "Humanpack ones also turn but wont attack the player since factions dont work in vanilla yet.

 

 

 

Edited by xyth (see edit history)
Link to post
Share on other sites

By the silence I take it that so far this modlet is bug free?  I have new zombies and humans to push to the mod but am waiting for confirmation that whats here so far is stable.  Thanks.

  • Like 1
Link to post
Share on other sites
12 hours ago, corona9800 said:

no issues XYTH the mode works great in the zombie pack only issue in the animal pack is i never see the birds im about 100 hours in a new play through havent seen nothing flying.

I can increase the spawnrate on the birds.  I plan on doing another polish pass soon.

11 hours ago, Dre said:

@xyth Nice mod. Thank you. Really appreciate all the hard work. (running it on my server/game).  A19 stable (all the ones that you had as a19 ready a few days ago). 

Thanks.  Glad you like it.

  • Like 1
Link to post
Share on other sites

Xyth good day

 

I uploaded the Mod yesterday and installed 3 of 0-CreaturePackAnimals, Humans and Zombies .. But not seeing anything new or old at the moment .. this is the only creature mod in game .. Is there something else I need to install in the mods folder?? A patch or something for A19 b180 .. this is in my Vanilla game.

Thank You, Be Safe and Take Care ... the Old Gamer .. 😌

 

PS: I have noticed in War3zuk Modlet .. he has a creature patch .. is that by you or did he do something?? 

Edited by gpcstargate
forgot something (see edit history)
Link to post
Share on other sites

You dont need anything else, but War3Z loads the some of the creaturepacks and then does some edits on the xml to remove many of them.  Loading both is likely your issue.

Link to post
Share on other sites
1 hour ago, xyth said:

You dont need anything else, but War3Z loads the some of the creaturepacks and then does some edits on the xml to remove many of them.  Loading both is likely your issue.

No _ I just loaded your 3 .... I was just saying That I saw that he had done something else.

Thank you for the reply ... the Old Gamer .. 😌

 

Link to post
Share on other sites

Updated the zombiepack.  Lots of new zombies.  A few are "shiny" as I don't have the time to rebuild all the A18 ones that used Spectacular shaders.   If any really bother folks I will fix those.  Most were rebuilt to reduce size, make A19 compatible, and fix shaders.

 

Animal pack updated with fixes for the swarms, which were moved into the xythanimals bundle.

 

 

 

 

Edited by xyth (see edit history)
  • Like 1
  • Thanks 3
Link to post
Share on other sites

I did.  The stripper was too large in file size for the quality of the character.  The cosplay german guy was also large and very shiny and would need rebuilding.  

Link to post
Share on other sites

Thanks for fixing the swarms. I have a question. Do you plan to apply the wandering orde bandits to the mod? be scavenging or loot a building and spawn according to game estage, it would be great! I also have another question the behemoth appear the hordes of day 7?

Link to post
Share on other sites
13 hours ago, corona9800 said:

just wondering i put them back in your latest update just for personal use i did notice the file size,so i deleted the guppy soldiers all of guppy zombies are great just wasnt a fan of those 

This version I packaged like kinds of zombies together so it would be easy for folks to remove what they didnt like.

11 hours ago, Souhank said:

Thanks for fixing the swarms. I have a question. Do you plan to apply the wandering orde bandits to the mod? be scavenging or loot a building and spawn according to game estage, it would be great! I also have another question the behemoth appear the hordes of day 7?

Yes, i added 2 days in the 50 day rotation that will have wandering bandit hordes.  I am working on the human pack now.  They all work, but the gun holding position is wrong on most of the new ones since the original authors didnt use that function.  I am rebuilding them with those components.  The behemoth has a small spawn chance in the wasteland during the day, and more likely at night.  Should not spawn in hordes. 

Edited by xyth (see edit history)
Link to post
Share on other sites
5 hours ago, xyth said:

This version I packaged like kinds of zombies together so it would be easy for folks to remove what they didnt like.

Yes, i added 2 days in the 50 day rotation that will have wandering bandit hordes.  I am working on the human pack now.  They all work, but the gun holding position is wrong on most of the new ones since the original authors didnt use that function.  I am rebuilding them with those components.  The behemoth has a small spawn chance in the wasteland during the day, and more likely at night.  Should not spawn in hordes. 

Imagine Behemoth spawning in hordes... Or even hordes of Behemoths... Who would like that? LOL

Link to post
Share on other sites

Human pack updated with some new humans.  Some which were in a18 were not added due to bad weapon rotations on the models.  Several others are close but need some adjusting eventually.   Bandits were added to the spawner so on some days bandit squads roam rather than zombie hordes.

  • Like 1
  • Thanks 1
Link to post
Share on other sites

heya Xyth. 4/5 players are having no issues with the packs thus far (thank you for work), however 1 player is having multiple errors upon entering the game. He has a folder structure that is correct as far as i could see: steamapps/common/7 days to die/mods/0-creaturepack*  . Couple things i noticed is a) its saying "[MODS] No mods folder found" b) when i did a console "killall" -- 2020-09-01T16:53:20 8086.060 INF Executing command 'killall' by Terminal Window - Gave 99999 damage to entity humanWhispererBetaHunter -- and he was able to enter game c) it keeps referencing: steamapps/common/7 days to die/7daystodie_data/../mods/0-creaturepack*/resources/harleysounds.unity3d failed , when 7daystodie_data doesnt have a "mods" folder anywhere in his file structure.. If you can provide assistance I would appreciate it.. I'll provide whatever i can:

 

output log: https://pastebin.com/XQKT3Wmb

Imgur: https://imgur.com/a/MIqgdFr

Link to post
Share on other sites
3 hours ago, Syrex said:

heya Xyth. 4/5 players are having no issues with the packs thus far (thank you for work), however 1 player is having multiple errors upon entering the game. He has a folder structure that is correct as far as i could see: steamapps/common/7 days to die/mods/0-creaturepack*  . Couple things i noticed is a) its saying "[MODS] No mods folder found" b) when i did a console "killall" -- 2020-09-01T16:53:20 8086.060 INF Executing command 'killall' by Terminal Window - Gave 99999 damage to entity humanWhispererBetaHunter -- and he was able to enter game c) it keeps referencing: steamapps/common/7 days to die/7daystodie_data/../mods/0-creaturepack*/resources/harleysounds.unity3d failed , when 7daystodie_data doesnt have a "mods" folder anywhere in his file structure.. If you can provide assistance I would appreciate it.. I'll provide whatever i can:

 

output log: https://pastebin.com/XQKT3Wmb

Imgur: https://imgur.com/a/MIqgdFr

Check out the output log:

D:/SteamLibrary/steamapps/common/7 Days To Die/7DaysToDie_Data/../Mods/0-CreaturePackAnimals

This is your error right there. Mods folder doesn't go into 7DaysToDie_Data subfolder. It goes into 7 Days To Die folder directly.

Link to post
Share on other sites

kinda missed the part where i said "when 7daystodie_data doesnt have a "mods" folder anywhere in his file structure", plus it's saying "Trying to guess path from mod name". Is there a file that i should have him look at to make sure its pointing correctly? he showed me his 7daystodie_data (when he gets home from work i asked him to look in each of the folders to be 100% certain since it said there was a "/../Mods")

 

imgur of _data folder: https://imgur.com/gkw9fVd

 

 

**Edit**: I think i figured it out, he's gonna check when he gets home.. he said he created folders for each of the packs naming the folders "0-CreaturePackAnimals" (as an example), extracted the files (which already have a folder named as such in there) and moved each into Mods folder.. so his file structure is actually: Steam\steamapps\common\7 Days To Die\Mods\0-CreaturePackAnimals\0-CreaturePackAnimals.. so a install oops.. thanks for reply mr.devolver ^5

Edited by Syrex (see edit history)
Link to post
Share on other sites
  • xyth pinned and unpinned this topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...