Jump to content
xyth

A19/A18 CreaturePacks - A community entity project

Recommended Posts

Thanks for the replies.

 

It is indeed a new save and world generated

I have manually deleted the world and saves multiple time and been able to reproduce the same error.

 

I've also attached the log. 

output_log__2020-05-06__15-02-37.txt

Share this post


Link to post
Share on other sites

Seems like your loading .50 of the zombiepack, and the fix is in .51    Please update that pack and retest on a new world.

Share this post


Link to post
Share on other sites

like @xyth said, you're using an old version - update '0-CreaturePackZombies' to the latest version (18.4.1.51) - that should help.

A new world may not be needed in that specific case ;)

Share this post


Link to post
Share on other sites

*Faceplam*. Why did I not check that beforehand.

After updating it seems to have fixed the error for that specific spot, so i'm assuming it's solved :).

 

Thank you guys for replying and the advice. 

Hopefully that is the last of that (and if not i'll probably be back again lol)

 

And keep up the good work guys, your work is appreciated!

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi Xyth,

Got this error with the latest DL of the Human pack.

 

2020-05-06T18:50:22 90.190 EXC Requested value 'BlockPenetrationFactor' was not found.
ArgumentException: Requested value 'BlockPenetrationFactor' was not found. 

 

This is the only instance I found.

 

        <item name="ammoNPCShotgunShell">

                <passive_effect name="BlockPenetrationFactor" operation="base_set" value="5"/>

 

I commented it out and the pack loaded. 

 

Thanks to you and all the contributors. 

Share this post


Link to post
Share on other sites

Installation

Just drop the mod into your Mods folder and have fun. They are not dependent on each other so load the ones you want. If your using a dedicated server, you also need to load this into your dedi server Mods folder.

 

Is this for single player only? I put in Mods folder on rented server, all i get are errors in the console, red lettering when i enter a region. Can't get out unless i use ctrl+alt+del - or am i missing something? This would be awesome...if this has been answered before, then sorry...thanks for the work and hopefully i get to see it...thanks again

Share this post


Link to post
Share on other sites

Will require both a server and a client install.

  • Thanks 1

Share this post


Link to post
Share on other sites

This is just ... amazing! This plus the compopack for more prefabs makes the game so much more interesting. There's some super creepy new zombies in there. Love them!

 

I had a couple NRE's pop up, but I'm having so much fun that I don't even care! Great job to everyone involved!

Share this post


Link to post
Share on other sites
Posted (edited)
17 minutes ago, Melen said:

This is just ... amazing! This plus the compopack for more prefabs makes the game so much more interesting. There's some super creepy new zombies in there. Love them!

 

I had a couple NRE's pop up, but I'm having so much fun that I don't even care! Great job to everyone involved!

You should report any NREs that may pop up though, Xyth was on the hunt for NREs, I believe.

Edited by mr.devolver (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

Can i ask does this mod touch any vanilla textures ? am using a mod called War3zuk Alpha 18.4 B4 AIO OverHaul, and when i play it some of the vanilla textures drop to very low quality EXP:

image.png.913e24f9710fae0e930064c028b714c6.png

but then some odd reason when i remove some of the files from this mod in that pack ie , 0-CreaturePackAnimals or the zombie Pack it all goes back to normal. Just wondering if there would be a reason why this might happen , and if you have any thoughts , thanks.

Edited by AdrianVaughan (see edit history)

Share this post


Link to post
Share on other sites

Running low on texture memory.  Turn texture streaming off in the video settings. 

Share this post


Link to post
Share on other sites
31 minutes ago, Guppycur said:

Running low on texture memory.  Turn texture streaming off in the video settings. 

You know what's funny? Texture streaming is what's supposed to prevent you from running low on texture memory. It seems like the feature could use some bugfixing...

Share this post


Link to post
Share on other sites
49 minutes ago, Guppycur said:

Running low on texture memory.  Turn texture streaming off in the video settings. 

Thanks very much, that worked.

Share this post


Link to post
Share on other sites
1 hour ago, mr.devolver said:

You know what's funny? Texture streaming is what's supposed to prevent you from running low on texture memory. It seems like the feature could use some bugfixing...

Yeh, but that would be logical.  We don't do logical in these here parts. :)

  • Like 2
  • Haha 1

Share this post


Link to post
Share on other sites

And no, this mod does not touch vanilla textures.

Share this post


Link to post
Share on other sites
18 hours ago, mr.devolver said:

You know what's funny? Texture streaming is what's supposed to prevent you from running low on texture memory. It seems like the feature could use some bugfixing...

Yeah when i play its got less then 200mb of my 8gb om my evga 2080.  

Share this post


Link to post
Share on other sites

Small issue: the baker trader fell into my death pit where I do horde nights and now I can't get him out and he is indestructible so I can't get rid of him. Is there a quick edit I can do to a cfg to make him vulnerable and wipe his crusty @%$*#! from my world?

Share this post


Link to post
Share on other sites

No idea on that one.  Likely there is a console command to remove it if you know the entityid number.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks for the response anyways. I was hoping since he is a trader something specific made him invulnerable.

 

While he is a pain he does stay in my pit and beat up on horde night zombies. Silver lining. :D

Edited by CynicalGamer (see edit history)

Share this post


Link to post
Share on other sites

What makes him invulnerable is the NPCID property that enables the trader functionality.  You could try backing up the game save then remove that property from the trader then you should be able to kill him, but it may 1.  corrupt the game save (hence the backup) and 2. will disable all other custom traders.  Once hes killed, put the property back and restart, but keep that backup savegame handy cause it might corrupt on restarting that version.

 

 

Share this post


Link to post
Share on other sites

Thank your very much for this awesome pack. When I use this mod on dedicated server + already existing world, everything works fine, new zombies roaming everywhere, but the radiated zombies are disappeared. Before I added the mod, they were pretty common all around (Gamestage 400+). Is it intentional, or it is because it's not a new world? It looks like the new zombie types somehow erased the possibility of radiated trait, and I miss them.

Share this post


Link to post
Share on other sites

It is not intentional.  We don't remove any vanilla zombies, so not sure whats going on in your case.

Share this post


Link to post
Share on other sites

really liking these packs but could you maybe add a non hostile harley? or more non hostile versions of bandits in general at least to the spawnmenu?

Share this post


Link to post
Share on other sites

The creature packs are intended to be a resource mod; one where you can adjust things easily to fit your needs.  If you want Harley to be a survivor rather than a bandit, you just need to make a small edit to the entityclasses.xml file. For example, BanditHarley has this line:         

 

<entity_class name="humanHarleyBandit" extends="humanMeleeMaleBanditTemplate">

To make Harley a survivor, you would change that line to:

<entity_class name="humanHarleyBandit" extends="humanMaleSurvivorTemplate">

 

Have fun.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...