Jump to content

Unable to Place Blocks


Recommended Posts

I am playing a single player game and trying to build a wall to protect an area that I will be building a base in. While digging out the area and placing blocks, I came upon a section that is 1 block wide x 3 blocks long x 2 blocks deep that I am not able to place any blocks in. I have dug out 2 blocks around and 3 blocks below the affected area and nothing. I have even used the highlight and clear selection commands and still I can't build in that spot. I have also restarted the game after completely shutting down steam and re-validating the files without success.

Any suggestions?

Link to comment
Share on other sites

It's a bug. Validation won't help.

Sometimes placing frames all around it and then removing them works.

Sometimes piling frames on top, then breaking out the support so that debris is formed in the bad spot, and finally clearing out the debris works.


Never tried it, but maybe making a container surrounding it and then filling with water might do something.

That's about all I can think of at the moment.


EDIT: BTW... which version are you running? Is it the latest experimental or the latest stable? I think this was fixed in the latest experimental, though I could be wrong.

Link to comment
Share on other sites

I will try the wood frames thing again.


I am running version A18.1 (b8)


EDIT: Well tried to do that with wood frames, dirt blocks, and topsoil blocks with no luck. The area only filled up a little and the glitch remained even after I cleared the fallen blocks.


Guess I will have to wait until they release the fix to stable, unless someone has another idea.


Thanks for the help though AtomicUs5000.

Link to comment
Share on other sites

I suppose it could be something else invisible.

Maybe one of those surface nodes with those few blocks of ore beneath them? Maybe it's invisible because random generation terrain smoothing forced the terrain above the top of the node.

That might explain why it's not falling like a tree when removing blocks. Though I would think that the ore should still fall.


I can't think of anything else it might be.

Link to comment
Share on other sites

Ya I tried the build up and remove blocks thing to try to fill it in and nothing.

I also dug out all around it, even using the debug clearing method and nothing.

Tried explosives and that didn't work either.

Didn't try water, but I can even though I am sure it will be the same result.


Really annoying that it is right where I need to place a part of my base defenses.


Is there a command that can let me copy/paste something there?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...