Jump to content

Archived

This topic is now archived and is closed to further replies.

Neph

Insane RAM usage in A18

Recommended Posts

I've been playing the game for years with the same PC (got a new gpu 2 years ago) and the same settings and everything was fine but A18 is basically unplayable for me.

 

My PC:

Win 7 (64bit)

GTX 1070 (8gb)

16gb RAM

 

Apart from the regular frame drops (which I can kind of live with), the RAM usage is insane since I installed A18! It used to be 6-7gb (if even that), now it uses 12gb - all the time. When I join a server, RAM usage goes up and it never decreases again. I go back to the main menu - still 12gb. When I try to log back into the server, 90% of the time the game just crashes. And not only that, the window's gone but the process still shows up in the task manager and it takes at least 5 minutes to finally close. If I force-close it, it might close within 2 minutes BUT just now it didn't:

 

I timed out on the server (no idea why), tried to log back in but the screen turned black with one of Unity's "fun" "Object reference not set to an instance of an object" errors. I tabbed out of the game, after 2 minutes it crashed but was still running in the background. I tried to force-close it but no luck this time... I waited 10 minutes, not able to do anything else because 7d2d was still hogging all of the RAM to itself (even the mouse cursor was lagging!) - in this time I tried to close the process 5 times but no luck. In the end I had to force a shut-down of my PC because I wasn't even able to open the start menu.

 

I'm not the only one with this problem: There are at least 3 other players on the server I'm playing on, 2 are using Win 10, 1 is using Win 7. We all have different gpus and use different graphics settings - I have my texture size set to "full", while others use "half" and one of them even "quarter". The only thing in common is that our game uses way more RAM than it should.

Share this post


Link to post
Share on other sites

Well, from your description it seems you also have the same server in common. Did you try out a local game or log in to a different server to see if the problem occurs there as well? Did you have to install a mod to play on the server? Was the server updated to a new version recently (without starting a new world) ?

 

Your client also generates a logfile, https://7daystodie.com/forums/showthread.php?37912-IMPORTANT-Please-Read-Before-Creating-New-Threads tells you how to find and upload this logfile. It might give valuable hints.

Share this post


Link to post
Share on other sites

It doesn't affect everyone on the server, other players' PCs only use 5-6gb of RAM.

I played on the same server before (A17) and everything was fine, the problem didn't appear until it updated to A18.

I haven't tried a local game or a different server but I'm going to.

I didn't install any mods but there are a couple of lightweight mods installed on the server (e.g. a UI one to show hunger and thirst) but the server used similar ones, if not the same ones, with A17 too.

There's been a reset with every new, big game version.

Going to check out the logfile, thanks.

 

One addition to the problem:

I left MSI Afterburner running yesterday and only around 6gb of VRAM (out of 8gb) were being used, so it's not even running out of VRAM and using RAM instead. I am getting the suspicion though that it's using the HDD to make up for the missing RAM because the system's still really slow, even after the 72d2 exe is closed - like it would be if huge amounts of data were being copied around.

 

I just spoke to someone else: Their game uses 13.2gb out of 16.

 

 

Edit:

I just tried to create a SP map. The game crashed at:

WorldGenerator:Exporting Generated Data: Writing Roadmap to SplatMap3 33%

It doesn't say anything else after that.

Share this post


Link to post
Share on other sites

According to Steam system requirements, this game is supposed to only use up to 4GB of vram (which recently changed from 2gb). So it looks like you have more problems than just 1 memory issue.

Share this post


Link to post
Share on other sites

Check your swapfile (virtual memory) settings, set it to "system managed" on

a disk that has some room to spare.

Share this post


Link to post
Share on other sites
I left MSI Afterburner running yesterday and only around 6gb of VRAM (out of 8gb) were being used...

 

Monitor your "Fan Tachometer" and "GPU Temperature" with MSI Afterburner. When temp hits 60+ (celsius) the fan should kick on, lowering or stabilizing the temp, and you should see the tachometer getting RPMs. If the fan is failing, temp will continue to climb and the card gets auto-throttled, dropping fps regardless of VRAM usage.

 

This happened to me recently with NO other indicators that my GPU fan was failing. No weird fan noises or popping capacitors, no artifacting, no ozone smells of burning plastic components, just a video card at 83% VRAM usage getting slower and slower as I played (temp auto-throttling). GPU-Z showed why under "PerfCap Reason" and userbenchmark.com test showed the GPU performing well below average, compared to others with the same exact hardware. Here are links to what I used:

 

https://www.userbenchmark.com/Software

https://www.techpowerup.com/gpuz

Share this post


Link to post
Share on other sites

As you have 8gb of vram turn off texture streaming it's not needed that might help.

If it's on it'll load a lot of stuff into RAM and it doesn't need to.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...