Jump to content
MrJim

Could this be modded?

Recommended Posts

I'm really enjoying A18, but I have experienced one major problem with the game-play. In all alphas prior to A18, it was possible to 'aim down sight' (ADS) with a weapon, whilst still running. Doing so would drastically slow your movement speed, but nonetheless, it was possible. In A18 however, you simply can't do this; you can no longer ADS and run simultaneously. Now, for most people that isn't an issue, but I happen to be physically disabled, & use a 'mouthstick' to access a trackball & keyboard with which to play 7D2D. I tend to toggle run on permanently, and just deal with the stamina issues. Sadly, with A18 as it stands, I now have to toggle run on, then when I want to ADS I have to toggle run off, ADS, aim & shoot, and toggle run back on again. Which adds a whole new level of difficulty for me when playing the game!

 

So, as the title of this post says, could A18 be modded so as to go back to the how things were in previous alphas? I love everything about A18, except this one rather irritating change!

Share this post


Link to post
Share on other sites
I'm really enjoying A18, but I have experienced one major problem with the game-play. In all alphas prior to A18, it was possible to 'aim down sight' (ADS) with a weapon, whilst still running. Doing so would drastically slow your movement speed, but nonetheless, it was possible. In A18 however, you simply can't do this; you can no longer ADS and run simultaneously. Now, for most people that isn't an issue, but I happen to be physically disabled, & use a 'mouthstick' to access a trackball & keyboard with which to play 7D2D. I tend to toggle run on permanently, and just deal with the stamina issues. Sadly, with A18 as it stands, I now have to toggle run on, then when I want to ADS I have to toggle run off, ADS, aim & shoot, and toggle run back on again. Which adds a whole new level of difficulty for me when playing the game!

 

So, as the title of this post says, could A18 be modded so as to go back to the how things were in previous alphas? I love everything about A18, except this one rather irritating change!

 

I imagine it could be done, depends if its a baked feature or in the XML code.

Ill have a boo at it right now and see if I can find something.

Share this post


Link to post
Share on other sites

@MrJim-

I took a look for the cause in the xmls for you but don't see it. Aiming a gun causes your stamina to decrease but I don't see anything linking it to mobility in the xml's. Might be in the dll. Sorry cant help more

Share this post


Link to post
Share on other sites

I asked the question in Guppycur's modding discord to get the information , and as Spider suspected this only be done via SDX / DMT patch script.

 

 

So a fix can be done for this to help you out , seems a few others want this fix too ... so stay tuned as HAL9000 is on the case and has offered to do the fix script .

 

 

Ragsy!!

Share this post


Link to post
Share on other sites

Hi MrJim,

 

To get this modded in you'll need to grab a copy of DMT if you don't already have it.

 

Once that's on your system and set up grab a copy of this: HalsRunAndGun and extract it into the folder you set for your mods in DMT.

 

Then open DMT again and click build.

 

If everything goes well you should see a "Build completed" message in DMT and you can click the Play button to start the game.

 

If you don't get that message post what you get here and we'll have a look.

 

Cheers,

 

Hal

Edited by HAL9000 (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites
Hi MrJim,

 

To get this modded in you'll need to grab a copy of DMT if you don't already have it.

 

Once that's on your system and set up grab a copy of this: HalsRunAndGun and extract it into the folder you set for your mods in DMT.

 

Then open DMT again and click build.

 

If everything goes well you should see a "Build completed" message in DMT and you can click the Play button to start the game.

 

If you don't get that message post what you get here and we'll have a look.

 

Cheers,

 

Hal

 

Wow, thank you so much for this! I'll download DMT and HalsRunAndGun, and see if I can get it running! Many, many thanks for all your efforts!

Share this post


Link to post
Share on other sites

No worries, just post here if you have any problems or want any tweaks to the mod.

 

Cheers,

 

Hal

Share this post


Link to post
Share on other sites
No worries, just post here if you have any problems or want any tweaks to the mod.

 

Cheers,

 

Hal

 

Unfortunately I've run into a few problems. I installed DMT as described, and put 'HalsRunAndGun' into a folder called 'Mods'. I entered all the info into DMTViewer, hit the build button, and then ran the game. Once I got to the game menu, the console popped up, with a few red lines that I assume are error messages. You con see them here:

 

503604559_Consoleerrormessage.thumb.jpg.edc10fa9b9ff2b2344dbce746ff144a9.jpg

 

If I try to continue a game, the game loads, but the mouse doesn't work, & I can't get back to the game menu either. I had to Alt-tab back to the desktop and close the game from Task Manager. Do you have any advise as to where I'm going wrong? Thanks in advance.

Share this post


Link to post
Share on other sites

Scratch that - I got it working! I had put DMT into its own folder, rather than in with the 7D2D executable. I still got a line or two in red in the console, but the RunAndGun mod is working perfectly - thank you once again!

Share this post


Link to post
Share on other sites
Scratch that - I got it working! I had put DMT into its own folder, rather than in with the 7D2D executable. I still got a line or two in red in the console, but the RunAndGun mod is working perfectly - thank you once again!

 

Hi MrJim,

 

Yep they need to go in separate folders, you may need to reset your 7 days install in steam and regen the mod in DMT to get rid of the red errors. It looks like there may be a random dll trying to get loaded by the game. Glad you got it working.

 

Cheers,

 

Hal

Share this post


Link to post
Share on other sites
Hi MrJim,

 

Yep they need to go in separate folders, you may need to reset your 7 days install in steam and regen the mod in DMT to get rid of the red errors. It looks like there may be a random dll trying to get loaded by the game. Glad you got it working.

 

Cheers,

 

Hal

 

Hi Hal - So I've been playing 7D2D with your run & gun modlet without any problems, except until today, when it was horde night. I don't know whether this is because of your modlet, but for some reason, the zombies spawned in, but didn't move at all...they just stood still & ignored me! Just out of curiosity, I went into diagnostic mode & spawned in another group of 25 zombies, and they did the same thing! Could this be due to the modlet?!

Share this post


Link to post
Share on other sites
Hi Hal - So I've been playing 7D2D with your run & gun modlet without any problems, except until today, when it was horde night. I don't know whether this is because of your modlet, but for some reason, the zombies spawned in, but didn't move at all...they just stood still & ignored me! Just out of curiosity, I went into diagnostic mode & spawned in another group of 25 zombies, and they did the same thing! Could this be due to the modlet?!

 

Hi MrJim,

 

I don't think so, or at least I can't reproduce it. Did you get rid of those red errors when starting the game? It could be that is preventing some config from being loaded during the game startup.

 

Try with a refresh copy of 7 days (delete the whole folder if you need to) and re-apply the mod. A copy of your log file would also help point to the issue. You can usually find that in your AppData folder (in "LocalLow\The Fun Pimps\7 Days To Die" I think)

 

Cheers,

 

Hal

Share this post


Link to post
Share on other sites
Hi MrJim,

 

I don't think so, or at least I can't reproduce it. Did you get rid of those red errors when starting the game? It could be that is preventing some config from being loaded during the game startup.

 

Try with a refresh copy of 7 days (delete the whole folder if you need to) and re-apply the mod. A copy of your log file would also help point to the issue. You can usually find that in your AppData folder (in "LocalLow\The Fun Pimps\7 Days To Die" I think)

 

Cheers,

 

Hal

 

Thanks Hal. So I uninstalled 7D2D, deleted the folders & reinstalled the game, DMT & the Run and Gun mod. I changed the time & date in the console to the next Horde night, and had the same problem as before - zombies spawn in, but just stand there & ignore me. I am still getting some red entries in the console when starting the game too. Here's my Player.log (edited to remove my IP address)...

 

[ATTACH]30573[/ATTACH]

Player.log.txt

Share this post


Link to post
Share on other sites

Any chance you have 2 copies of Hals Modlet in your Mods folder?

 

2019-11-15T13:46:14 8.947 INF [MODS] Start loading

2019-11-15T13:46:14 8.949 INF [MODS] Trying to load from HalRunAndGun

2019-11-15T13:46:14 8.949 WRN [MODS] Folder HalRunAndGun does not contain a ModInfo.xml, ignoring

2019-11-15T13:46:14 8.949 WRN [MODS] Failed loading mod from HalRunAndGun

2019-11-15T13:46:14 8.949 INF [MODS] Trying to load from Hal's Run and Gun

2019-11-15T13:46:14 8.981 INF [MODS] Loaded Mod: Hal's Run and Gun (1.0)

2019-11-15T13:46:14 8.981 INF [MODS] Initializing mod code

2019-11-15T13:46:14 8.981 INF [MODS] Loading done

Share this post


Link to post
Share on other sites
Any chance you have 2 copies of Hals Modlet in your Mods folder?

 

2019-11-15T13:46:14 8.947 INF [MODS] Start loading

2019-11-15T13:46:14 8.949 INF [MODS] Trying to load from HalRunAndGun

2019-11-15T13:46:14 8.949 WRN [MODS] Folder HalRunAndGun does not contain a ModInfo.xml, ignoring

2019-11-15T13:46:14 8.949 WRN [MODS] Failed loading mod from HalRunAndGun

2019-11-15T13:46:14 8.949 INF [MODS] Trying to load from Hal's Run and Gun

2019-11-15T13:46:14 8.981 INF [MODS] Loaded Mod: Hal's Run and Gun (1.0)

2019-11-15T13:46:14 8.981 INF [MODS] Initializing mod code

2019-11-15T13:46:14 8.981 INF [MODS] Loading done

 

Well that's very odd - yes, there are now two subfolders in the MODS folder, although I only copied one folder in there! The two folders are "HalRunAndGun" and "Hal's Run and Gun" (without the quotes). I'm not sure how that happened? Should I delete one?

Share this post


Link to post
Share on other sites
Well that's very odd - yes, there are now two subfolders in the MODS folder, although I only copied one folder in there! The two folders are "HalRunAndGun" and "Hal's Run and Gun" (without the quotes). I'm not sure how that happened? Should I delete one?

 

Ah, I think you're using the in-game Mods folder for the DMT location but that's where the information gets copied to when installing the mods through DMT.

 

Try them in separate areas. I usually put DMT and the mods in a separate folder e.g.

 

C:\Games\DMT\DMTViewer.exe

and

C:\Games\DMTModLibrary\ <--all the mods I download go in here

 

With the game folder pointed at

 

C:\Games\7DTD\

 

 

Looking at your log I can see there's another problem with a DLL loading exception

 

ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.
 at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
 at System.Reflection.Assembly.GetTypes () [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0 
 at Pathfinding.AstarData.FindGraphTypes () [0x00015] in <a973c9e76b9448d290cc8c9c84773925>:0 
 at AstarPath.InitializeAstarData () [0x00000] in <a973c9e76b9448d290cc8c9c84773925>:0 
 at AstarPath.Awake () [0x00066] in <a973c9e76b9448d290cc8c9c84773925>:0 
UnityEngine.Object:Internal_InstantiateSingle_Injected(Object, Vector3&, Quaternion&)
UnityEngine.Object:Internal_InstantiateSingle(Object, Vector3, Quaternion)

 

AStarPath is the pathing code the game uses for the zombies so having an error here is probably why they're just staring at you now.

 

Now even if I try having two copies of the mod in the game's mod folder I still don't get that error when loading the game up so try again with DMT and the mods outside the game folder (don't forget to completely delete the game folder so any errant files get deleted too). If that doesn't work I'll do a quick video showing how I'm installing it.

 

Cheers,

 

Hal

Share this post


Link to post
Share on other sites
Ah, I think you're using the in-game Mods folder for the DMT location but that's where the information gets copied to when installing the mods through DMT.

 

Try them in separate areas. I usually put DMT and the mods in a separate folder e.g.

 

C:\Games\DMT\DMTViewer.exe

and

C:\Games\DMTModLibrary\ <--all the mods I download go in here

 

With the game folder pointed at

 

C:\Games\7DTD\

 

 

Looking at your log I can see there's another problem with a DLL loading exception

 

ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.
 at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
 at System.Reflection.Assembly.GetTypes () [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0 
 at Pathfinding.AstarData.FindGraphTypes () [0x00015] in <a973c9e76b9448d290cc8c9c84773925>:0 
 at AstarPath.InitializeAstarData () [0x00000] in <a973c9e76b9448d290cc8c9c84773925>:0 
 at AstarPath.Awake () [0x00066] in <a973c9e76b9448d290cc8c9c84773925>:0 
UnityEngine.Object:Internal_InstantiateSingle_Injected(Object, Vector3&, Quaternion&)
UnityEngine.Object:Internal_InstantiateSingle(Object, Vector3, Quaternion)

 

AStarPath is the pathing code the game uses for the zombies so having an error here is probably why they're just staring at you now.

 

Now even if I try having two copies of the mod in the game's mod folder I still don't get that error when loading the game up so try again with DMT and the mods outside the game folder (don't forget to completely delete the game folder so any errant files get deleted too). If that doesn't work I'll do a quick video showing how I'm installing it.

 

Cheers,

 

Hal

 

You're a genius! That fixed it - no console error messages at all this time too. Yeah, I'd installed DMT and the Mod itself in subfolders under the 7 Days to Die folder. Putting them in a different folder fixed it straight away. Thank you SO much for taking the time & trouble to not only write the Mod, but to troubleshoot it with me as well. You're really very kind, cheers!

Share this post


Link to post
Share on other sites

To Hal and others who helped MrJim....Respect! That was really kind of you all to fix his problem. Need a lot more of this in our society.

Share this post


Link to post
Share on other sites
You're a genius! That fixed it - no console error messages at all this time too. Yeah, I'd installed DMT and the Mod itself in subfolders under the 7 Days to Die folder. Putting them in a different folder fixed it straight away. Thank you SO much for taking the time & trouble to not only write the Mod, but to troubleshoot it with me as well. You're really very kind, cheers!

 

No worries MrJim, glad you're back playing, happy hunting :)

 

Cheers,

 

Hal

Share this post


Link to post
Share on other sites
On 11/15/2019 at 10:50 PM, HAL9000 said:

 

No worries MrJim, glad you're back playing, happy hunting :)

 

Cheers,

 

Hal

Hi Hal, sorry to resurrect this thread.  I've been using your 'Run & Gun' mod very successfully for ages now, both in A18 and A19.  Unfortunately, the most recent update to A19 (A19 B-178) seems to have broken it.  The mod compiles without errors in 'DMTviewer.exe' but when I attempt to load 7D2D, the game hangs at the 'Loading game data' stage of the process.  Is there any possibility you could take a look at the problem & see if there's a work-around, by any chance?  I'm missing A19 already!  Many thanks in advance!

Share this post


Link to post
Share on other sites

Hi MrJim, 

 

I updated a bunch of mods the other week, I can't remember if this one needed any updates but give this latest build a go. I've used it on the latest experimental release and seems to run ok. 

 

https://github.com/HAL-NINE-THOUSAND/HalRunAndGun/releases/download/a19/HalRunAndGunA19.zip

 

With A19 you'll need to make sure you're running the latest version of DMT (it should be DMT v2 now) 

 

https://github.com/HAL-NINE-THOUSAND/DMT/releases/download/v2.0/DMTv2.0.7486.30873.zip

 

If you're still having trouble post your logs and I'll have a look.

 

Cheers,

 

Hal

 

 

 

Share this post


Link to post
Share on other sites
On 8/10/2020 at 2:31 PM, HAL9000 said:

Hi MrJim, 

 

I updated a bunch of mods the other week, I can't remember if this one needed any updates but give this latest build a go. I've used it on the latest experimental release and seems to run ok. 

 

https://github.com/HAL-NINE-THOUSAND/HalRunAndGun/releases/download/a19/HalRunAndGunA19.zip

 

With A19 you'll need to make sure you're running the latest version of DMT (it should be DMT v2 now) 

 

https://github.com/HAL-NINE-THOUSAND/DMT/releases/download/v2.0/DMTv2.0.7486.30873.zip

 

If you're still having trouble post your logs and I'll have a look.

 

Cheers,

 

Hal

 

 

 

Hi Hal, good to hear from you.  I took your advice & installed DMT 2 along with your 'Run & Gun' mod from the links you provided.  The mod complied without errors & I was able to get into the game at least, but unfortunately the mod didn't appear to work; I still wasn't able to run and aim-down sight at the same time.

Share this post


Link to post
Share on other sites
35 minutes ago, MrJim said:

Hi Hal, good to hear from you.  I took your advice & installed DMT 2 along with your 'Run & Gun' mod from the links you provided.  The mod complied without errors & I was able to get into the game at least, but unfortunately the mod didn't appear to work; I still wasn't able to run and aim-down sight at the same time.

Can you post your player log file from the game and the build log from DMT? That should give us the information to debug what's going wrong

Share this post


Link to post
Share on other sites
50 minutes ago, HAL9000 said:

Can you post your player log file from the game and the build log from DMT? That should give us the information to debug what's going wrong

Sorry Hal, I can't seem to find the player log file - it's supposed to be a txt file in the '7DaysToDie_Data' folder, isn't it?  There's no sign of a txt file in that location, unfortunately.

 

Is the build log for DMT just the text in the right pane from DMT?  Here's that text:

 

Parsing arguments
Running BackupFiles
Backup dll found: H:\SteamLibrary\steamapps\common\7D2D Mods\DMT/Backups/SP/19.0b178/Assembly-CSharp.dll
Running DeployDlls
Deploying DLLs
Running LocalisationPatch
Localisation no longer handled in DMT after A17
Running InitialPatchTask
No patch scripts found...
Hooking harmony
Hooking console commands
Running CreateModDll
Compiling Mods.dll...
Built in 456ms
Mods.dll compile successful

Parsing arguments
Running LinkedPatchTask
No patch scripts found...
Link patching 0 files

Parsing arguments
Running FinalPatchTask
No patch scripts found...
Final patching 0 files
Running CreateHarmonyDlls
Compiling Harmony mod for Hal's Run and Gun...
Running CopyModFolders
Copying mod folders
Copy from H:\SteamLibrary\steamapps\common\7D2D Mods\DMTModLibrary/HalRunAndGun/
Copying H:\SteamLibrary\steamapps\common\7D2D Mods\DMTModLibrary/HalRunAndGun//ModInfo.xml
Deleting asset H:\SteamLibrary\steamapps\common\7 Days To Die//Mods/Hal's Run and Gun/Harmony\Harmony-Hal's Run and Gun.dll
Deleting asset H:\SteamLibrary\steamapps\common\7 Days To Die//Mods/Hal's Run and Gun/Harmony\Harmony-Hal's Run and Gun.pdb
Deleting asset H:\SteamLibrary\steamapps\common\7 Days To Die//Mods/Hal's Run and Gun/Harmony\HarmonyManager.cs
Deleting asset H:\SteamLibrary\steamapps\common\7 Days To Die//Mods/Hal's Run and Gun/Harmony\RunAndGunTranspiler.cs
Copying H:\SteamLibrary\steamapps\common\7 Days To Die//Mods/Hal's Run and Gun/Harmony/Harmony-Hal's Run and Gun.dll
Copying H:\SteamLibrary\steamapps\common\7 Days To Die//Mods/Hal's Run and Gun/Harmony/Harmony-Hal's Run and Gun.pdb
Copying H:\SteamLibrary\steamapps\common\7 Days To Die//Mods/Hal's Run and Gun/Harmony/HarmonyManager.cs
Copying H:\SteamLibrary\steamapps\common\7 Days To Die//Mods/Hal's Run and Gun/Harmony/RunAndGunTranspiler.cs
16:02:31: Build completed in 3.37 seconds

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...