Jump to content
Cody3413

PLEASE HELP! "IndexOutOfRangeException: Index Was Outside The Bounds Of Array"

Recommended Posts

TEMP WORK AROUND

 

Hey survivors! If anyone gets this bug now until a patch goes out, please try the following.

 

 

- Schwanz9000

 

 

 

 

I was playing Alpha 18 and i was rotating a block when "IndexOutOfRangeException: Index Was Outside The Bounds Of Array" popped up at the top of the screen, and it just keeps repeating. It will not let me move or escape or anything ive tried everything even unistalling and reinstalling.

Edited by schwanz9000 (see edit history)

Share this post


Link to post
Share on other sites

game kind of stuck after I use copy shape on concrete

 

game just stuck at this screen already try everything that I can do and rice

[ATTACH=CONFIG]30447[/ATTACH][ATTACH=CONFIG]30448[/ATTACH]

hop this can be fix:smile-new:

Share this post


Link to post
Share on other sites
I was playing Alpha 18 and i was rotating a block when "IndexOutOfRangeException: Index Was Outside The Bounds Of Array" popped up at the top of the screen, and it just keeps repeating. It will not let me move or escape or anything ive tried everything even unistalling and reinstalling.

 

1194598177_7daystodieerror.jpg.dd516739c4f40594ea9d37ab8f4c175f.jpg

Share this post


Link to post
Share on other sites

This same thing happened to me when I tried to copy shape and I think it ended up hitting a block that was a terrain block. My character has become completely unusable and I had to delete it from the server to be able to log back on again. So now I get to try to guess what all perk books I had to give them to myself again to get back to where I was :(. I think if I had a way to just delete the block from my inventory it would work fine but I don't know of a character editor that works in A18.

 

Edit: I was using the flagstone helper block at the time.

Edited by Backslash2099 (see edit history)

Share this post


Link to post
Share on other sites

Same thing happened to me, was using wood frame and was trying to copy shape. Is there any way to fix this without deleting character from server and starting over? I tried killing myself and I'm still stuck alive but my bag is on the ground. If someone attempts to open my bag they get a null error too and can't open containers till the relog.

 

IndexOutOfRangeException: Index was outside the bounds of the array.
 at Block.GetAltBlockValue (System.Int32 typeID) [0x00011] in <48a082dfa81b446482fba2e9368723b2>:0 
 at ItemClassBlock.GetBlockValueFromItemValue (ItemValue _itemValue) [0x00013] in <48a082dfa81b446482fba2e9368723b2>:0 
 at ItemClassBlock.CloneModel (World _world, ItemValue _itemValue, UnityEngine.Vector3 _position, UnityEngine.Transform _parent, System.Boolean _bUseDropModel, System.Boolean _bUseHandModel, System.Int64 _textureFull) [0x00000] in <48a082dfa81b446482fba2e9368723b2>:0 
 at Inventory.createHeldItem (System.Int32 _idx, ItemValue _itemValue) [0x0001d] in <48a082dfa81b446482fba2e9368723b2>:0 
 at Inventory.ForceHoldingItemUpdate () [0x0006a] in <48a082dfa81b446482fba2e9368723b2>:0 
 at EModelBase.SwitchModelAndView (System.Boolean _bFPV, System.Boolean _bMale) [0x002bc] in <48a082dfa81b446482fba2e9368723b2>:0 
 at EModelUMA.onCharacterCreated (UMA.UMAData _umaData) [0x00098] in <48a082dfa81b446482fba2e9368723b2>:0 
 at UnityEngine.Events.InvokableCall`1[T1].Invoke (T1 args0) [0x00011] in <316842062a1e4ad6b2fee7b9fe26257b>:0 
 at UnityEngine.Events.UnityEvent`1[T0].Invoke (T0 arg0) [0x00023] in <316842062a1e4ad6b2fee7b9fe26257b>:0 
 at UMA.UMAData.FireUpdatedEvent (System.Boolean cancelled) [0x00026] in <873538336fa34b18be73e356dab2552c>:0 
 at UMA.UMAGeneratorBuiltin.UMAReady () [0x0007f] in <873538336fa34b18be73e356dab2552c>:0 
 at UMA.UMAGeneratorBuiltin.HandleDirtyUpdate (UMA.UMAData data) [0x00156] in <873538336fa34b18be73e356dab2552c>:0 
 at UMA.UMAGeneratorBuiltin.OnDirtyUpdate () [0x0003d] in <873538336fa34b18be73e356dab2552c>:0 
 at UMA.UMAGeneratorBuiltin.Update () [0x00050] in <873538336fa34b18be73e356dab2552c>:0 

(Filename: <48a082dfa81b446482fba2e9368723b2> Line: 0)

Edited by grukdon (see edit history)

Share this post


Link to post
Share on other sites
What shape?

 

I forget tbh, but I'm pretty sure it was a ramp I was trying to copy. It even may have been copy rotation, rather than copy block, now that I think of it. I just ended up deleting my character file from the server and starting over. :upset:

Share this post


Link to post
Share on other sites

I have encountered the same error and I was using bullet proof glass and when I hovered over concrete and held 'R' to open the context menu I choose "Copy Shape" and now my game is destroyed.

 

EDIT: Okay so, I just tested this just now and was able to reproduce the bug in a new game. 18.2 (b2)

It happened when I was using a bullet proof glass block, I place one down, I have my mouse pointer hovered over the bullet proof glass and then when I hold "R" I am able move my mouse away from the bullet proof glass and point it at something else because there is a slight delay to when the radial context menu pops up and I choose "copy shape" and that is when I get the "IndexOutOfRangeException: Index Was Outside The Bounds Of Array" error.

 

p.s I used creative menu.

Edited by mo'guts (see edit history)

Share this post


Link to post
Share on other sites

THANK YOU mo'guts!!! Was finally able to get this. It happens if you are moving too fast and the radial menu is off the block you're trying to copy. I'll get this reported.

Share this post


Link to post
Share on other sites

Awesome, thanks mo'guts for taking the time to figure it out. I've been afraid to use the copy block ever since.

 

And a thank you to schwanz9000 for the video with a workaround, now I don't have to fear copy rotation !!!

Share this post


Link to post
Share on other sites

TEMP WORK AROUND

 

Hey survivors! If anyone gets this bug now until a patch goes out, please try the following.

 

 

- Schwanz9000

 

 

 

Hey, i was super happy to found this video explaining how to fix the bug. but i have a problem, i follow every step as in the video but every time i restart the game after using kill 171 the character loads into the game with the same error.

 

the bugged block is a stag of flag stone blocks, i try to drag them out of inventory, scrap or drop but everytime i reload the game im back where i started. is there anyone who knows how to fix this, i have so many hours in that restarting is not really a option. thanks.

Share this post


Link to post
Share on other sites
Hey, i was super happy to found this video explaining how to fix the bug. but i have a problem, i follow every step as in the video but every time i restart the game after using kill 171 the character loads into the game with the same error.

 

the bugged block is a stag of flag stone blocks, i try to drag them out of inventory, scrap or drop but everytime i reload the game im back where i started. is there anyone who knows how to fix this, i have so many hours in that restarting is not really a option. thanks.

 

the problem was i didnt drop all the items on death, as i changed the option drop nothing on death :miserable:

Share this post


Link to post
Share on other sites

I Get this error    IndexOutOfRangeException: Index was outside the bounds of the array.

from connection manager 

 

 

First I get this spamed a bit ...

 

NullReferenceException: Object reference not set to an instance of an object
  at (wrapper dynamic-method) EntityAlive.Update_Patch1(object)
 
(Filename:  Line: -1)

 

Then the game stopping spam of this

 

IndexOutOfRangeException: Index was outside the bounds of the array.
  at Inventory.GetItemActionInSlot (System.Int32 _slotIdx, System.Int32 _actionIdx) [0x00017] in <3ca2702590144b2c95bd610195728952>:0 
  at GameManager.ItemActionEffectsClient (System.Int32 _entityId, System.Int32 _slotIdx, System.Int32 _itemActionIdx, System.Int32 _firingState, UnityEngine.Vector3 _startPos, UnityEngine.Vector3 _direction, System.Int32 _userData) [0x00025] in <3ca2702590144b2c95bd610195728952>:0 
  at NetPackageItemActionEffects.ProcessPackage (World _world, INetConnectionCallbacks _netConnectionCallback) [0x00048] in <3ca2702590144b2c95bd610195728952>:0 
  at ConnectionManager.ProcessPackages (INetConnection _connection, NetPackageDirection _disallowedDirection) [0x000b2] in <3ca2702590144b2c95bd610195728952>:0 
  at ConnectionManager.Update () [0x00125] in <3ca2702590144b2c95bd610195728952>:0 
 
(Filename: <3ca2702590144b2c95bd610195728952> Line: 0)

IndexOutOfRangeException: Index was outside the bounds of the array.
  at Inventory.GetItemActionInSlot (System.Int32 _slotIdx, System.Int32 _actionIdx) [0x00017] in <3ca2702590144b2c95bd610195728952>:0 
  at GameManager.ItemActionEffectsClient (System.Int32 _entityId, System.Int32 _slotIdx, System.Int32 _itemActionIdx, System.Int32 _firingState, UnityEngine.Vector3 _startPos, UnityEngine.Vector3 _direction, System.Int32 _userData) [0x00025] in <3ca2702590144b2c95bd610195728952>:0 
  at NetPackageItemActionEffects.ProcessPackage (World _world, INetConnectionCallbacks _netConnectionCallback) [0x00048] in <3ca2702590144b2c95bd610195728952>:0 
  at ConnectionManager.ProcessPackages (INetConnection _connection, NetPackageDirection _disallowedDirection) [0x000b2] in <3ca2702590144b2c95bd610195728952>:0 
  at ConnectionManager.Update () [0x00125] in <3ca2702590144b2c95bd610195728952>:0 
 
(Filename: <3ca2702590144b2c95bd610195728952> Line: 0)

 

 

This is with the Darkess fall mod installed 

output_log.txt

Share this post


Link to post
Share on other sites

I am getting an index out of range when i launch the mod. I get to initializing world then launcher freezes. If i delete and reinstall the mod the game will launch once the i get the same error

 

1785854835_Annotation2020-05-26172230.thumb.png.03a588f82c213a68632cb0de4434f978.png

Share this post


Link to post
Share on other sites
46 minutes ago, DocRamse said:

I am getting an index out of range when i launch the mod. I get to initializing world then launcher freezes. If i delete and reinstall the mod the game will launch once the i get the same error

 

1785854835_Annotation2020-05-26172230.thumb.png.03a588f82c213a68632cb0de4434f978.png

Please read the Sticky thread first, then start a new thread. Don't raise the dead.
 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...