Jump to content

Unable to locate a running instance of Steam


Recommended Posts

I updated my dedicated server (running on linux) from alpha 17.4 to 18.1 (b2) but when I start the server the log reports:


[steamworks.NET] Could not initialize Server


and the command line reports back:


[s_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.

dlopen failed trying to load:


with error:

steamclient.so: cannot open shared object file: No such file or directory

[s_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.



Looking around the net this error seems to indicate that the wrong version (usually 32bit) of steamclient.so is being used. I assume it's looking at the steamclient.so that's in the 7d2d_server install directory. I've tried pointing that file to every instance of serverclient.so within the Steam directory I can find with no success. I've even tried a fresh install of both steamcmd and 7d2d with no luck.


I didn't have this issue with a17, any ideas where I should look to troubleshoot this?

Link to comment
Share on other sites

Thanks! That helped immensely.


It was looking for the file in a few directories under the /lib folder. I linked the 64bit steamclient.so under the plugins directory to one of those directories and the server started! It still gives me a "SteamAPI_Init() failed" error but it starts and I can connect to it :).


I'm still curious what changed between a17 and a18 that caused this.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...