Jump to content
psouza4

MeanCloud's Mining modlet (A18) with copper, zinc, and excavators

Recommended Posts

Hi,

 

Installed your mod... sounds great. In my already running world, the ore spawned on the land as boulder, and in stash. On the forge, I see the 3rd Input with Zinc and Copper. But when I place the ore, it don't work. Even more, only the 1st slot of my forge is working. 2nd and 3rd do nothing. even for other input. If I put inputs in 1st, it work except for Zinc and Copper which I see a count down but nothing store... I've put pref in the data/prefab and everything :(

 

What am I doing wrong?

Share this post


Link to post
Share on other sites

Great mod, thanks for sharing :)

I love mods that add more ores to the game. I would love to see more different types of ore for mining, so I wonder if you plan to make more ore for mining mods?

What about cobalt to make batteries, nickel to make "stainless steel blocks/reinforced steel", aluminium to make better vehicle parts, tungsten for even harder blocks :D

 

Share this post


Link to post
Share on other sites

Anyone run this alongside with Darkness Falls? Any issues? It seems ok but wanted to check.

Share this post


Link to post
Share on other sites
9 hours ago, AngryFire said:

Anyone run this alongside with Darkness Falls? Any issues? It seems ok but wanted to check.

I just did a quick test, It seem to work, also forges worked. I know Darkness falls use content based on mods that author say is in conflict with this mod but it seem to work ok.
Both copper and zinc melted ok, but you need to change required forge tool since it ask for a tool in basic forge that is not in DF. About excavators I have no idea since I dont tested them but I saw error messages about loot containers I think.

Share this post


Link to post
Share on other sites
7 hours ago, xxx73 said:

I just did a quick test, It seem to work, also forges worked. I know Darkness falls use content based on mods that author say is in conflict with this mod but it seem to work ok.
Both copper and zinc melted ok, but you need to change required forge tool since it ask for a tool in basic forge that is not in DF. About excavators I have no idea since I dont tested them but I saw error messages about loot containers I think.

Thanks for the response!

I did play with it a bit in DF. Excavators did seem to work ok, they were pulling in resources. I did see several errors regarding unable to patch bioms.xml with this mods changes (DF alters this file, likely why) but I am not sure of the consequences (errors were due to first 3 groups of your bioms.xml). I was only able to find copper doing test mining, no zinc. But it seems to work from what I can tell.

Share this post


Link to post
Share on other sites
Posted (edited)
Quote

2020-05-28T09:50:20 219.231 WRN XML patch for "biomes.xml" from mod "MeanCloud's Mining for A18.1+" did not apply: <set xpath="/worldgeneration/biomes/biome[@name='snow']/subbiome[@prob='0.292']/@prob" 

I get one of these for each of the biomes. The ore is in game, though. Are these anything to concern myself with?

BTW, thank you for the mod. 

Edit: could be conflict with Punishing Weather by Doughphungus. They both alter the same line in biomes.xml

Edit: it's not from Punishing Weather. I pulled it and started a new game. Still get warnings.

Edited by scm1893
new info (see edit history)

Share this post


Link to post
Share on other sites

Made an account just to post here.  Would it be possible to get an update for A19?  I haven't bee able to find anything else like this for it.  

 

Much love from New Zealand! 

Share this post


Link to post
Share on other sites
Posted (edited)

Really enjoyed this on a18, keen for an a19 update! I know its still experimental, so I understand if you want to wait for the stable release to update. In the mean time, could you possibly give some support in troubleshooting the mod as is? I am comfortable making XML edits and am extremely keen to get this working! I added brass to drop from normal stone ore for now, but I really enjoyed the copper/zinc mix realism and balance your mod provided.

 

The mod still works, but biomes.xml has a few paths that need updating, I think. The excavators and rock crushers still work, and copper and zinc can still be found throughout the world, but the blocks.xml has broken the sinks and they wont drop brass when harvested now (i think, not entirely certain on this as I only tried it once and could be mistaken).

 

Let me know if youre willing to provide some pointers on what to change and I should be able to work out the rest! Can PM you logs and what not. Running dedicated server but can test on SP as well. Have 3 different systems that can test, running 5 different instances of OS lol. 3 x windows, 1 x mac and 1 x linux ubuntu. Currently testing your mod on latest experimental on my ubuntu installation so that things dont get messed up on the server.

 

EDIT

ok so the mod works fine in SP with a few errors, but nothing crazy. However, dedicated server loads fine both from in game RWG and nitrogen maps, but if any player tries to join they get a constant console error: 

2020-07-28T06:02:06 79.889 ERR XML loader: Loading and parsing '' failed
2020-07-28T06:02:06 79.889 EXC An item with the same key has already been added. Key: ParticleEffects/p_snowstorm1
ArgumentException: An item with the same key has already been added. Key: ParticleEffects/p_snowstorm1
  at System.Collections.Generic.Dictionary`2[TKey,TValue].TryInsert (TKey key, TValue value, System.Collections.Generic.InsertionBehavior behavior) [0x000c1] in <567df3e0919241ba98db88bec4c6696f>:0 
  at System.Collections.Generic.Dictionary`2[TKey,TValue].Add (TKey key, TValue value) [0x00000] in <567df3e0919241ba98db88bec4c6696f>:0 
  at DictionaryList`2[T,S].Add (T _key, S _value) [0x00000] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at BiomeParticleManager.RegisterEffect (System.String biome, System.String prefabName, System.Single chunkMargin) [0x00066] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at WorldBiomes.parseBiome (System.Byte id, System.String name, System.Xml.XmlElement biomeElement, System.Boolean _instantiateReferences) [0x007e2] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at WorldBiomes.readXML (System.Xml.XmlDocument _xml, System.Boolean _instantiateReferences) [0x0011d] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at WorldBiomes..ctor (System.Xml.XmlDocument _genxml, System.Boolean _instantiateReferences) [0x0003d] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at WorldStaticData+<LoadBiomes>d__37.MoveNext () [0x00013] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at ThreadManager+<CoroutineWrapperWithExceptionCallback>d__40.MoveNext () [0x00044] in <4c0bf365ea03490793bfa81289f382e8>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
Logger:masterLogException(Exception)
Logger:Exception(Exception)
Log:Exception(Exception)
<>c__DisplayClass57_0:<handleReceivedConfigs>b__0(Exception)
<CoroutineWrapperWithExceptionCallback>d__40:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
 
(Filename: <567df3e0919241ba98db88bec4c6696f> Line: 0)

Repeats over and over again.

Yes I performed the prefabs section on both server and client. This error doesnt show in the F1 window at all in SP. Same OS, same system, same files.

Edited by Eko (see edit history)

Share this post


Link to post
Share on other sites

Hi, not sure if I missed something, how do I use the excavator? I've made one and placed it but nothing happens. TIA

Share this post


Link to post
Share on other sites
2 hours ago, Ytsirk said:

Hi, not sure if I missed something, how do I use the excavator? I've made one and placed it but nothing happens. TIA

Wait lol.

 

After a certain  period it will change. 

Share this post


Link to post
Share on other sites
On 7/28/2020 at 5:10 AM, Eko said:

Really enjoyed this on a18, keen for an a19 update! I know its still experimental, so I understand if you want to wait for the stable release to update. In the mean time, could you possibly give some support in troubleshooting the mod as is? I am comfortable making XML edits and am extremely keen to get this working! I added brass to drop from normal stone ore for now, but I really enjoyed the copper/zinc mix realism and balance your mod provided.

 

The mod still works, but biomes.xml has a few paths that need updating, I think. The excavators and rock crushers still work, and copper and zinc can still be found throughout the world, but the blocks.xml has broken the sinks and they wont drop brass when harvested now (i think, not entirely certain on this as I only tried it once and could be mistaken).

 

Let me know if youre willing to provide some pointers on what to change and I should be able to work out the rest! Can PM you logs and what not. Running dedicated server but can test on SP as well. Have 3 different systems that can test, running 5 different instances of OS lol. 3 x windows, 1 x mac and 1 x linux ubuntu. Currently testing your mod on latest experimental on my ubuntu installation so that things dont get messed up on the server.

 

EDIT

ok so the mod works fine in SP with a few errors, but nothing crazy. However, dedicated server loads fine both from in game RWG and nitrogen maps, but if any player tries to join they get a constant console error: 

2020-07-28T06:02:06 79.889 ERR XML loader: Loading and parsing '' failed
2020-07-28T06:02:06 79.889 EXC An item with the same key has already been added. Key: ParticleEffects/p_snowstorm1
ArgumentException: An item with the same key has already been added. Key: ParticleEffects/p_snowstorm1
  at System.Collections.Generic.Dictionary`2[TKey,TValue].TryInsert (TKey key, TValue value, System.Collections.Generic.InsertionBehavior behavior) [0x000c1] in <567df3e0919241ba98db88bec4c6696f>:0 
  at System.Collections.Generic.Dictionary`2[TKey,TValue].Add (TKey key, TValue value) [0x00000] in <567df3e0919241ba98db88bec4c6696f>:0 
  at DictionaryList`2[T,S].Add (T _key, S _value) [0x00000] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at BiomeParticleManager.RegisterEffect (System.String biome, System.String prefabName, System.Single chunkMargin) [0x00066] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at WorldBiomes.parseBiome (System.Byte id, System.String name, System.Xml.XmlElement biomeElement, System.Boolean _instantiateReferences) [0x007e2] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at WorldBiomes.readXML (System.Xml.XmlDocument _xml, System.Boolean _instantiateReferences) [0x0011d] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at WorldBiomes..ctor (System.Xml.XmlDocument _genxml, System.Boolean _instantiateReferences) [0x0003d] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at WorldStaticData+<LoadBiomes>d__37.MoveNext () [0x00013] in <4c0bf365ea03490793bfa81289f382e8>:0 
  at ThreadManager+<CoroutineWrapperWithExceptionCallback>d__40.MoveNext () [0x00044] in <4c0bf365ea03490793bfa81289f382e8>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
Logger:masterLogException(Exception)
Logger:Exception(Exception)
Log:Exception(Exception)
<>c__DisplayClass57_0:<handleReceivedConfigs>b__0(Exception)
<CoroutineWrapperWithExceptionCallback>d__40:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
 
(Filename: <567df3e0919241ba98db88bec4c6696f> Line: 0)

Repeats over and over again.

Yes I performed the prefabs section on both server and client. This error doesnt show in the F1 window at all in SP. Same OS, same system, same files.

Hi, did you find a solution?

Share this post


Link to post
Share on other sites
On 9/12/2020 at 2:11 AM, xxx73 said:

Hi, did you find a solution?

I did, but the XML edit I had got lost when I switched to the newest Alpha. Since im playing on my own now and not running a server, I havent done the fix again. What I did end up doing, going from memory, is basically just edited MeanCloud's biomes.xml and blocks.xml. All I did was delete the offending prefabs. I was dubious, thinking that this would break the placement of the mining blocks in the world, but it didnt seem to break anything. Check your server logs. It will tell you exactly what lines to delete. Hopefully MC returns to this someday :)
All the best!

 

Share this post


Link to post
Share on other sites
On 10/9/2020 at 6:06 AM, Eko said:

I did, but the XML edit I had got lost when I switched to the newest Alpha. Since im playing on my own now and not running a server, I havent done the fix again. What I did end up doing, going from memory, is basically just edited MeanCloud's biomes.xml and blocks.xml. All I did was delete the offending prefabs. I was dubious, thinking that this would break the placement of the mining blocks in the world, but it didnt seem to break anything. Check your server logs. It will tell you exactly what lines to delete. Hopefully MC returns to this someday :)
All the best!

 

ok thanks.

Share this post


Link to post
Share on other sites

I have made most of the mods work for DF, but my files is very much changed to work well in DF so no reason to share anything here.

Share this post


Link to post
Share on other sites

Is there any word on an update for this modlet, or is there a mod out there that does something similar for A19?
Not finding brass after literally destroying entire cities is kind of killing my hardcore runs.

Share this post


Link to post
Share on other sites

The copper and zinc and recipes from this mod is working out of the box, I think, you just have to remove all the other things.

My files is for Darkness Fall mod, that I strongly recommend, so they will not work well with 7dtd vanilla, and they are tweaked also.

 

 

Edited by xxx73 (see edit history)

Share this post


Link to post
Share on other sites

Alright I feel bad that I fixed it and others cant use. Full disclaimer, this worked on my server on the first version of A19 stable. I havent played the server since then, as I have been busy IRL and also building a massive prefab. So take this as you will, but always backup your files before editing. I will not give you my entire XMLs because I have changed some other aspects of MC's mod that you may not like. Don't ask, because you won't get it. If you want super custom stuff, you have to at least learn how to make basic edits yourself. I have literally zero background in coding, HTML or otherwise, and I found this to be fairly straightforward. It just takes a little bit of patience, care, and determination. 

Now, one thing I noticed about some of MC's XMLs is that he hasn't tabbed out some of the sections, which means that your document won't look as neat as I put it in here. If you want it all to look neat, its easy and safe to press enter for a new line for each section, and even highlight everything within a section (not including the title of the section) and then press tab to set it as its own section. Only do this if youre confident, but I highly recommend it. The neater your work is, the less trouble you will find later if you have to go back over it. I literally could not have done these edits originally if I hadn't gone through and at least cleaned up the parts I needed to change - because I am an amateur, walls of text are really hard for me to understand!
Here's an example:
(DO NOT COPY PASTE THIS - it has the bugged code in it! Do the work, reap the rewards)
 

Spoiler

<subbiome prob="0.195"> <!-- Ore Sub Biome: copperOre -->
            <layers>
                <layer depth="2" blockname="terrDestroyedStone"/> <layer depth="2" blockname="terrDirt"/>
                <layer depth="1" blockname="terrStone"> <resource blockname="terrGravel" prob="0.7830" rwgGenerationType="all"/> </layer>
                <layer depth="*" blockname="terrStone"> <resource blockname="terrOreCopper" prob="0.6500" rwgGenerationType="all"/> <resource blockname="terrGravel" prob="0.7830" rwgGenerationType="all"/> </layer> <layer depth="1" blockname="terrStone"/> <layer depth="3" blockname="terrBedrock"/>
            </layers>
            <decorations><decoration type="prefab" name="deco_copper_vein" checkresource="-7" onslopes="true" prob=".01857" rotatemax="3"/><decoration type="block" blockname="rockResource" prob=".00033" rotatemax="3"/><decoration type="block" blockname="rockResource02" prob=".00033" rotatemax="3"/><decoration type="block" blockname="cntWastelandRandomLootHelper" prob="0.00025"/><decoration type="block" blockname="treeDeadPineLeaf" prob="0.010" rotatemax="7"/><decoration type="block" blockname="scrapMetalPile" prob=".015" rotatemax="3"/><decoration type="block" blockname="brickDestroyedBlock01" prob=".0004" rotatemax="7"/><decoration type="block" blockname="brickDestroyedBlock02" prob=".0004" rotatemax="7"/><decoration type="block" blockname="brickDestroyedBlock03" prob=".0004" rotatemax="7"/><decoration type="block" blockname="rock01" prob=".004" rotatemax="3"/><decoration type="block" blockname="rock02" prob=".004" rotatemax="3"/><decoration type="block" blockname="rock04" prob=".004" rotatemax="3"/><decoration type="block" blockname="cntBirdnest" prob="0.001"/><decoration type="block" blockname="cinderBlocks01" prob=".006" rotatemax="7"/><decoration type="block" blockname="cinderBlocks02" prob=".006" rotatemax="7"/><decoration type="block" blockname="cinderBlocks03" prob=".006" rotatemax="7"/><decoration type="block" blockname="treeBurntMaple01" prob="0.0012" rotatemax="7"/><decoration type="block" blockname="treeBurntMaple02" prob="0.0012" rotatemax="7"/><decoration type="block" blockname="treeBurntMaple03" prob="0.0012" rotatemax="3"/><decoration type="block" blockname="treeMountainPineDry21m" prob="0.0006" rotatemax="7"/><decoration type="block" blockname="treeDeadPineLeaf" prob="0.001" rotatemax="7"/><decoration type="block" blockname="treeDeadTree02" prob="0.002" rotatemax="7"/><decoration type="block" blockname="treeDeadPineLeaf" prob="0.010" rotatemax="7"/><decoration type="prefab" name="waste_rubble_bldg_01" prob=".003"/><decoration type="prefab" name="waste_rubble_bldg_02" prob=".003"/><decoration type="prefab" name="waste_rubble_bldg_03" prob=".003"/><decoration type="prefab" name="waste_rubble_bldg_09" prob=".002"/><decoration type="prefab" name="waste_rubble_highway_01" prob=".0015"/><decoration type="prefab" name="mp_waste_pile_01" prob=".0065"/><decoration type="prefab" name="mp_waste_pile_02" prob=".0065"/><decoration type="prefab" name="mp_waste_pile_03" prob=".005"/><decoration type="prefab" name="mp_waste_pile_04" prob=".003"/><decoration type="prefab" name="mp_waste_pile_05" prob=".003"/><decoration type="block" blockname="carsRandomHelper" prob="0.13" rotatemax="3"/><decoration type="block" blockname="treeBrownGrassDiagonal" prob=".05"/></decorations>
        </subbiome>



Becomes:
   


<subbiome prob="0.195"> <!-- Ore Sub Biome: copperOre -->
            <layers>
                <layer depth="2" blockname="terrDestroyedStone"/> <layer depth="2" blockname="terrDirt"/>
                <layer depth="1" blockname="terrStone"> <resource blockname="terrGravel" prob="0.7830" rwgGenerationType="all"/> </layer>
                <layer depth="*" blockname="terrStone"> <resource blockname="terrOreCopper" prob="0.6500" rwgGenerationType="all"/> <resource blockname="terrGravel" prob="0.7830" rwgGenerationType="all"/> </layer> <layer depth="1" blockname="terrStone"/> <layer depth="3" blockname="terrBedrock"/>
            </layers>
            <decorations>
                <decoration type="prefab" name="deco_copper_vein" checkresource="-7" onslopes="true" prob=".01857" rotatemax="3"/>
                <decoration type="block" blockname="rockResource" prob=".00033" rotatemax="3"/>
                <decoration type="block" blockname="rockResource02" prob=".00033" rotatemax="3"/>
                <decoration type="block" blockname="cntWastelandRandomLootHelper" prob="0.00025"/>
                <decoration type="block" blockname="treeDeadPineLeaf" prob="0.010" rotatemax="7"/>
                <decoration type="block" blockname="scrapMetalPile" prob=".015" rotatemax="3"/>
                <decoration type="block" blockname="brickDestroyedBlock01" prob=".0004" rotatemax="7"/>
                <decoration type="block" blockname="brickDestroyedBlock02" prob=".0004" rotatemax="7"/>
                <decoration type="block" blockname="brickDestroyedBlock03" prob=".0004" rotatemax="7"/>
                <decoration type="block" blockname="rock01" prob=".004" rotatemax="3"/>
                <decoration type="block" blockname="rock02" prob=".004" rotatemax="3"/>
                <decoration type="block" blockname="rock04" prob=".004" rotatemax="3"/>
                <decoration type="block" blockname="cntBirdnest" prob="0.001"/>
                <decoration type="block" blockname="cinderBlocks01" prob=".006" rotatemax="7"/>
                <decoration type="block" blockname="cinderBlocks02" prob=".006" rotatemax="7"/>
                <decoration type="block" blockname="cinderBlocks03" prob=".006" rotatemax="7"/>
                <decoration type="block" blockname="treeBurntMaple01" prob="0.0012" rotatemax="7"/>
                <decoration type="block" blockname="treeBurntMaple02" prob="0.0012" rotatemax="7"/>
                <decoration type="block" blockname="treeBurntMaple03" prob="0.0012" rotatemax="3"/>
                <decoration type="block" blockname="treeMountainPineDry21m" prob="0.0006" rotatemax="7"/>
                <decoration type="block" blockname="treeDeadPineLeaf" prob="0.001" rotatemax="7"/>
                <decoration type="block" blockname="treeDeadTree02" prob="0.002" rotatemax="7"/>
                <decoration type="block" blockname="treeDeadPineLeaf" prob="0.010" rotatemax="7"/>
                <decoration type="prefab" name="waste_rubble_bldg_01" prob=".003"/>
                <decoration type="prefab" name="waste_rubble_bldg_02" prob=".003"/>
                <decoration type="prefab" name="waste_rubble_bldg_03" prob=".003"/>
                <decoration type="prefab" name="waste_rubble_bldg_09" prob=".002"/>
                <decoration type="prefab" name="waste_rubble_highway_01" prob=".0015"/>
                <decoration type="prefab" name="mp_waste_pile_01" prob=".0065"/>
                <decoration type="prefab" name="mp_waste_pile_02" prob=".0065"/>
                <decoration type="prefab" name="mp_waste_pile_03" prob=".005"/>
                <decoration type="prefab" name="mp_waste_pile_04" prob=".003"/>
                <decoration type="prefab" name="mp_waste_pile_05" prob=".003"/>
                <decoration type="block" blockname="carsRandomHelper" prob="0.13" rotatemax="3"/>
                <decoration type="block" blockname="treeBrownGrassDiagonal" prob=".05"/>
            </decorations>
        </subbiome>

 

 

  1.  Download a second fresh a copy of the latest MeanCloud Mining mod and put it somewhere other than the game directory. Make sure you name it differently so you know what version it is. AKA "MCM bkup before edits" . Why do this? Because it seems that MC won't be returning for a while and there's a chance the download links will break before then. 
  2.  It would be best if you try to run with mod as is and then check your error logs to get an idea of what is causing the errors. My errors may have been slightly different to yours as I play with other mods and they could be causing additional errors that you dont have. I'm fairly certain all the errors were just because of the new alpha updates though because I seem to remember running the game with only MCM installed - BUT it was a while ago and all sorts of user errors can interfere with that. If you don't know how to check/access your logs and are too scared to find out how, editing XMLs is not for you. Just wait for mod authors to make the stuff you want. 
  3. Make the edits in your original MC mining mod config files.  Use Notepad++ so that the walls of code dont look like a dog's dinner. Trust me, just do it. It's a way better program, its free, and you will make less mistakes.


KEY
I did not code block anything below because I know how easy it is to make mistakes when you're nervous, so I've used my own colour system to help you.
Blue Text - Location markers only! These are only there to assist you in finding the code you need to change. Simply using CTRL F and then replacing everything it finds will not work, because lines of code are repeated elsewhere that we need to leave alone. Use the lines in blue text as a way to navigate your document, and do not change the lines I have made blue.
Red Text - Lines or entire sections to delete! Do not just speed through my post and delete everything you see in red, because I have used the red text to highlight entire sections that need deleting. This is to avoid spamming the thread with walls of text, and also to make sure you're not just half-assing this, because that's where mistakes are made and I'll be damned if I let anyone try to blame me for their own mistakes. 
Green Text - Lines to add into the document. The blue text will indicate where to put these lines. So long as you add them into the correct section, it does not matter where in that section you put it. 
Large Bold Text - Instructions. Read carefully. 
Itallics Text - Further explanations to help you understand what you are doing. 


*********************************

RIGHT! On to the editing!
biomes.xml:
 

Spoiler

From the top of the document, just straight up delete

<set xpath="/worldgeneration/biomes/biome[@name='city']/subbiome[@prob='0.292']/@prob">0.185</set>
 <set xpath="/worldgeneration/biomes/biome[@name='city_wasteland']/subbiome[@prob='0.292']/@prob">0.185</set>
 <set xpath="/worldgeneration/biomes/biome[@name='wasteland_hub']/subbiome[@prob='0.292']/@prob">0.185</set>
 <set xpath="/worldgeneration/biomes/biome[@name='city']/subbiome[@prob='0.312']/@prob">0.210</set>
 <set xpath="/worldgeneration/biomes/biome[@name='city_wasteland']/subbiome[@prob='0.312']/@prob">0.210</set>
 <set xpath="/worldgeneration/biomes/biome[@name='wasteland_hub']/subbiome[@prob='0.312']/@prob">0.210</set>

 <set xpath="/worldgeneration/biomes/biome[@name='city']/subbiome[@prob='0.342']/@prob">0.235</set>
 <set xpath="/worldgeneration/biomes/biome[@name='city_wasteland']/subbiome[@prob='0.342']/@prob">0.235</set>
 <set xpath="/worldgeneration/biomes/biome[@name='wasteland_hub']/subbiome[@prob='0.342']/@prob">0.235</set>

 

Next, find the main section:
<append xpath="/worldgeneration/biomes/biome[@name='wasteland']">
Then find each of the subsections: 
<subbiome prob="0.195"> <!-- Ore Sub Biome: zincOre -->
<subbiome prob="0.195"> <!-- Ore Sub Biome: copperOre -->

Now, delete the following lines from each of the subsections above:

<decoration type="prefab" name="waste_rubble_bldg_01" prob=".003"/>
<decoration type="prefab" name="waste_rubble_bldg_02" prob=".003"/>
<decoration type="prefab" name="waste_rubble_bldg_03" prob=".003"/>
<decoration type="prefab" name="waste_rubble_bldg_09" prob=".002"/>
<decoration type="prefab" name="waste_rubble_highway_01" prob=".002"/>
<decoration type="prefab" name="mp_waste_pile_01" prob=".0065"/>
<decoration type="prefab" name="mp_waste_pile_02" prob=".0065"/>
<decoration type="prefab" name="mp_waste_pile_03" prob=".005"/>
<decoration type="prefab" name="mp_waste_pile_04" prob=".003"/>
<decoration type="prefab" name="mp_waste_pile_05" prob=".003"/>

 

Next, find the main section:
<append xpath="/worldgeneration/biomes/biome[@name='burnt_forest']">
Then find each of the subsections: 
<subbiome prob="0.195"> <!-- Ore Sub Biome: zincOre -->
<subbiome prob="0.195"> <!-- Ore Sub Biome: copperOre -->

Now, delete the following lines from each of the subsections above:
<decoration type="prefab" name="remnant_burnt_deco_01" prob=".0009"/>
<decoration type="prefab" name="remnant_burnt_deco_02" prob=".0009"/>

Find the main sections below and delete the entire section:

<append xpath="/worldgeneration/biomes/biome[@name='city']">
<append xpath="/worldgeneration/biomes/biome[@name='city_wasteland']">
<append xpath="/worldgeneration/biomes/biome[@name='wasteland_hub']">

<!-- cities; less common, ignore subbiome -->
 <append xpath="/worldgeneration/biomes/biome[@name='city']/layers/layer[@depth='*']">

 

"delete the entire section" means select everything within each of the main headings from the "<append xpath*****>" open brackets right up until the "</append> closed brackets, then press delete. Deleting only the headings above will just break things. Make sure you get the whole section. This is why it is VERY important to use a program like Notepad ++ that highlights code blocks and lets you minimize each section. Take a look at the example spoiler I did above to see the difference between Windows Notepad and Notepad ++. No, I am not affiliated with the program at all - I just appreciate the sh*t out of it!!

 

**************************************************


Phew! That's a lot!! Don't worry, the next one is much easier :)
blocks.xml:
 

Spoiler

 

Find:
 <!-- update various blocks throughout the game to produce copper and zinc where appropriate -->
It is not a "section", rather a commented out line. In Notepad ++ it will appear in green text. 
Then delete everything underneath that, right up to, but not including:
</MeanCloud_Mining>
That means, don't delete this line! That should remain at the end of your document.
 

***************************************************

This is not technically required for the mod to function, but it adds the chance to get rare gems from MC's ore just like the vanilla ore. If you feel that this is unbalanced for your server, you're all done with editing!
Find this section:
<block name="terrOreCopper">
Add these lines: 

<property name="Tags" value="ore,deepOre"/>

<drop event="Harvest" name="resourceRawDiamond" prob=".005" count="1" tag="artOfMiningLuckyStrikeHarvest"/>
<drop event="Harvest" name="resourceSilverNugget" prob=".01" count="1" tag="artOfMiningLuckyStrikeHarvest"/>
<drop event="Harvest" name="resourceGoldNugget" prob=".007" count="1" tag="artOfMiningLuckyStrikeHarvest"/>

Do the same addition for this section: 
<block name="terrOreZinc">

 


THE LAST STEP:
Be really f*cking grateful if this helped you in any way, because it took me 3hrs to put together and I have no personal need to do so. I did this because I know how frustrating it is to not feel confident enough to make that change you so desperately want, especially when you don't know if the mod author will ever return. Hopefully, this demystifies HTML coding and gives you the confidence to go on and make all sorts of changes you have previously dreamed about. Feel free to pass this on as a sort of general guide. Even though I didn't actually intend on writing a walkthrough, I still prefer to teach a man to fish, rather than spoon feed fishies all the time. Peace!

Edited by Eko (see edit history)
  • Thanks 3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...