Jump to content
psouza4

MeanCloud's Mining modlet (A18) with copper, zinc, and excavators

Recommended Posts

Nice Modlet, good work. But unfortunally not compatible with smxui from Sirillion :(

 

Does his mod mess with the forge?

 


Yeah I see that he completely reskins the forge, among other stuff -- thus the point of his mod. And forcibly sets it back to 4 inputs. He'd need to allow 6 inputs or it'll crash.

Edited by psouza4 (see edit history)

Share this post


Link to post
Share on other sites
Does his mod mess with the forge?

 


Yeah I see that he completely reskins the forge, among other stuff -- thus the point of his mod. And forcibly sets it back to 4 inputs. He'd need to allow 6 inputs or it'll crash.

 

can you rewrite yours for me so i can use the ui ?

Share this post


Link to post
Share on other sites
can you rewrite yours for me so i can use the ui ?

It won't work that way, his mod needs to support more inputs, not my mod support less. No point having no inputs for zinc or copper ;)

Share this post


Link to post
Share on other sites
It won't work that way, his mod needs to support more inputs, not my mod support less. No point having no inputs for zinc or copper ;)

 

ok thx

Share this post


Link to post
Share on other sites

I installed v1.01 into A18 stable and it works great, thank you ! Not quite sure what to do with most of the blocks that come up from the excavators though - the ones that are identified as ores crush with sand ok and give me lots of materials, but I'm not sure what to do with blocks of things like ashphalt, sandstone, fertile ground, that sorta thing ... Umm, help ? Thanks :)

 

Edit : having played a bit more trying stuff out it seems that all of those other blocks can be tossed into the forge where they'll turn into something useful - is that correct ? Cheers.

Edited by Grolbu (see edit history)

Share this post


Link to post
Share on other sites
Edit : having played a bit more trying stuff out it seems that all of those other blocks can be tossed into the forge where they'll turn into something useful - is that correct ? Cheers.
Everything except for asphalt, which is only useful as a building tool for paving. If you don't want to build with it, you can just toss it away. :)

Share this post


Link to post
Share on other sites

So I have a player on our server who is insisting that he cannot find the nodes for coal and is instead getting zinc, he is convinced that coal has been replaced. So where are the prime spots to find each node/vein in the game?

Share this post


Link to post
Share on other sites

Hey my friends and I installed the mod no issue but we're trying to figure out why we can't find coal nodes/veins anymore, we can only find zinc no matter how hard we look. If I were to just be lazy and apply a blue filter over say copper's deco.jpg, would that change it in the game? I know I'd need to give them each the edited .jpg if it does but we're looking to have an easy time, appearance doesn't matter to us.

 

Also some instructions on the mod on how to use the excavator would be appreciated. We're not sure how it works, we've left it out on the ground on all sorts of places and it doesn't generate anything.

Share this post


Link to post
Share on other sites

Sweet, thank you :) Is there a capacity limit for materials in the forge or can I keep throwing things in there basically forever ?

Share this post


Link to post
Share on other sites

hello, so when I use this I get some wrn, will this hurt the game or is it ok?

 

 

2019-11-03T23:28:22 253.057 WRN XML patch for "biomes.xml" from mod "MeanCloud's Mining for A18" did not apply: <append xpath="/worldgeneration/biomes/biome[@name=snow]/layers/layer[@depth=10]"

2019-11-03T23:28:22 253.057 WRN XML patch for "biomes.xml" from mod "MeanCloud's Mining for A18" did not apply: <append xpath="/worldgeneration/biomes/biome[@name=snow]/subbiome/layers/layer[@depth=10]"

2019-11-03T23:28:22 253.057 WRN XML patch for "biomes.xml" from mod "MeanCloud's Mining for A18" did not apply: <append xpath="/worldgeneration/biomes/biome[@name=pine_forest]/layers/layer[@depth=10]"

2019-11-03T23:28:22 253.058 WRN XML patch for "biomes.xml" from mod "MeanCloud's Mining for A18" did not apply: <append xpath="/worldgeneration/biomes/biome[@name=pine_forest]/subbiome/layers/layer[@depth=10]"

2019-11-03T23:28:22 253.058 WRN XML patch for "biomes.xml" from mod "MeanCloud's Mining for A18" did not apply: <append xpath="/worldgeneration/biomes/biome[@name=wasteland]/layers/layer[@depth=1]"

2019-11-03T23:28:22 253.058 WRN XML patch for "biomes.xml" from mod "MeanCloud's Mining for A18" did not apply: <append xpath="/worldgeneration/biomes/biome[@name=wasteland]/layers/layer[@depth=10]"

2019-11-03T23:28:22 253.058 WRN XML patch for "biomes.xml" from mod "MeanCloud's Mining for A18" did not apply: <append xpath="/worldgeneration/biomes/biome[@name=wasteland]/subbiome/layers/layer[@depth=10]"

2019-11-03T23:28:22 253.058 WRN XML patch for "biomes.xml" from mod "MeanCloud's Mining for A18" did not apply: <append xpath="/worldgeneration/biomes/biome[@name=burnt_forest]/layers/layer[@depth=10]"

2019-11-03T23:28:22 253.058 WRN XML patch for "biomes.xml" from mod "MeanCloud's Mining for A18" did not apply: <append xpath="/worldgeneration/biomes/biome[@name=city]/layers/layer[@depth=10]"

Share this post


Link to post
Share on other sites

It means, the ores will not be generated underground. Did you start a new map? Do you use any other mods which affect the biome creation?

 

I use this modlet without any issues, no errors or warnings at world creation.

Share this post


Link to post
Share on other sites

no, I found the problem it the smxhud modlet im using your mod loads fine but when I add the smxhud I get the wrn, I was wondering if they could be made compatible, what would I have to change or could I add the smxhud files to your files?

 

----Up Date----

I tried to combined them but it didn't work. but for some reason the biomes will not load with or with out modlets in, I do have the prefabs in and I start a new game every time I try.

Edited by dragonslayer770 (see edit history)

Share this post


Link to post
Share on other sites

Maybe you could provide a full outputlog.txt? I don't see a reason why a hud modlet should affect the biomes creation.

Share this post


Link to post
Share on other sites

I'm sure further up the log you'll find conflicts with the forge -- I'm guessing the HUD mod is changing the forge inputs (there needs to be 8, not 6).

Share this post


Link to post
Share on other sites
Hey my friends and I installed the mod no issue but we're trying to figure out why we can't find coal nodes/veins anymore, we can only find zinc no matter how hard we look. If I were to just be lazy and apply a blue filter over say copper's deco.jpg, would that change it in the game? I know I'd need to give them each the edited .jpg if it does but we're looking to have an easy time, appearance doesn't matter to us.

 

Also some instructions on the mod on how to use the excavator would be appreciated. We're not sure how it works, we've left it out on the ground on all sorts of places and it doesn't generate anything.

 

You can't apply a filter to a mesh texture. The images are just for admins to know what 3D entity they're placing and are not indicative of the color of the texture. I tested it thoroughly and did get multiple nodes (coal vs copper, zinc vs. pot. nitrate).

 

The excavators are automatic. You should notice them do something after 5-10 minutes of gameplay if you're in the area. 15+ minutes if you're unlucky. If they aren't, you should post your log.

Share this post


Link to post
Share on other sites

so I tried it again still the same and I recopied the prefabs to 7 days prefabs with this being the only modlet in.

 

https://www.dropbox.com/s/nk0hc4ew3ilhirz/output_log__2019-11-06__14-45-40.txt?dl=0

 

and I have one with the modlets I use

 

https://www.dropbox.com/s/q6js223yaj05mwn/output_log__2019-11-06__15-04-19.txt?dl=0

Edited by dragonslayer770 (see edit history)

Share this post


Link to post
Share on other sites

Updated mod to v1.02.

 

A18.1 changed some of the probabilities of sub-biomes, which threw some warnings. While these warnings would not prevent the mod from working, it was causing the probability of copper and zinc ore to not spawn as frequently as it should.

 

Generate a new RWG game using v1.02 for a better distribution of ore. Keep in mind that zinc ore looks like potassium nitrate (they share appearance) and copper ore looks like lead ore (they also share appearance), since I'm not a 3D video game artist.

 

Fully tested with game version A18.1 b6.

Share this post


Link to post
Share on other sites
so I tried it again still the same and I recopied the prefabs to 7 days prefabs with this being the only modlet in.

 

https://www.dropbox.com/s/nk0hc4ew3ilhirz/output_log__2019-11-06__14-45-40.txt?dl=0

 

and I have one with the modlets I use

 

https://www.dropbox.com/s/q6js223yaj05mwn/output_log__2019-11-06__15-04-19.txt?dl=0

 

it works know thanks for the up date.

I was wondering if I can use this or some of the code in my mod.

Share this post


Link to post
Share on other sites

Just installed your mining mod along with cannabis and fishing. I'm trying them out now on a fresh map. Server is 14.1.28.98:17657 if anyone is interested. I've always enjoyed various mining/fishing mods and can't wait to see how everything works!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...