Jump to content

Shifting and ghost textures


Recommended Posts

Hello, coming with "this: https://imgur.com/a/V29Y54a


First time experiencing this plague whatever that is, never in any alpha seen that happen, even didn't see it the entire time played a18 untill today. For 2 in-game days tried to troubleshoot this thing by turning off various video settings, nothing affected those ghost blocks growing literaly everywhere, tried validating game files, tried restarting computer, tried placing blocks in them to see if they refresh...


The game was fine, the first time entered a bigger city was also fine at the start, explored some station, stayed there for a night, decided to go explore a nearby church and when zombie broke out of those side holes it was "unleashed", didn't notice the walls vanished bcs... they didn't vanish on screen, they did for bf tho, he killed zombie, personaly commented that there are ghost blocks that can pass thro and we moved on, later saw shifting walls as if they had some face muscles and changed their expresions, it changed between like half and high quality as if high quality walls were under a thin layer of medium quality ones. The strange ghost walls were surrounding the house walls, were filling doorways, replacing blocks of railings and stairs, trash bags, sinks, refrigerators and all kinds of props, noticed a thin wooden fence wall being turned into a full block, the texture didn't change, just it showed a whole block, out of 4 blocks only 1 of them turned into the weird one, could go inside it but only that thin one side where it originaly was had a hitbox.


At this point suspecting the files are corrupted and verification just did nothing so going to reinstall the game fresh, also thought that there might be something in the city that causes it, but then why bf doesn't have anything like that?, he have the same graphic card. Realy have no idea and our game evening was ruined bcs of this bug and if anyone knows any way to fix that, would be glad to know.

Link to comment
Share on other sites

  • 2 months later...

sometimes there are files left, for a clean install you have to delete all folder like:




\Steam\steamapps\common\7 Days To Die



For a Easy ->Full<- Cleaning:


In steam right click the game and <click> show game launcher.

<click> the "Tools" [Tab] and select the "Clean Game Data" button.

Click all boxes *Discovered map of remote games* check the All Maps so it tries to find and erase all the past game maps it can.

Link to comment
Share on other sites

  • 7 months later...

Exact same problem here since a19 b163 onwards. I have also tried starting a new world several times but after a while the issue always returns (on 4 different random gen worlds). Quitting the game and going into steam to verify files fixes the immediate issue but after moving on to another POI the issue returns. On my current save I am 14hrs in and when the problem presented itself again just after horde night I decided to experiment. I backed up my save, used the 7dtd launcher to delete all traces of any games, uninstalled 7dtd, rebooted my computer, re-installed the game, regenerated my world and replaced my save. I went back in and everything seemed fine for 30 seconds until I pulled up to the POI I was supposed to clear, it was covered in these ghost blocks. I'm at a loss short of quitting the game and verifing the files only to play for another 15mins until the issue presents itself again.


They always seem to be the same texture, those greeny marble looking tiles with a few wood plates here and there exactly like in the image from OP. Can't interact with them or see through them but you can walk straight through them and once through you can see what was on the other side. I'm not opposed to starting a new game but would rather not. Any help on fixing this issue would be appreciated.


Also I just checked with the paint brush and the texture is called Grey Marble

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...