Jump to content

Linux Null Reference Exception


Recommended Posts

I'm Looking to see if I can get some help to shed light on an Issue with The Linux version of 7dtd throwing a Null Reference Exception with a UI mod. The reason I'm bringing the issue here is because for one, the mod author does not use Linux so he cannot help with the issue and also secondly, the issue only happens in Linux. The mod works 100% in windows which brings me to think there is a bug somewhere with the UI modding in the Linux version of 7dtd. I don't seem to be the only one with this issue also.

So the mod I'm seeing issues with is the SMX mod by Sirillion. like I said before, works 100% in windows but in Linux the game will load and I will get into the map then the F1 console opens and spams "Object reference not set to an instance of an object" in red and I am unable to interact with the game and have to force quit. When I open the log and scroll past all the usual loading stuff I see this:


(Filename: Line: -1)


NullReferenceException: Object reference not set to an instance of an object

at XUiV_Texture.UpdateData () [0x00000] in <filename unknown>:0

at XUiView.Update (Single _dt) [0x00000] in <filename unknown>:0

at XUiV_Texture.Update (Single _dt) [0x00000] in <filename unknown>:0

at XUiController.Update (Single _dt) [0x00000] in <filename unknown>:0

at XUiController.Update (Single _dt) [0x00000] in <filename unknown>:0

at XUiC_CompassWindow.Update (Single _dt) [0x00000] in <filename unknown>:0

at XUiController.Update (Single _dt) [0x00000] in <filename unknown>:0

at XUi.OnUpdateDeltaTime (Single updateDeltaTime) [0x00000] in <filename unknown>:0

at XUiUpdater.Update () [0x00000] in <filename unknown>:0

at GameManager.gmUpdate () [0x00000] in <filename unknown>:0

at GameManager.Update () [0x00000] in <filename unknown>:0


I do play a heavy moded game but the error goes away when I remove that mod. I'm stuck in trying to figure out if its his mod or a bug in the Linux game with certain UI modifications. It is the only Mod I have found that makes heavy use of custom graphics for the UI so i've been unable to test other UI mods for the same issue.

Link to comment
Share on other sites

Ok, you've got a couple of other errors before that.


This first one, I'm not 100% certain is an actual issue. It's been a while since I played this game on Linux.


Failed setting thread niceness (priority) to 0 due to EACCES (errno 13) violation. Lowering niceness (raising priority) requires CAP_SYS_NICE or superuser.


This one is definitely an issue, but probably wouldn't affect single-player much.


2019-07-24T10:41:04 25.915 INF NET: Starting server protocolsBind exception: System.Net.Sockets.SocketException: Protocol option not supported

at System.Net.Sockets.Socket.SetSocketOption (SocketOptionLevel optionLevel, SocketOptionName optionName, Boolean optionValue) [0x00000] in <filename unknown>:0

at LiteNetLib.NetSocket.BindSocket (System.Net.Sockets.Socket socket, System.Net.IPEndPoint ep, Boolean reuseAddress) [0x00000] in <filename unknown>:0 , errorCode: ProtocolOption


Basically it means that the port the game is trying to use isn't available because it's already in use. May be caused by a previousl/recent crashed session too though.



The first serious issue though is right here...

2019-07-24T10:41:16 37.767 WRN XML patch for "items.xml" from mod "Mayics Firearms 2" did not apply: <set xpath="/items/item[@name='ammoRocketFrag']/property[@name='Material' and @value]/@value" 

The problem with the way Unity loads the xml, is that the error may only be in that location, but the issue cascades into everything that is loaded afterwards. So the problem with that mod, is causing the issue in the other mod you're trying to use.


I bet that if you disable the Mayics Firearms 2 mod, you'll find that the UI mod works just fine. (If you have any items from that mod, you will want to tuck them somewhere other than your player before removing it, and not access that place you put them until you put the mod back in.)


It's also remotely possible that one of the other mods changes a UI feature that conflicts with SMXhud. I would have to research each of the other mods to determine if that was the case.

Link to comment
Share on other sites

Unfortunately I've tried it before I installed That mod and still got that error. Ill remove all mods after I wake up tomorrow and leave just the SMXhud mod and see what happens. If I get the same error ill post the new log.

Link to comment
Share on other sites

That was from a new game, sorry I didnt specify, after I removed the mods I made a new game. The previous one was a randomly generated map, the current log is from a Navezgane single player map I made after removing all of the other mods..

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...