Jump to content

d3d11: failed to create buffer

Recommended Posts

EDIT: I had to delete several D3D11: failed to create buffer lines from the output log because the file was too large for pastebin.


Hello, here is the issue:

After sometime in game the video will freeze & I can hear audio (foot steps when WASD)(inventory menu TAB) (jump animation SPACE BAR) (ambient sound) etc....

Left the game run for sometime & never get a 'game crash' or 'display driver stopped responding' message.

I have to press windows key, control alt delete to task manager. When viewing task manager 7 days to die is running along with unity crash report.

End task to close 7 days to die.


This issue has been happening from alpha 16 onward.

Attached log file.



Things I have tried:

1: restart steam / pc

2: verify game files via steam

3: try older GPU driver versions

4: disable G-sync

5: change monitor res. from game options to 1920x1080

6: v-sync off / on from game options

7: MsConfig / services: disable all non Microsoft services & all startup except Steam


PC specs:

Windows 10 x64 home edition

2560 x 1440 144hz G-sync Monitor

i7-8700k LGA1151

Geforce GTX 1080Ti Driver Version 430.86

Z370 Aorus gaming 7

G.Skill TridentZ DDR4 16GB

Samsung NVMe SSD 960 EVO 250GB

Crucial MX300 SSD 1Tb

Seasonic 80 + Gold 850 FX

Link to comment
Share on other sites

One thing I see is that it's trying to load a prefab that's not there. Not saying that's the issue but, maybe there's some remnant of a mod lying about?

In the launcher there's an option to clean all game data, I'd try that, then uninstall and reinstall.

Link to comment
Share on other sites

Just tried launching game with GLCore. While in game, there is noticeable stutter/hitching when walking & turning. After about 3 to 8 minutes game closed & exit to desktop with no warning. Tried 4 times, same result.

Is there a way to create Developer support ticket. I appreciate the help from community.


Attached log files





Link to comment
Share on other sites

If you're 100% sure your install is clean at this point, then I honestly don't think the game is the issue in this case.


If the problem is system related, and not game related, then a stess test may be able to show that.

You could run some stress tests like prime95 and furmark to see if the system can handle it. If it can't,

then you know it's the system and not the game.


Maybe you're having heat problems; are you overclocking? An app like HWMonitor will show you cpu and gpu temps.


It could be a hardware problem with the 1080, or a corrupt system/driver file...

If it was me, I'd start with the basics...

Set cpu/gpu speeds to defaults. Clean install nvidia drivers.

Check temps in game and under stress tests.

Run dxdiag, chckdsk, sfc /scannow. I forget the command but DISM can do a Win 10 repair.

Run a memory test

Link to comment
Share on other sites

Ran DISM /Online /Cleanup-Image /RestoreHealth from cmd. No issues found.

Ran DISM /Online /Cleanup-Image /CheckHealth from cmd. No issues found.

Ran sfc /scannow from cmd. No issues found.

MemTest86 results: Pass complete, no errors: 0

Monitor CPU temp. using CPUID HWMonitor & run prime95 Version 29.8b5 for 2 hours. No crash & CPU temp. 78 degrees C.

For the GPU stress test, Superposition Benchmark. Ran several times. No crash & GPU temp. Max 79 degrees C.

It is not a hardware problem with 1080ti, pc or corrupt system/driver files.

I ran the game using - force-d3d9 as launch option & no problems. Based on my findings, it looks like a Unity DirectX / OpenGL issue with specific hardware/driver/Windows 10 version 1903.

If anyone has more suggestions to eliminate other possibilities, please let me know.

Link to comment
Share on other sites

That's a lot of testing, good job. That's intersting that d3d9 works but opengl and d3d11 doesn't.


Maybe try running DDU (display driver uninstall), which is supposed to do a great job at cleaning up display drivers.

After DDU, do a clean install of the nvidia driver.


Also, try the Microsoft end-user dirextx installer to reinstall directx. https://www.microsoft.com/en-us/download/details.aspx?id=35

Link to comment
Share on other sites

Already tried DDU & clean install of nvidia driver before posting here.

Found this from Microsoft site about directX, Updates will be available through Windows 10 Update. There is no stand-alone package for these versions of DirectX.

I ran the Microsoft end-user directx installer and got this message, a newer or equivalent version already installed.

Link to comment
Share on other sites

Update, same issue as OP with -force-d3d9.

Command line arguments: D:\SteamLibrary\steamapps\common\7 Days To Die\7DaysToDie.exe -force-d3d9 -force-d3d11 -logfile,

Checked logs, still getting 'd3d11: failed to create buffer' with -force-d3d9 as command line argument.

The -force-d3d11 in command line argument is not from me, possibly game is forcing -force-d3d11 ?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...