Jump to content
Sign in to follow this  
Haidrgna

Gnamod UI

Recommended Posts

Quick question ..

 

When will this be Updated ?? You have a Updated version on the mod launcher, but I would like to have one here also for the Vanilla game .. when not using the mod launcher.

 

Thank you

 

I am currently working on the 0.7.0 version of this, currently only in Dev for the launcher. Once that is done, hopefully the end of this week, I will update all the manual downloads as well. The next version will include a new player window (done), Map window (done) and I will try to also get the Notes window, shape selector and progression window done. Possibly also include some dev windows (for the poi editor).

 

I want to release a full and complete version for the 0.7.0 release and then update this thread (and the Gnamod base thread). So until that is done the launcher will only have the latest version.

 

Does the current version have any bugs, things not working in the stable release? If so I will update he manual download version (As not much did change since A17.)

Share this post


Link to post
Share on other sites

Good Day Haidrgna

 

A Issue has popped up with todays Update to A 18.2 b5 .. getting an error message for UI .. it is happening on both versions 0.6.0 and 0.7.0 .. have checked them both.

 

 

2028256142_7DaystoDieScreenshot2019_12.04-16_29_16.86(2).jpg.7c3f6ad89c268745bddd2055e0f30517.jpg

 

Hope you can read it .. but it has to do with line 368 to 370 in the uxi.xml

Thought I should let you know.

103741402_7DaystoDieScreenshot2019_12.04-16_29_16.86(2).jpg.647a698c1b22e4e1b679bbb9180c5d95.jpg

Edited by gpcstargate (see edit history)

Share this post


Link to post
Share on other sites

Thanks for reporting, this is fixed in the dev branch (launcher only), it relates to a editor part of the UI I think, so unless you are doing prefab edits it should work for other menu's. I will push a fix later today to the other branches.

Share this post


Link to post
Share on other sites
Thanks for reporting, this is fixed in the dev branch (launcher only), it relates to a editor part of the UI I think, so unless you are doing prefab edits it should work for other menu's. I will push a fix later today to the other branches.

 

Using COMPOPACK 42 by Magoli in both games and also getting it on the launcher also version, Just under A 18.2 b5 Sable only .. (A 18.1 b8 is fine)

 

Edit .. I just doubled checked the Launcher version ( UI Stable ) and with Game Version A 18.2 b5 Stable .. I still get the error message.

 

Thank you for your hard work .. the Old Gamer … :02.47-tranquillity:

Edited by gpcstargate (see edit history)

Share this post


Link to post
Share on other sites
Using COMPOPACK 42 by Magoli in both games and also getting it on the launcher also version, Just under A 18.2 b5 Sable only .. (A 18.1 b8 is fine)

 

Edit .. I just doubled checked the Launcher version ( UI Stable ) and with Game Version A 18.2 b5 Stable .. I still get the error message.

 

Thank you for your hard work .. the Old Gamer … :02.47-tranquillity:

 

Probably because I had not yet deployed a hotfix (was at work until now).

 

Update:

Added a small hotfix to the Stable version of Gnamod UI that should fix the Light Properties menu from bugging out after the backend of the window was changed in A18.2 (b5).

 

The Dev version on the launcher also has this fix but other currently still experimental changes.

Share this post


Link to post
Share on other sites
Is this server side only I'm hoping?

 

You can install this modlet on a server, it should work for clients to, but they might not see the Gnamod Icon if they have not downloaded the modlet themselves. I have not really tested it as server side only, the UI relies on a few added localizations that the vanilla UI did not have localized as well so those may be missing as I do not think localizations are pushed by servers.

 

But I guess you need to test to see if it works or not and let me know, there might be options to make a fully server side working version.

Share this post


Link to post
Share on other sites

@ Haidrgna

 

Question .. Is the map light ( the amount of light that is shown when you open your map ) controlled by the UI .. tried to adjust with gamma .. but it is much brighter than before, don't know if you can adjust .. but thought I would let you know.

*** Like taking a 60 watt bulb and replacing with 75 watt bulb *** not sure what happened and hoping you know what I'm trying to say. ON Both version Launcher and this one.

 

Thank you and But _ error is fixed .. that part is good .. the Old Gamer … :02.47-tranquillity:

Edited by gpcstargate (see edit history)

Share this post


Link to post
Share on other sites
@ Haidrgna

 

Question .. Is the map light ( the amount of light that is shown when you open your map ) controlled by the UI .. tried to adjust with gamma .. but it is much brighter than before, don't know if you can adjust .. but thought I would let you know.

*** Like taking a 60 watt bulb and replacing with 75 watt bulb *** not sure what happened and hoping you know what I'm trying to say. ON Both version Launcher and this one.

 

Thank you and But _ error is fixed .. that part is good .. the Old Gamer … :02.47-tranquillity:

 

I know what you mean and I have no idea what causes it, it happens sometimes on games, other games it does not. The map is rendered somwhere in code and in the 0.7.0 version I have no adjustments to that window. The dev version has some experimental new map but its awfully limited and much seems hard coded on the map.

 

All I know is the very bright map also happens on the vanilla UI and could be a (rare) UI bug.

Share this post


Link to post
Share on other sites

I will try it on my server and let you know. I really like everything about it and it would be something everyone else would like of it works server side.

 

 

You can install this modlet on a server, it should work for clients to, but they might not see the Gnamod Icon if they have not downloaded the modlet themselves. I have not really tested it as server side only, the UI relies on a few added localizations that the vanilla UI did not have localized as well so those may be missing as I do not think localizations are pushed by servers.

 

But I guess you need to test to see if it works or not and let me know, there might be options to make a fully server side working version.

Share this post


Link to post
Share on other sites
I know what you mean and I have no idea what causes it, it happens sometimes on games, other games it does not. The map is rendered somwhere in code and in the 0.7.0 version I have no adjustments to that window. The dev version has some experimental new map but its awfully limited and much seems hard coded on the map.

 

All I know is the very bright map also happens on the vanilla UI and could be a (rare) UI bug.

 

Thank you .. It READJUSTED Back to Normal when I went back into game the second time .. Dag-gone bugs _ it's all TFP fault .. Lol

Thank you again, at least you knew what I was talking about .. the Old Gamer … :02.47-tranquillity:

Share this post


Link to post
Share on other sites
Thank you .. It READJUSTED Back to Normal when I went back into game the second time .. Dag-gone bugs _ it's all TFP fault .. Lol

Thank you again, at least you knew what I was talking about .. the Old Gamer … :02.47-tranquillity:

 

Yeah probably a hard to track bug, if you can find when it happens they might be able to fix it, but it seems pretty random.

Share this post


Link to post
Share on other sites

I'm playing on the Mod Launcher and just started to get this message when loading game:

795445918_7DaystoDieScreenshot2020_01.10-11_50_14.54(2).jpg.a58df7eec51358f79807fbf61751200e.jpg

 

Has something to do with the newer version UI Stable that must have been updated, never saw it before and it does not show up on the Vanilla version using the older UI Stable mod ( I copied to the vanilla game ) .. I running 2 different games with the exact same mods.

Thank you .. the Old Gamer … :02.47-tranquillity:

Share this post


Link to post
Share on other sites
I'm playing on the Mod Launcher and just started to get this message when loading game:

[ATTACH=CONFIG]31140[/ATTACH]

 

Has something to do with the newer version UI Stable that must have been updated, never saw it before and it does not show up on the Vanilla version using the older UI Stable mod ( I copied to the vanilla game ) .. I running 2 different games with the exact same mods.

Thank you .. the Old Gamer … :02.47-tranquillity:

 

I cannot read that, its to small. Maybe post logs instead on something like pastebin if you want me to be able to look at it.

 

I also have no idea what you did, the current Dev version of the UI is only compatible with 18.3 and the stable has not updated for a while and should still be compatible with 18.2.

 

The fact that 18.3 remains experimental is a problem though as I want to release the new version, but it will break with 18.2 for sure because of the font changes and other stuff they altered to make the new localization work.

Share this post


Link to post
Share on other sites
I cannot read that, its to small. Maybe post logs instead on something like pastebin if you want me to be able to look at it.

 

I also have no idea what you did, the current Dev version of the UI is only compatible with 18.3 and the stable has not updated for a while and should still be compatible with 18.2.

 

The fact that 18.3 remains experimental is a problem though as I want to release the new version, but it will break with 18.2 for sure because of the font changes and other stuff they altered to make the new localization work.

 

OK, I thought you might have a problem reading it .. so I'll type it out. Sorry about that.

word for word and spacing.

 

[Physics.PhysX] QuickHullConvexHullLib::findSimplex: Simplex input points appers to be coplanar.

 

Maybe it has nothing to do with .. Gnamod Core UI (Stable) .. but it just started to show up maybe a few days ago .. after doing a Pre-Sync Mod and launching the game on the Launcher.

But Like I said .. I'm using the same version of (Gnamod Core UI) that I copied from launcher game file to my Vanilla game on 12/5/19 with No Issues and the exact same mod package that I use on all my 7D2D games.

 

The game runs and I thought that I would just give you a heads up .. never used Pastebin before .. but if need be, I can try if you still need it.

Thank You .. the Old Gamer … :02.47-tranquillity:

Edited by gpcstargate (see edit history)

Share this post


Link to post
Share on other sites
OK, I thought you might have a problem reading it .. so I'll type it out. Sorry about that.

word for word and spacing.

 

[Physics.PhysX] QuickHullConvexHullLib::findSimplex: Simplex input points appers to be coplanar.

 

Maybe it has nothing to do with .. Gnamod Core UI (Stable) .. but it just started to show up maybe a few days ago .. after doing a Pre-Sync Mod and launching the game on the Launcher.

But Like I said .. I'm using the same version of (Gnamod Core UI) that I copied from launcher game file to my Vanilla game on 12/5/19 with No Issues and the exact same mod package that I use on all my 7D2D games.

 

The game runs and I thought that I would just give you a heads up .. never used Pastebin before .. but if need be, I can try if you still need it.

Thank You .. the Old Gamer … :02.47-tranquillity:

 

This message you typed over seems to be related to some physics stuff so could be your video drivers or something. But its kind of pointless to me, since it is just one isolated message. The log shows the entire story, with that there is a chance to point it down. So far all evidence suggests is not related to the UI mod, but I cannot be sure with a log where the error appears.

Share this post


Link to post
Share on other sites

I have just updated the manual download link as well as the mod launcher versions.

 

Since A18.3 is still in experimental there are two versions of the UI modlet. The 0.7.0 version is compatible with A18.2 b5 and before while the latest version 0.7.2 is compatible only with 18.3 b3 and later. They changed the fonts in 18.3 and some other stuff, so if you load the wrong version you will have no text and some other issues will pop up.

 

The mod launcher also has these versions, there you can find the A18.2 version under Gnamod CoreUI (Stable) and the 18.3 version under Gnamod CoreUI (Latest).

 

The main changes in the 0.7.2 version:

- Compatibility changes to 18.3 b3.

- Redone the Players window, use more screenspace and bigger icons/text for better readability since there is enough space on the screen.

- Redone the Map window, this is still a work in progress and has some hiccups I am not sure are fixable with xml only. The icons on the waypoint selection are currently still to large and working on finding a way to get them to draw horizontally (seems hard-coded to draw vertically).

- This version has mostly been made compatible with the new font changes but since I was mostly working on getting the Gnamod Core mod out to a stable release this kind of was put on hold. Now that it is done I will likely pick this up again and work on it for until 18.3 goes to stable.

 

Updating the main post(s) and adding new A18 screenshots is also on my list for this week as much of it is outdated.

Share this post


Link to post
Share on other sites

@ Haidrgna

 

You remember me saying that I was getting an issue with a [Physics.PhysX] popping up in loading screen. A couple post back.

 

I started another game and did NOT SHOW UP _ UNTIL I started to Build a " Floating Base " .. which I had just added to the game on the launcher also, But that 1 was just a small escape route. ……

Anyway .. I'm starting to think it may have something to do with the Floating Bases … AND A 18.2 … this never happened before in earlier games .. But TFP changed up a bunch of the coding in the A 18 game as we all know and it might be a conflict of a " floating structure vs a standard on ground structure " ….. And the game still runs just fine, well for now anyway. Had my 300 kill Z's on the 14 day horde.

 

Just thought I might just pass that thought on. Have a great weekend … the Old Gamer .. :02.47-tranquillity:

Edited by gpcstargate (see edit history)

Share this post


Link to post
Share on other sites
@ Haidrgna

 

You remember me saying that I was getting an issue with a [Physics.PhysX] popping up in loading screen. A couple post back.

 

I started another game and did NOT SHOW UP _ UNTIL I started to Build a " Floating Base " .. which I had just added to the game on the launcher also, But that 1 was just a small escape route. ……

Anyway .. I'm starting to think it may have something to do with the Floating Bases … AND A 18.2 … this never happened before in earlier games .. But TFP changed up a bunch of the coding in the A 18 game as we all know and it might be a conflict of a " floating structure vs a standard on ground structure " ….. And the game still runs just fine, well for now anyway. Had my 300 kill Z's on the 14 day horde.

 

Just thought I might just pass that thought on. Have a great weekend … the Old Gamer .. :02.47-tranquillity:

 

Then whatever causes it must be in that modlet, at least it seems logical that way. Not sure how that mod works, but floating stuff generally leads to stability issues. Probably should let the creator know if you have not already or if it uses vanilla stuff report it as a bug.

Share this post


Link to post
Share on other sites

no-no .. you misunderstood .. I'm building floating bases with the game blocks .. there are thin blocks (Plate block) that you Can lay down one direction _ flat and then rotate in advance to the upper side of the block that will give you a (2 block) spacing between them.

I started building them in A15 and never had an issue until now ..

 

Game will not show any issue in the loading F1 screen .. until I start building one of the floating base and it will only show up in F1 after starting the game again (when going back into game next time). It must have something to do with TFP coding changes ………. But the Game still will run fine, even with that error _ just strange. never happen until A18.2

 

251570_20200116165715_1.jpg.f524c1b38cd7c91cffcfc47b6b722d49.jpg

 

And the Zombies have No clue .. vultures and splitters are the main problem .. haven't had bombers on the base design yet.

Just want to give you my thoughts and let you Know everything is good with UI.

Have Fun and Enjoy … the Older Gamer .. :02.47-tranquillity:

251570_20200116105106_1.jpg.2afaf78fc42be8f44555e4cc3c16ac6a.jpg

Edited by gpcstargate (see edit history)

Share this post


Link to post
Share on other sites
no-no .. you misunderstood .. I'm building floating bases with the game blocks .. there are thin blocks (Plate block) that you Can lay down one direction _ flat and then rotate in advance to the upper side of the block that will give you a (2 block) spacing between them.

I started building them in A15 and never had an issue until now ..

 

Game will not show any issue in the loading F1 screen .. until I start building one of the floating base and it will only show up in F1 after starting the game again (when going back into game next time). It must have something to do with TFP coding changes ………. But the Game still will run fine, even with that error _ just strange. never happen until A18.2

 

[ATTACH=CONFIG]31205[/ATTACH] …. [ATTACH=CONFIG]31206[/ATTACH]

 

And the Zombies have No clue .. vultures and splitters are the main problem .. haven't had bombers on the base design yet.

Just want to give you my thoughts and let you Know everything is good with UI.

Have Fun and Enjoy … the Older Gamer .. :02.47-tranquillity:

 

Ok I was not sure you talking about the plate exploit or actual floating blocks, since both are a thing. Floating blocks just give more problems, the plates are valid for SI, but the AI has issues with it. I rather stay away from such exploits and build a real base.

Share this post


Link to post
Share on other sites

Yes .. I can understand that and I think maybe TFP tightened up on the SI .. you really have to watch what you build using it .. I have had a couple fall because of over expanding or to much weight.

I keep most construction at 5 blocks between supports now .. The Big Ones seem to collapse easier now.

So Now, this is about as Big as I build them and able to get all workstation in it with up to 3 forges on top. " You know screamers love heat, lol "

 

Thank you, again … the Old Gamer .. :02.47-tranquillity:

Share this post


Link to post
Share on other sites

I have pushed the 0.7.2 Version to the stable branch now that A18.3 has hit stable. If you ran into issues before using this modlet try updating it (on the Mod Launcher that is). For the manual download you can install the Latest version, but I will update those shortly as well so the stable version is clear what it is.

Share this post


Link to post
Share on other sites

Haidrgna .. Glad to hear you updated .. I had to remove the UI on game when .. "A 18.3 b4 Stable" .. Auto updated on Steam, caused some major error ..

So I'm guessing the link here has been Updated to 0.7.2, is that correct? FOR _ A 18.3 b4 Stable.

Thank you

 

PS: First pages still says " Current latest version: 0.7.2 for A18.3 b3 (experimental version). "

Edited by gpcstargate (see edit history)

Share this post


Link to post
Share on other sites
Haidrgna .. Glad to hear you updated .. I had to remove the UI on game when .. "A 18.3 b4 Stable" .. Auto updated on Steam, caused some major error ..

So I'm guessing the link here has been Updated to 0.7.2, is that correct? FOR _ A 18.3 b4 Stable.

Thank you

 

PS: First pages still says " Current latest version: 0.7.2 for A18.3 b3 (experimental version). "

 

There is no difference as far the UI is concerned between b3 and b4. But I will update it.

 

Also if a Stable version breaks there is always a Latest version to load up. The latest version I keep up to date with any experimental releases, while the stable stays behind to remain compatible with the last stable release of the game.

 

People seem to be scared of the latest or dev releases, but those are usually the best versions of my mods, just may also contain some style issues in case of the UI.

Edited by Haidrgna (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...