Jump to content

EAC Client Will Not Launch


Recommended Posts



My problem is that when I try to run the game through the shortcut steam creates on downloading/installing 7 Days to Die, I get the EAC splash screen, the meter on the bottom fills, then the splash screen closes and the client does not launch.


I can run 7DaysToDie_EAC.exe manually in the game directory as an Administrator and it loads up fine, though I cannot join any servers with EAC enabled as halfway through downloading the map, I get kicked by EAC and a temporary ban of 15 minutes. I don't know if this is because EAC is not running properly or because I have slow internet, though I can play fine on servers without EAC.


I have noticed in my task manager that when the EAC launcher goes away, the 7DaysToDie.exe process shows briefly, then disappears. If I try to launch the game too many times like this, eventually I get a blue screen error of BAD_POOL_HEADER.


The game leaves behind no log in GameDirectory/7DaysToDie_Data.


Games runs fine if I disable EAC, both for server and singleplayer.


What I have tried:

Disabling my AntiMalware and Comodo Firewall completely.

Repairing EAC with the EasyAntiCheatSetup.exe as Administrator

Uninstalling and Reinstalling EAC with EasyAntiCheatSetup.exe as Administrator

Deleting the 7DaysToDie folder in AppData/Roaming.

Verifying Integrity of Files through Steam.

Uninstalling EAC, Uninstalling 7 Days to Die through Steam, deleting remaining game folder, deleting 7DaysToDie folder in AppData/Roaming, deleting the entire FunPimps subentry in the Registry, running CCleaner on the Registry, then finally redownloading the game through steam.


I am thoroughly flummoxed.



Windows 10

GFX Nvidia GTX 1060

CPU Intel i7 7700k


Running game on M.2 SSD

Link to comment
Share on other sites

I have run an sfc scan and it did not return any errors. Same with chkdsk. I have recently updated my GFX driver because of the security issue found in April, so I don't think it is that. I also don't think it is my memory or any other drivers for that matter as the issue only comes up with EAC, and only if I run it too many times where it fails to launch. If anything, I think it has something to do with the launch not handling the memory correctly. If any of my hardware had issues, I would see errors in more places than just with EAC.

Link to comment
Share on other sites

Try a system restore maybe? Check Audio and Network drivers for an update. Run a memory check just for fun. It's very easy and then at least you'll know instead of surmising. As a test, uninstall Comodo and whatever other Anti-malware you have and just let Win 10 Defender and Firewall handle it. Don't install EAC manually, let 7D2D do it.


If you're confident you've narrowed it down to an EAC coding problem, then EAC support would be your next step.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...