Jump to content

A19 NPCs DMT Mod


xyth

Recommended Posts

Currency: item=549 m=0 ut=0 Faction: 6

Adding Buff for Attack Target()

NullReferenceException: Object reference not set to an instance of an object

at EAIMaslowLevel1SDX.PerformAction () [0x00000] in <filename unknown>:0

at EAIMaslowLevel1SDX.CheckForFoodBin () [0x00000] in <filename unknown>:0

at EAIMaslowLevel1SDX.CanExecute () [0x00000] in <filename unknown>:0

at EAITaskList.OnUpdateTasks () [0x00000] in <filename unknown>:0

at EAIManager.Update () [0x00000] in <filename unknown>:0

at EntityAlive.updateTasks () [0x00000] in <filename unknown>:0

at EntityAlive.OnUpdateLive () [0x00000] in <filename unknown>:0

at EntityNPC.OnUpdateLive () [0x00000] in <filename unknown>:0

at EntityAliveSDX.OnUpdateLive () [0x00000] in <filename unknown>:0

at EntityAlive.OnUpdateEntity () [0x00000] in <filename unknown>:0

at World.TickEntities (Single _partialTicks) [0x00000] in <filename unknown>:0

at GameManager.gmUpdate () [0x00000] in <filename unknown>:0

at GameManager.Update () [0x00000] in <filename unknown>:0

 

(Filename: Line: -1)

Link to comment
Share on other sites

So I downloaded the SDX tool, this is the order I did things.

 

1. After trying SDX tool first time, got some errors.

2. Verified integrity of game, fixed files SDX changed.

3. Put NPC mod and all 4 dependencies into mod folder. They were the only mods in folder.

4. Selected NPC mod and all 4 dependencies and pressed build.

5. No matter what I always get an error saying the dependencies are being used by another process and it fails to build.

 

Anything I'm doing wrong and can do to fix this?

Link to comment
Share on other sites

So I downloaded the SDX tool, this is the order I did things.

 

1. After trying SDX tool first time, got some errors.

2. Verified integrity of game, fixed files SDX changed.

3. Put NPC mod and all 4 dependencies into mod folder. They were the only mods in folder.

4. Selected NPC mod and all 4 dependencies and pressed build.

5. No matter what I always get an error saying the dependencies are being used by another process and it fails to build.

 

Anything I'm doing wrong and can do to fix this?

 

This doesn't sound like a feature of SDX / DMT. Do you have any on-access anti-virus scanners that may be interrupting it?

Link to comment
Share on other sites

I just have the free trial version of AVG. I'm pretty sure it's not interrupting anything, since I can successfully build sometimes. If it was anti virus I would never be able to. But I can only successfully build when its like just 1 file. If I add in other files it says the file is being used by another process. But I tried it when the only program open was the SDX tool. I even tried it with both steam on and off. Only background programs I have running are AVG and NVIDA control panel.

Link to comment
Share on other sites

I'm having installation troubles, myself. Using 17.4, newly downloaded. DMT, newly installed. Only AnimationSDX, aXUI_Dialog, Patch_Entity, SDX_EntityAliveSDX, Xyth Bandits, Xyth NPCs, and Xyth Wandering Traders installed. Whether I check them all off or just AnimationSDX, I get the same error:

 

Running BackupFiles

Backup dll found: K:\K Mods\7 Days to Die\Manager/Backups/SP/17.4b4/Assembly-CSharp.dll

Running DeployDlls

Deploying DLLs

Running LocalisationPatch

Running InitialPatchTask

Compiling PatchScripts assembly for InitialPatch...

Built patch file in 554ms

PatchMods compile successful

Found patcher mods: 1

 

Hooking console commands

Running CreateModDll

Compiling Mods.dll...

Built in 539ms

g:\Full Games\7 Days to Die\Mods - DMT\AnimationSDX\Scripts\MecanimSDX.cs(992,35): error CS0103: The name 'ResourceWrapper' does not exist in the current context

Failed to compile Mods.dll

Build failed

 

process exited with error code -1

 

 

 

(g:\Full Games\7 Days to Die\Mods - DMT\AnimationSDX\Scripts\MecanimSDX.cs(992,35): error CS0103: The name 'ResourceWrapper' does not exist in the current context) is in yellow

 

(Failed to compile Mods.dll

Build failed

 

process exited with error code -1) is in red

 

I don't know what else to do. I'm reading through the thread (on page 14 and counting) I googled everything about ResourceWrapper I could find, as well as any tutorials on installing this. Nothing came up. I initially tried this with SDX, but updated a few hours ago when I discovered DMT through my troubleshooting efforts. Any help would be appreciated.

 

EDIT: Turns out the link on the front page is out of date. I found this one in the forums and realized Animations was 3 months old there and 4 months old in another. Did the trick. https://github.com/SphereII/SphereII.Mods/

 

EDIT 2: How do I get the npcs to loot for me? Asking them about themselves does nothing. I see no readme or details on the subject. Please, and thank you.

Edited by Tristam (see edit history)
Link to comment
Share on other sites

I'm having installation troubles, myself. Using 17.4, newly downloaded. DMT, newly installed. Only AnimationSDX, aXUI_Dialog, Patch_Entity, SDX_EntityAliveSDX, Xyth Bandits, Xyth NPCs, and Xyth Wandering Traders installed. Whether I check them all off or just AnimationSDX, I get the same error:

 

Running BackupFiles

Backup dll found: K:\K Mods\7 Days to Die\Manager/Backups/SP/17.4b4/Assembly-CSharp.dll

Running DeployDlls

Deploying DLLs

Running LocalisationPatch

Running InitialPatchTask

Compiling PatchScripts assembly for InitialPatch...

Built patch file in 554ms

PatchMods compile successful

Found patcher mods: 1

 

Hooking console commands

Running CreateModDll

Compiling Mods.dll...

Built in 539ms

g:\Full Games\7 Days to Die\Mods - DMT\AnimationSDX\Scripts\MecanimSDX.cs(992,35): error CS0103: The name 'ResourceWrapper' does not exist in the current context

Failed to compile Mods.dll

Build failed

 

process exited with error code -1

 

 

 

(g:\Full Games\7 Days to Die\Mods - DMT\AnimationSDX\Scripts\MecanimSDX.cs(992,35): error CS0103: The name 'ResourceWrapper' does not exist in the current context) is in yellow

 

(Failed to compile Mods.dll

Build failed

 

process exited with error code -1) is in red

 

I don't know what else to do. I'm reading through the thread (on page 14 and counting) I googled everything about ResourceWrapper I could find, as well as any tutorials on installing this. Nothing came up. I initially tried this with SDX, but updated a few hours ago when I discovered DMT through my troubleshooting efforts. Any help would be appreciated.

 

EDIT: Turns out the link on the front page is out of date. I found this one in the forums and realized Animations was 3 months old there and 4 months old in another. Did the trick. https://github.com/SphereII/SphereII.Mods/

 

EDIT 2: How do I get the npcs to loot for me? Asking them about themselves does nothing. I see no readme or details on the subject. Please, and thank you.

 

Glad you were able to figure it out. Yes, the new repos contains the fixed AnimationSDX.

 

The loot AI task is experimental, and not sure how well it works. You would need to add it to the AI Task list for it show up in the dialog.

Link to comment
Share on other sites

Thank you. Yes, I discovered your notes inside the folders after some digging. No idea how to add it to the task list yet, but I'll try it. Your notes also said that the pathing the AI uses does some "zombie" on its way. I don't know what that means. Does it mean they get distracted by enemies? That they burst through walls to get the loot like zombies? Lastly, did you update the front page or are you purposely leaving the new info in the middle of the thread so people need to read through? (I wouldn't blame you)

Link to comment
Share on other sites

Thank you. Yes, I discovered your notes inside the folders after some digging. No idea how to add it to the task list yet, but I'll try it. Your notes also said that the pathing the AI uses does some "zombie" on its way. I don't know what that means. Does it mean they get distracted by enemies? That they burst through walls to get the loot like zombies? Lastly, did you update the front page or are you purposely leaving the new info in the middle of the thread so people need to read through? (I wouldn't blame you)

 

The original post is probably out of date because I change repos too much for others to keep up, sadly. In A18, I want to unify them, and drop SDX and go with DMT fully.

 

Sometimes zombies will start punching blocks or not navigate correctly around obstacles that you'd expect a human to be able to too.

Link to comment
Share on other sites

Thank you. I'm going to try to add it myself, but if you want to give me some details on how it's done, it would definitely save me a headache. Thanks for all your great mods in general though. You and Xyth are the truth.

 

Sure, it's listed in the documentation here: https://github.com/SphereII/SphereII.Mods/tree/master/SDX_EAITasks

<property name="AITarget-5" value="LootLocationSDX, Mods" />

 

I know some other people have enabled it; I'm not sure how they did it.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Having an error on my server in which, I spawn an NPC, hire him. Command him to stay, and a few things happen. Placed bar stools... didnt see them.. killed the NPC BAM. Stools appear.

 

Friend walks into our Community Center bar, I spawn another NPC, hire him, command him to stay. Friend is unable to jump, crouch, or sprint. I can hear him walking around, but only see him walking in place. He says he is right in front of me, but I see him very far away at the bar, me at the door. Kill the NPC, and BAM were staring at each other face to face and he regains full movement again.

 

Happened earlier, but I actually blamed another mod for it. Seems it was this one.

Link to comment
Share on other sites

Having an error on my server in which, I spawn an NPC, hire him. Command him to stay, and a few things happen. Placed bar stools... didnt see them.. killed the NPC BAM. Stools appear.

 

Friend walks into our Community Center bar, I spawn another NPC, hire him, command him to stay. Friend is unable to jump, crouch, or sprint. I can hear him walking around, but only see him walking in place. He says he is right in front of me, but I see him very far away at the bar, me at the door. Kill the NPC, and BAM were staring at each other face to face and he regains full movement again.

 

Happened earlier, but I actually blamed another mod for it. Seems it was this one.

 

Do you have a a log file from the incident? Maybe the NPC was generating some kind of error.

Link to comment
Share on other sites

Do you have a a log file from the incident? Maybe the NPC was generating some kind of error.

 

I don't have a log from that incident, but I do have to say, only with the NPC mod do I get this error, and this is also causing issues currently on my server..

 

nt: 11 (28) Items: 3 CO: 2 RSS: 6086.4MB

2019-11-05T13:23:26 4124.639 INF AIDirector: Scout spawning failed

2019-11-05T13:23:42 4140.783 INF Time: 67.63m FPS: 34.83 Heap: 2668.0MB Max: 2688.1MB Chunks: 547 CGO: 38 Ply: 2 Zom: 3 Ent: 14 (46) Items: 10 CO: 2 RSS: 6094.8MB

Invalid Layer Index '1'

 

(Filename: C:\buildslave\unity\build\Modules/Animation/Director/AnimatorControllerPlayable.cpp Line: 919)

 

Invalid Layer Index '1'

 

(Filename: C:\buildslave\unity\build\Modules/Animation/Director/AnimatorControllerPlayable.cpp Line: 919)

 

Invalid Layer Index '1'

 

(Filename: C:\buildslave\unity\build\Modules/Animation/Director/AnimatorControllerPlayable.cpp Line: 919)

 

 

Used the same mods in A17 and got the same error. We actually had to remove the NPC mod because of it. Wandering trader and Bandits mod works just fine.

 

Removed this mod, error gone. Put the mod back. turn on the server, error is back.

 

EDIT: Server is having the same issue we had back in A17.. players can't join after a certain amount of time, and our server hangs saying a player is still there, when they are not. Happens when they get around NPCs. A player said they hired an NPC for bloodmoon, and then the server crashed and kicked him off, but the server was still on, and unable to have players connect.

 

Also, this spam in log makes it extremely frustrating to debug any errors we may have... 15min of my server being on and my log file size is 12,623,245 bytes......

Edited by jerseyetr (see edit history)
Link to comment
Share on other sites

I don't have a log from that incident, but I do have to say, only with the NPC mod do I get this error, and this is also causing issues currently on my server..

 

 

 

 

Used the same mods in A17 and got the same error. We actually had to remove the NPC mod because of it. Wandering trader and Bandits mod works just fine.

 

Removed this mod, error gone. Put the mod back. turn on the server, error is back.

 

EDIT: Server is having the same issue we had back in A17.. players can't join after a certain amount of time, and our server hangs saying a player is still there, when they are not. Happens when they get around NPCs. A player said they hired an NPC for bloodmoon, and then the server crashed and kicked him off, but the server was still on, and unable to have players connect.

 

Also, this spam in log makes it extremely frustrating to debug any errors we may have... 15min of my server being on and my log file size is 12,623,245 bytes......

 

I'm looking into the Invalid Layer index '1'. We've never tracked down the source yet.

Link to comment
Share on other sites

version 1.55 with dedi fix for animation. Still some command issues left.

 

Quick question, does it make a difference if I'm playing A18 Stable vs. Experimental (18.1)? I'd like to start a new game with this mod, via the mod launcher, and would like to know which version to install.

Link to comment
Share on other sites

Quick question, does it make a difference if I'm playing A18 Stable vs. Experimental (18.1)? I'd like to start a new game with this mod, via the mod launcher, and would like to know which version to install.

 

it should not make a difference what you choose.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...