Jump to content

A17.2 Prefab bounds


Recommended Posts

I'm trying to make a smallish building, a research facility. I have the prefab completed, but the bounds is all off. It always has this very large "dynamic prefab" included with it. When I place the prefab in the world, my building, which is about 25x25 blocks, shows up; but then this huge area close to 100 blocks or more if flattened out around it and it destroys everything in its path. I have even started a brand new prefab, pressed Shift+G, encompassed the prefab, ticked "Show Bounds" then ticked "Calculate Bounds", but no matter what I do, it makes this large greenish "Dynamic Prefab" that I can turn off or on visibility of it in the editor. Doesn't matter if I have it off or on when saving the prefab, it retains it. I have even resized it in the editor and ticked "Calculate Bounds", but it always goes right back to the same size. And I can find no way to resize or disable it in the xml file created with the prefab. I've looked at prefabs included with the game, and all of their bounds and "dynamic prefabes" are nice and tightly fitted to the prefab. What am I missing or doing wrong??




Link to comment
Share on other sites

save your prefab, and back it up.

using the selection functions, highlight/encase/draw a selection box around your entire actual prefab.

ctrl+c to copy it.

on the esc menu, hit "create new prefab"

when it clears into a new blank world

ctrl+v to paste it in the world, you might have to do this twice.

save it, and turn dynamic prefabs back on, you should see a properly sized box.

fiddle with it to get it to correct ground heights.


it's very picky, and might take some doing.


also, after you save it, load a different prefab, and then load yours again. it should align itself to 0,0 on reload.

check bounds again.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...