Jump to content
Damocles

[A19] NITROGEN , a random world generator for 7DtD

Recommended Posts

I've a question. When I try to generate a map with Nitrogen it will say

creating output directory: NitroGenMap  D:\7days\NitroGen_WorldGenerator_v0501\NitroGen_WorldGenerator\output\NitroGenMap
output directory created
... running terrain generation ...
null
Total time taken: 0 min 0 sec

 

 

And then it won't generate a map. Anyone got any ideas why this is happening?

 

Share this post


Link to post
Share on other sites
Posted (edited)
16 minutes ago, CrystalPrelude said:

I've a question. When I try to generate a map with Nitrogen it will say

creating output directory: NitroGenMap  D:\7days\NitroGen_WorldGenerator_v0501\NitroGen_WorldGenerator\output\NitroGenMap
output directory created
... running terrain generation ...
null
Total time taken: 0 min 0 sec

 

 

And then it won't generate a map. Anyone got any ideas why this is happening?

 

 

Hi CrystalPrelude

 

You have java x64 installed and you have loaded the prefablist.txt list for vanilla or for CompoPack.

Have you changed something in the configuration?

Edited by Gouki (see edit history)

Share this post


Link to post
Share on other sites

Actually, I just figured it out. I updated java, but that didn't work. So I tried a previous version, and that DID work.

 

What I discovered is that when I'm installing the new Nitrogen, it isn't creating an output folder in the directory. When I made one, it started working just fine.

Share this post


Link to post
Share on other sites

That's weird, I have the new version, but it's great that it has been fixed.

I guess you didn't name the map and it generates it for you as NitrogenMap, it says so here.

 

I've a question. When I try to generate a map with Nitrogen it will say

creating output directory: NitroGenMap  D:\7days\NitroGen_WorldGenerator_v0501\NitroGen_WorldGenerator\output\NitroGenMap
output directory created
... running terrain generation ...
null
Total time taken: 0 min 0 sec

Share this post


Link to post
Share on other sites

after having a few days playing with nitrogen I have a few questions / feedback

When creating a custom map (using a user defined heightmap file, mask file and biome file) the preview map appears to render vertically flipped.   Initially when I saw this I thought I had to flip my HM and MASK files thinking that the in game map would be upside down otherwise... As it turned out no, the preview map only was being flipped.  Is this something others are encountering?

Will nitrogen allow me to use my custom biome image and incorporate that into the preview map in the future?  Right now it generates its own random biomes.png file which I then overwrite with my custom one once the map is generated but I was unable to get the tools/previewmapgenerator to work with generating a new map preview with my 12K A19 map - I was getting a lot of prefab list errors and ended up copying over the prefab list from the root level resources directory and renaming it to match the prefablist filename in the tools/previewgenerator/resources/ directory.  None of this worked for me with regards to getting a new preview map to generate, it literally sat there for over half an hour running the preview map generator before I ended the console session.  Is this something that will be fixed going forward?

 

Overall thankyou very much for this tool Damocles, it's a great tool, I just wish it would allow me to include my own custom biomes.png file without it needing to generate a new biomes.png if it already exists and if it included an overlay of sorts of the biomes file with the preview map.

Share this post


Link to post
Share on other sites

Good afternoon.Guys, please help me find the version of NitroGen v0. 355 for 7days to die 17.4.
Or maybe if someone still has this version, please share it.

Share this post


Link to post
Share on other sites
Just now, fox4some1 said:

Good afternoon.Guys, please help me find the version of NitroGen v0. 355 for 7days to die 17.4.
Or maybe if someone still has this version, please share it.

 

Hi fox4some1

 

In the main post is the version for A17 stable, check well, I hope it helps you.
Says Old version A17.

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/27/2020 at 8:26 PM, talonofwindspeak said:

NOTRADER.thumb.jpg.c94f5f5e4751d50b3e922ac2b34d3688.jpg

 

Not sure why I get this with the latest Nitrogen + compo pack. Only way I can get the quest to give me a trader location is wiping all save data at the launcher then I will get one map with trader location. If I then make another map I get this... only way is to wipe all stored data again. Therefore I can only have one map at a time as have to always delete everything other save. Seems to me problem is with compo pack. Easiest way to delete compo pack? (remove the prefabs folder?)

I know I've seen a lot of people posting about this lately. I have created a few dozen worlds to test, both co-op and solo. I have noticed if I do a fully normal, default, balanced world gen - traders work just fine. If I do a full snow biome, or full desert, or 'some' variations of the biomes, the 'no trader' error pops up. It's not a name change issue as one person mentioned previously, as with a purely default gen world using this mod, it works just fine. Changing the world/biome setting doesn't affect names or prefab names. So, there is something else going on. I have yet to figure out what or why biome changes would affect initial traders - except (possibly) perhaps some traders are now coded to only spawn in specific biomes and it's causing havoc with the mod....?

 

Edit: just for clarification purposes, I have completely wiped everything from my previous patches and saves. Wiped every file and folder, started 100% fresh. It still happens on my rig and my wife's, unless it's a 'default biome' map.

Edited by Darkwolfe73
typos & missing words :) (see edit history)

Share this post


Link to post
Share on other sites
16 hours ago, Darkwolfe73 said:

I know I've seen a lot of people posting about this lately. I have created a few dozen worlds to test, both co-op and solo. I have noticed if I do a fully normal, default, balanced world gen - traders work just fine. If I do a full snow biome, or full desert, or 'some' variations of the biomes, the 'no trader' error pops up. It's not a name change issue as one person mentioned previously, as with a purely default gen world using this mod, it works just fine. Changing the world/biome setting doesn't affect names or prefab names. So, there is something else going on. I have yet to figure out what or why biome changes would affect initial traders - except (possibly) perhaps some traders are now coded to only spawn in specific biomes and it's causing havoc with the mod....?

 

Edit: just for clarification purposes, I have completely wiped everything from my previous patches and saves. Wiped every file and folder, started 100% fresh. It still happens on my rig and my wife's, unless it's a 'default biome' map.

Upon further testing I can confirm it was because of setting Wasteland only for biome setting. For whatever reason the trader quest can't find trader location on this setting. I looked it up and there are a lot of traders and some were quite close in a city and town but there is some issue between the quest and that location. Spawning in burnt biome seems to be fine as I made the add burnt and wasteland and add more burnt and wasteland and spawning in burnt gives trader location. Haven't gotten a spawn in wasteland yet with those biome selections. Some one else posted that they experienced the same thing and to just keep reloading till you get a trader location in the wasteland, but who wants to keep doing the starting quest over and over. If you want to do a 100% wasteland map you just might have to go cheat mode and give your self a bit of stuff to offset having to take the extra time to find that first trader.

Share this post


Link to post
Share on other sites

OK I am going out of my mind, I have been trying to copy paste , ctrl a and paste dragging to , the prefabs.txt and all I get is a bunch of symbols and messed up lines. If I try to right click copy then right click paste, paste is greyed out and I cant copy over.

 

I am sure it is simple and I am an idiot but someone please help me.

I was able to ctrl a and paste to the 7 days folder but I am trying to get itt into the prefabs for nitrogen.

Share this post


Link to post
Share on other sites

I think I figured it out, I was trying to copy the actual prefabs into the text list.... like I said I am an idiot

Share this post


Link to post
Share on other sites
21 hours ago, Darkwolfe73 said:

I know I've seen a lot of people posting about this lately. I have created a few dozen worlds to test, both co-op and solo. I have noticed if I do a fully normal, default, balanced world gen - traders work just fine. If I do a full snow biome, or full desert, or 'some' variations of the biomes, the 'no trader' error pops up. It's not a name change issue as one person mentioned previously, as with a purely default gen world using this mod, it works just fine. Changing the world/biome setting doesn't affect names or prefab names. So, there is something else going on. I have yet to figure out what or why biome changes would affect initial traders - except (possibly) perhaps some traders are now coded to only spawn in specific biomes and it's causing havoc with the mod....?

 

Edit: just for clarification purposes, I have completely wiped everything from my previous patches and saves. Wiped every file and folder, started 100% fresh. It still happens on my rig and my wife's, unless it's a 'default biome' map.

Hi Darkwolfe! 
I had the same problem... but figured out how to fix it... follow these steps:

1) In Nitrogen\Resources folder, open 'CompoPack_43.txt' in a text editor
2) Look for "//TRADER'S" section, and ADD directly under that header (pushing the others down...) these rows:

trader_bob,none,2,-1,41,27,46,trader
trader_hugh,none,2,-8,45,28,49,trader
trader_jen,none,2,-1,43,24,41,trader
trader_joel,none,2,-1,35,32,35,trader
trader_rekt,none,2,-1,37,24,37,trader

3) Now run Nitrogen again, and the top-right dropdown, select the CompoPack prefab

When you open the map in a new game, you'll see it find a trader!

Share this post


Link to post
Share on other sites

How would I go about generating a world with the "natural" biome option enabled and "north south" off without mountains and plateau's generating in the desert and snow parts of the map while keeping small hills and elevation changes on the map?

Share this post


Link to post
Share on other sites

Hi guys / gals! Super new to using outside programs, is there a video or a step by step guide that shows all the changes that need to be made to make this work for stable 19? Is there even any changes needed? I've heard some say that certain POI text changes are needed to be made but it's all a bit overwhelming for me and I would really love to try and generate the perfect world for me to survive (die) in ❤️ thanks in advance!

Share this post


Link to post
Share on other sites

I have Java x64 installed. Getting this when generating map. Any ideas on the problem and how I may fix it?

 

creating output directory: Walkabout  C:\Program Files\Nitrogen Map Gen\NitroGen_WorldGenerator\output\Walkabout
output directory created
... running terrain generation ...
null
Total time taken: 0 min 0 sec

 

Thanks

Share this post


Link to post
Share on other sites

Is there a way to prevent POI's from spawning in specific biomes? I don't see the option anymore

Share this post


Link to post
Share on other sites

@Damocles
I have been working with your tool since Novmember ALPHA 18! I love your work and this game would be unplayable for a person like me with you bringing CUSTOM MAP PROC to us! <3 <3 <3 

But....

I WANT SO MUCH MORE!!!!!! :)

-Biome settings for wasteland and burnt forest control amount and size of these zones
-DarknessFallZones biome setting in prefablist.txt //commented out by default control amount and size of these zones
-Updated prefablists for DarknessFalls with POI placed according to zone including prefablist for CompoPack45 together and seperate
-Snow zones customize currently you can only set N(Snow) can add desert zones but cannot add snow zones

I loved the addition of water borders, hills on flatland and smoothing! Too smooth though sometimes...

I usually create a 4k map for performance I use tiny for both city and town as these become too large to investigate they seem to work at this size.
I like 2-3 city and 1-2 small town to fill in and all the custom POI I can get, I am now learning to turn off ones I don't want by commenting them out
Maybe you could make one prefablist with every known POI and their counterparts in DF next to each other just commented out for advanced users to edit easier
 

The roads are coming along nicely and the mountain ranges are starting to look cool just need more zone placement options I find myself generating so many maps to get that just one perfect opening.

I was also thinking about something cool maybe you could wait to place the spawn points on the map til the very end of the generation, show us a preview of the map and allow us to click on a location and then place those spawn points!

Anyways hope this gets to you and hopes you find something to do with all this business.... ! Much love 7daystodie

Share this post


Link to post
Share on other sites

So I have a quick question - I have an old map I generated with alpha 18.

Now in alpha 19 i wiped the map data but kept the actual map file when I updated to alpha 19 on the server.

However, I'm getting the "no trader" bug.

Is there any fix for this using nitrogen? Can we not use nitrogen for A19 stable until its updated?

Or how do I go about fixing the "no trader" thing?

I am really hoping I can keep the map I generated, but its not a huge issue if I have to generate a new one.

Does the latest version of nitrogen work with A19 stable is really the most important question???

 

Thanks

Share this post


Link to post
Share on other sites
On 9/1/2020 at 3:24 AM, DBNimble said:

Hi Darkwolfe! 
I had the same problem... but figured out how to fix it... follow these steps:

1) In Nitrogen\Resources folder, open 'CompoPack_43.txt' in a text editor
2) Look for "//TRADER'S" section, and ADD directly under that header (pushing the others down...) these rows:

trader_bob,none,2,-1,41,27,46,trader
trader_hugh,none,2,-8,45,28,49,trader
trader_jen,none,2,-1,43,24,41,trader
trader_joel,none,2,-1,35,32,35,trader
trader_rekt,none,2,-1,37,24,37,trader

3) Now run Nitrogen again, and the top-right dropdown, select the CompoPack prefab

When you open the map in a new game, you'll see it find a trader!

I'm assuming if you generate a map with this list though, their won't be any new A19 POI's on the map?

Share this post


Link to post
Share on other sites

i got the 64bit Java. but I keep getting "null" when I try to generate map

On 8/28/2020 at 6:14 PM, Gouki said:

 

Hi CrystalPrelude

 

You have java x64 installed and you have loaded the prefablist.txt list for vanilla or for CompoPack.

Have you changed something in the configuration?

Whats prefablist.txt ?

Share this post


Link to post
Share on other sites

Hi, how can i make a single massive city that has a fixed number of traders?  I'd like the whole map to be a city.

Share this post


Link to post
Share on other sites
18 minutes ago, 96thousand said:

Hi, how can i make a single massive city that has a fixed number of traders?  I'd like the whole map to be a city.

This will make your game too slow.

Share this post


Link to post
Share on other sites
7 hours ago, CrazyAluminum said:

This will make your game too slow.

Not necessarily. This 4k map is essentially 9 extra large cities, and runs well.

2020-09-06_22h15_10.png.ff508c2dd81875d2f018359bbdd48a1c.png.


 

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...