Jump to content

[A19] NITROGEN , a random world generator for 7DtD


Recommended Posts

You copy the nitrogen map folder (located in the output folder) to the /data/worlds folder for your server. You can use an FTP program to do this. Once this is done, you will need to also edit your serverconfig file to change the following:

 

 <property name="GameWorld"                 value="your world name"/>    

 

You might also want to name your save game file to be the same as your world name.

 

Hope this helps.

Link to post
Share on other sites
27 minutes ago, dragonslayer770 said:

hello all can someone tell me how to get the nitrogen to read the compopack 44 prefab list? 

 

Hi dragonslayer770

 

In Compo pack 44 there is a folder called Nitrogen files, copy the file prefablist.txt and paste it in the Nitrogen Resources folder (rename it or make a backup copy of the prefablist.txt file that is by default in nitrogen).
In the nitrogen Resources folder edit the configPrefablist file and add this: prefablist.txt; CompoPack 44 A19, selecting the prefablist in the program will give you this and now you can have all the prefabs.

Link to post
Share on other sites
50 minutes ago, Gouki said:

 

Hi dragonslayer770

 

In Compo pack 44 there is a folder called Nitrogen files, copy the file prefablist.txt and paste it in the Nitrogen Resources folder (rename it or make a backup copy of the prefablist.txt file that is by default in nitrogen).
In the nitrogen Resources folder edit the configPrefablist file and add this: prefablist.txt; CompoPack 44 A19, selecting the prefablist in the program will give you this and now you can have all the prefabs.

I tried that and it comes up with cant fined file custom list but will try again when i get home.

 

Link to post
Share on other sites
29 minutes ago, dragonslayer770 said:

I tried that and it comes up with cant fined file custom list but will try again when i get home.

 

 

So I have configPrefablist.txt:


// listing of prefabslists
// lists must be present in the resources folder
// filename; description

prefablistA19.txt; A19 Vanilla (default)
prefablist_A18final.txt; A18 Vanilla
prefablist_CompoPack_43.txt; A18 Compo Pack 43
prefablist.txt; CompoPack 44 A19

Link to post
Share on other sites
4 minutes ago, dragonslayer770 said:

Does the prefablist .txt renamed to prefablist.txt; CompoPack 44 A19

 

I rename the original prefablist.txt to prefablistA19.txt; A19 Vanilla (default), to be able to add the prefablist.txt of the compopack and put it like this in configprefablist.txt - prefablist.txt; CompoPack 44 A19, CompoPack 44 A19 should appear like this when you select the list you want.

Link to post
Share on other sites
12 hours ago, Gouki said:

 

I rename the original prefablist.txt to prefablistA19.txt; A19 Vanilla (default), to be able to add the prefablist.txt of the compopack and put it like this in configprefablist.txt - prefablist.txt; CompoPack 44 A19, CompoPack 44 A19 should appear like this when you select the list you want.

still not working, in the configprefablist.txt i have prefablist.txt; CompoPack 44 A19 and the prefablist in the resources file is prefablist_CompoPack_44_A19.txt and it comes up with this C:\Users\username\Desktop\Nitrogen\NitroGen_WorldGenerator\resources\prefablist_compoPack_44 (The system cannot find the file specified), so what do i have to 

change to get the nitroGen to find the file?

Edited by dragonslayer770 (see edit history)
Link to post
Share on other sites
2 hours ago, dragonslayer770 said:

still not working, in the configprefablist.txt i have prefablist.txt; CompoPack 44 A19 and the prefablist in the resources file is prefablist_CompoPack_44_A19.txt and it comes up with this C:\Users\username\Desktop\Nitrogen\NitroGen_WorldGenerator\resources\prefablist_compoPack_44 (The system cannot find the file specified), so what do i have to 

change to get the nitroGen to find the file?

 

the prefablist in the resources file leave it like this prefablist.txt as it comes by default in the compopack.

Link to post
Share on other sites

question yall, how do i configure nitrogen to spread out cities and towns more than it currently is? for some reason no matter what I do towns and cities usually bunch up around one another and leave a ton of empty space in one area. 

 

for those wondering, i have what i assume is the newest a19 nitrogen build, and these are my current settings. most of my maps end up with towns and cities clustered either in the four corners, and very little in the middle, or bunched up in the middle / top / bottom of the map and very little around the edges. any help would be appreciated, i feel like a dumbass doing something wrong lol

 

(and to help you out, @CypherTodd, $20 USD is usually written out as "$20.00")

sgfdssfds.PNG

Link to post
Share on other sites

Is there a way to guarantee a prefab is included? I know you can set up settlements but i have a number of prefabs that i have tagged as unique since I only want one per map but they don't always get picked by the generator. So i have to generate multiple maps and check the prefabs.xml to see if they spawned. Getting multiple unique buildings to spawn on a decent random map is proving to be difficult. For now I have been using the world editor to get results but is very time consuming. 

Link to post
Share on other sites

is there any tried and true "easy" method to get the X,Y,Z coords for the size of a prefab (That's not listed/ custom), as well as the Y offset to make it flush with the ground?  The methods i've tried to use, i'm not sure if i'm using them right.

 

Link to post
Share on other sites

OK so I finally worked out how to make a map properly with compopack, I am using bluefang servers and had to uploaded the prefab list, 680mb 4200 files and took over 4 hours, I made the world in nitrogen uploaded world in nitrogen, and had 4 people playing on server just fine, we went into the wierd shaped book tower and while looting we froze up could move all over map but couldnt kill and couldnt loot, restared same issue. Any ideas?

 

Link to post
Share on other sites

Anyone know what this error is when trying to use =>  visitmap -6144 -6144 6144 6144 (in console)

 

Using 7dtd b180 - live map worked before ....

works with standard in game maps also, so not sure what changed, and sorry, I understand the error, just don't know

why it's happening, or a fix, thanks.

live map error.png

Edited by kokuojeiku (see edit history)
Link to post
Share on other sites

HELP! I've got about 8 hours on this and I am unaware why I am seeing so many load errors on prefabs.

Don't want to read? Video of the problem captured here: https://www.youtube.com/watch?v=0MDzbOHUpcQ

I am using dedicated server at my location.

Prefabs from compo were copied into: C:\steamcmd\steamapps\7_days_to_die\Data\Prefabs

 

Does it need to be elsewhere when running a dedicated server?

 

The map *does* seem to run.

Prefabs from Compo does *not* have a file named "xvanilla_ranger_station1"

 

 

 2020-08-16_16h38_17.png.0dea56409914c85f312b746455db587c.png

 

 

2020-08-16_16h42_44.thumb.png.c6e3d11fbd72364f8feecb16141bb63f.png

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...