Jump to content
Damocles

[A19] NITROGEN , a random world generator for 7DtD

Recommended Posts

If this is the location of your game then yes. Just make sure you copy or move the actual folder that  you created and not just the files.

so in the nitrogen output folder contains the maps you generated and they are called by whatever name you gave in map name within nitrogen copy the folder and its contents.

eg default name is NitroGenMap if you don't change it copy that folder and it's content

Edited by Lancer005 (see edit history)

Share this post


Link to post
Share on other sites
17 minutes ago, truckerraycruz said:

my nitrogen dont have generate combo44 only  for 43 not 44 even though i placed the combo pack for 44 ? what do i generate ? vanilla or 43 combo pack or costume  ? 

use vanilla. it contains the compo 44

Share this post


Link to post
Share on other sites

If I wanted to make more POIs unique when generating a world in Nitrogen, would I simply go to NitroGen_WorldGenerator>resources.prefablist and edit the specific POIs by adding ;unique to the end of each POI entry?

 

for example:

 

xcostum_red_mesa_alpha_labs(by_Pille),egal,2,-33,49,43,47,mountain;unique

Share this post


Link to post
Share on other sites
On 7/28/2020 at 10:26 PM, h0tr0d said:
On 7/28/2020 at 10:03 PM, Darelius said:

Hello, i have a small question:

Why its not possible to create smaller maps, then 4k?

I wanted to create a 1024x1024 map, bit it did not work - it makes automatically 4096 when i use random map size and enter 1024.

 

I wanted to make a game like ages ago, where there was a single town the entire map and each day there were 3-5 airdrops and no zombies at daytime and you had to survive the nights ;)

 

 

...DX

That's navezgane; not  the random-generated worlds.

Edited Tuesday at 11:18 PM by h0tr0d (see edit history)

 

Ergh - and how i can create smaller worlds with nitrogen?

 

 

...DX

Share this post


Link to post
Share on other sites
8 hours ago, fabulux said:

If I wanted to make more POIs unique when generating a world in Nitrogen, would I simply go to NitroGen_WorldGenerator>resources.prefablist and edit the specific POIs by adding ;unique to the end of each POI entry?

 

for example:

 

xcostum_red_mesa_alpha_labs(by_Pille),egal,2,-33,49,43,47,mountain;unique

 

Hi fabulux

 

Yes, one appears per map.

Share this post


Link to post
Share on other sites
1 hour ago, Gouki said:

 

Hi fabulux

 

Yes, one appears per map.

Thanks!

 

I kept generating maps where the cities all had the same 4 buildings or so in the city center, which seems odd when there are soooo many POIs in the list to choose from.

Share this post


Link to post
Share on other sites

I am having troubles with the Generator, cause none of them is having traders (even I didnt turn them off).

 

I wanted to have an only wasteland map and with the prefabs from the Combo pack. I installed the pack in the folder which the vanilla POIs are and generated different wasteland maps. Started the game, started playing, but when it comes to the first trader, it tells me: No Trader.


I couldnt believe it, so I turn flymode on and flew to the next city. But there were no traders at all. For sure I am doing something wrong, but I am very new to these things and wanted many different POIs installed in the game - I dont know what to do.

Share this post


Link to post
Share on other sites
24 minutes ago, Krisrennt said:

I am having troubles with the Generator, cause none of them is having traders (even I didnt turn them off).

 

I wanted to have an only wasteland map and with the prefabs from the Combo pack. I installed the pack in the folder which the vanilla POIs are and generated different wasteland maps. Started the game, started playing, but when it comes to the first trader, it tells me: No Trader.


I couldnt believe it, so I turn flymode on and flew to the next city. But there were no traders at all. For sure I am doing something wrong, but I am very new to these things and wanted many different POIs installed in the game - I dont know what to do.

 

Hi Krisrennt

 

If you already made sure that the option of traders is not turned off, it must be by default or what you have selected.
Apart from this another option in nitrogen to generate traders near the city.
Do you have the latest version of nitrogen?
Did you select the correct prefablist? Because nitrogen brings a prefablist for you to copy and overwrite the one that comes from the Nitrogen program.
Besides, if when doing the start mission to search for the trader, it appears that No Trader is a vanilla problem, not nitrogen.

 

Upload image of how you have nitrogen configured.

  • Like 1

Share this post


Link to post
Share on other sites
29 minutes ago, Gouki said:

 

Hi Krisrennt

 

If you already made sure that the option of traders is not turned off, it must be by default or what you have selected.
Apart from this another option in nitrogen to generate traders near the city.
Do you have the latest version of nitrogen?
Did you select the correct prefablist? Because nitrogen brings a prefablist for you to copy and overwrite the one that comes from the Nitrogen program.
Besides, if when doing the start mission to search for the trader, it appears that No Trader is a vanilla problem, not nitrogen.

 

Upload image of how you have nitrogen configured.

The Traders are activated. I downloaded the prefablist as the combo pack, which was a link in the nitrogen thread.

1.jpg

2.jpg

Share this post


Link to post
Share on other sites
Just now, Krisrennt said:

The Traders are activated. I downloaded the prefablist as the combo pack, which was a link in the nitrogen thread.

1.jpg

2.jpg

 

The new version of Compo pack is 44 (43 causes error in A19) and there is the link in the first post.


In nitrogen you have


City trader: one per city
Traders: many

 

I suppose there are too many traders, you can leave only the Traders option and the City trader option leave it at None.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Gouki said:

 

The new version of Compo pack is 44 (43 causes error in A19) and there is the link in the first post.


In nitrogen you have


City trader: one per city
Traders: many

 

I suppose there are too many traders, you can leave only the Traders option and the City trader option leave it at None.

Thank you for your patience. It seems that this will not be solved as quick as I hoped.

 

I downloaded the 44er Compo Pack and installed it. But it shows me still the 43er in the Nitrogen Program. I never installed the pack before.

 

For testing, I generated a World with the Vanilla prefabs and it seems just fine. The problem is, that there are no prefabs, just the vanilla prefabs. Despite I copied the files from the compopack into the 7DTD folder.

1.jpg

2.jpg

previewMap.png

Share this post


Link to post
Share on other sites
12 hours ago, Krisrennt said:

Thank you for your patience. It seems that this will not be solved as quick as I hoped.

 

I downloaded the 44er Compo Pack and installed it. But it shows me still the 43er in the Nitrogen Program. I never installed the pack before.

 

For testing, I generated a World with the Vanilla prefabs and it seems just fine. The problem is, that there are no prefabs, just the vanilla prefabs. Despite I copied the files from the compopack into the 7DTD folder.

1.jpg

2.jpg

previewMap.png

 

In Compo pack 44 there is a folder called Nitrogen files, copy the file prefablist.txt and paste it in the Nitrogen Resources folder (rename it or make a backup copy of the prefablist.txt file that is by default in nitrogen).
In the nitrogen Resources folder edit the configPrefablist file and add this: prefablist.txt; CompoPack 44 A19, selecting the prefablist in the program will give you this and now you can have all the prefabs.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you for the reply. I did as you said and generated a new world. Everything seemed fine. I started the game and - had the same error. Yesterday I placed some traders manually in my other world, cause there were no traders in it. I reached a trader but couldnt complete the quest. And therefore there are no clearing Zombie quest available. Only the fetch quests are there.

 

This screenshot is from my newest world, you see the quest cant be finished. But as you see on the map there are in the town at least 2 traders so it seems.

 

I really dont know what to do 😕 What I am doing wrong. If I only had to use prefab traders and place them manually - I would do. It took me some hours but after that in the test gaming it was frustrating to see that the game doesnt recognize the traders.


Ok I tested the world again and there are traders there (at least one!)

 

I did a screenshot - please dont mind the bad graphics, my pc is for this game weak.

 

- The Traders are there

- The new POIs are there

- But the Game doesnt "see" the traders.

 

I read that some had to cancel the finding quest and start it again. I did it a few times but the result was always the same.

 

 

1.jpg

2.jpg

3.jpg

Edited by Krisrennt (see edit history)

Share this post


Link to post
Share on other sites
24 minutes ago, Krisrennt said:

Thank you for the reply. I did as you said and generated a new world. Everything seemed fine. I started the game and - had the same error. Yesterday I placed some traders manually in my other world, cause there were no traders in it. I reached a trader but couldnt complete the quest. And therefore there are no clearing Zombie quest available. Only the fetch quests are there.

 

This screenshot is from my newest world, you see the quest cant be finished. But as you see on the map there are in the town at least 2 traders so it seems.

 

I really dont know what to do 😕 What I am doing wrong. If I only had to use prefab traders and place them manually - I would do. It took me some hours but after that in the test gaming it was frustrating to see that the game doesnt recognize the traders.


Ok I tested the world again and there are traders there (at least one!)

 

I did a screenshot - please dont mind the bad graphics, my pc is for this game weak.

 

- The Traders are there

- The new POIs are there

- But the Game doesnt "see" the traders.

 

I read that some had to cancel the finding quest and start it again. I did it a few times but the result was always the same.

 

 

1.jpg

2.jpg

3.jpg

 

That No Trader error is from vanilla, nitrogen has nothing to do with it.
I solved it by finding another trader and talking to him, after talking to the Trader the mission was activated up to 1.2km, lol.

Share this post


Link to post
Share on other sites

Yeah I thought this would solve the problem too. I teleported to every trader on the map but none of them want to finish the quest. 😕

 

If this quest would unfinished, but unlock the Kill Zombie and Find quest, I would be happy. But now only fetch quests are available. I spoke to every trader on the map and all of them have only fetch quests available. Is there a way to force the quest to be completed?

Edited by Krisrennt (see edit history)

Share this post


Link to post
Share on other sites
4 minutes ago, Krisrennt said:

Yeah I thought this would solve the problem too. I teleported to every trader on the map but none of them want to finish the quest. 😕

 

If this quest would unfinished, but unlock the Kill Zombie and Find quest, I would be happy. But now only fetch quests are available. I spoke to every trader on the map and all of them have only fetch quests available. Is there a way to force the quest to be completed?

Did you update your prefabs list to have the NEW trader prefab values??? I suspect you are still using the old trader values. (IN YOUR prefablist.txt under your Nitrogen Installl Directory under Resources)

 

IF you have the Combo Packs install you need to change them to this

xvanilla_trader_bob,none,2,-1,41,27,46,trader
xvanilla_trader_hugh,none,2,-8,45,28,49,trader
xvanilla_trader_jen,none,2,-1,43,24,41,trader
xvanilla_trader_joel,none,2,-1,35,32,35,trader
xvanilla_trader_rekt,none,2,-1,37,24,37,trader


IF you have just vanilla change them to this
trader_bob,none,2,-1,41,27,46,trader
trader_hugh,none,2,-8,45,28,49,trader
trader_jen,none,2,-1,43,24,41,trader
trader_joel,none,2,-1,35,32,35,trader
trader_rekt,none,2,-1,37,24,37,trader



You more than likely still have the old settlement_trader prefabs listed or something else being generated.

Share this post


Link to post
Share on other sites

I would love to have this error. At least then I can understand whats wrong.

 

I did two screenshots. One of them in the game and the other is the prefablist.txt which I am using.

 

 

Trader1.jpg

Trader2.jpg

Share this post


Link to post
Share on other sites
3 minutes ago, Krisrennt said:

I would love to have this error. At least then I can understand whats wrong.

 

I did two screenshots. One of them in the game and the other is the prefablist.txt which I am using.

 

 

Trader1.jpg

Trader2.jpg

Looks like the issue is something else you have a TON of traders
You are using the ComboPack44 correct?

 

I am not getting any of those issues with any of my generated files.

Share this post


Link to post
Share on other sites

15 Traders for a 8k Map is nothing I would consider "a ton". I played a generated nitrogenmap 8k from nexusmods with 24 Traders and did not have the errors.

 

I did everything the compoPack asked me to and never had this problem in any of my games without the compopack.


I would love to understand what the error is, but it seems there is maybe not a solution.

 

I will generate a map with few traders and see, if the error will occur.

Edited by Krisrennt (see edit history)

Share this post


Link to post
Share on other sites

Is there a chance that we could get something that more closely resembles a city design with suburbs?  I frequently end up with mountains of towers and city buildings including apartments, but barely any houses.  I'd love to have some subdivisions spread out with cul-de-sac's and the like on the outskirts of cities.  Preferably having the radius of the city area being 3x as large as they currently are, with a downtown area, an industrial area and then on the outside, the suburbs.

NitroGen is still better than the built-in map generator, as the built-in generator has no guarantees that all POIs would be in the game, many of them missing from a random gen map in-game, while Nitro tends to contain most (if not all) POIs, but there just aren't enough houses in NitroGen.

Share this post


Link to post
Share on other sites

Ok I generated another 8k map with four Traders.

 

The error still occurs. I tried to start the fetch quest, but it wont show it on the map, cause the "no trader" error is there.

 

It seems that I have to stick to just vanilla maps without new prefabs, which is very sad, cause I loved to create my own map. But I dont understand why the "no trader" is showing up. And google couldnt help me with the problem either. Some have problems, to find the trader, which is the quest trader. But I travelled to every one and none of them want to close the quest.

 

Edit: Ok, I tested one of the pregenerated maps, because maybe it was a game error? But on the map, the quest could be completed. So it only happens with the generated map with the Nitrogen generator. Which I find very sad, cause I loved how you handle it with all the settings you can choose. And I would love to solve this problem.

 

Lesstr.jpg

Edited by Krisrennt (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...