Jump to content
Damocles

[A19] NITROGEN , a random world generator for 7DtD

Recommended Posts

The trader prefab names have changed, make sure you update that in your config prefabs list A19 B173
the names are as follows

trader_joel.prefab

trader_rekt.prefab

trader_jen.prefab

trader_bob.prefab

trader_hugh.prefab

 

You can see this in your prefabs folder in your game install Data/Prefabs folder.

Share this post


Link to post
Share on other sites
1 hour ago, FastBurst said:

In 173 they renamed the traders to something else. like trader_hugh, trader_bob etc - this was stated in the ComboPack forum when ComboPack44 released for 173

 

Once the map is generated, you can load it into the worlds folder and open it in the World Editor and add the traders manually as well, as well as any other prefabs and save it.

What you are seeing is possibly the old settlement_01 that use to be used which is no longer used anymore.

 

Oh gotcha, I got it fixed through a post on Reddit and here. ""It turns out I used the wrong prefablist.txt in Nitrogen and to fix it I went into the "Nitrogen files" folder included with Compopack 44 and renamed the prefablist.txt file prefablist_CompoPack_44.txt so that I wouldn't overwrite the prefablist in Nitrogen. I then copied this file to the "Resources" folder in Nitrogen. Finally so that this prefablist would show up in the Prefab List picklist in Nitrogen, I opened the configPrefablists.txt file in Nitrogen and on the line for the custom list I put refablist_CompoPack_44.txt instead of yourownlist.txt. Then I opened Nitrogen as per usual, made sure to select the Custom List prefab list and generated my map." completely solved my issue.

Share this post


Link to post
Share on other sites

Glad to hear it, ComboPack44 already addresses the issue, but for those NOT using it, they need to go in and change the trader prefab names to work correctly IF they are using 173

Share this post


Link to post
Share on other sites
On 7/28/2020 at 3:15 AM, Maharin said:

So... why is NitroGen so much faster than the built-in generator?  I can generate a 16k x 16k map in NitroGen in 5.5 minutes on my not-the-fastest computer.  It takes that long to do a 4k x 4k in the built-in generator.  /boggle

Hi Maharin


Questions: why is NitroGen so much faster than the built-in generator?


Answer: Someone did a much better job, sorry Tfp.

 

  • Haha 1

Share this post


Link to post
Share on other sites

Is there a reason why im not getting a preview image in the preview folder? Also when I put the output folder into my 7DTD worlds folder it does not show up when i go to create a new world. does this have something to do with the A19 being "Experimental"?

Share this post


Link to post
Share on other sites
Posted (edited)

Not the output folder, just put the world folder in there. The preview not being generated may have something to do with not having a world generated correctly.

Make sure you have nothing that isn't supported selected when you generate the world; it overwrites if going into same folder etc.; it was something like that for me the first time.

Check the text at the bottom of the window in Nitrogen for anything indicating something was off.

Edited by h0tr0d (see edit history)

Share this post


Link to post
Share on other sites

What is the smallest possible map to be generated by Nitrogen or any other tool? I tried to input custom size values like 2048 1024 or just simple 1000, but it was reset back to default 4096.

Share this post


Link to post
Share on other sites
21 hours ago, Gouki said:

Hi Maharin


Questions: why is NitroGen so much faster than the built-in generator?


Answer: Someone did a much better job, sorry Tfp.

 

On a side note, now that I've been playing with this thing more, generating a 12k map with "many very large cities" and "many large towns" does take a while.  A bit over 22 minutes on this last run.  That would probably take 3 days with the built-in generator.  :p

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/28/2020 at 5:29 PM, Amcd12 said:

 

Oh gotcha, I got it fixed through a post on Reddit and here. ""It turns out I used the wrong prefablist.txt in Nitrogen and to fix it I went into the "Nitrogen files" folder included with Compopack 44 and renamed the prefablist.txt file prefablist_CompoPack_44.txt so that I wouldn't overwrite the prefablist in Nitrogen. I then copied this file to the "Resources" folder in Nitrogen. Finally so that this prefablist would show up in the Prefab List picklist in Nitrogen, I opened the configPrefablists.txt file in Nitrogen and on the line for the custom list I put refablist_CompoPack_44.txt instead of yourownlist.txt. Then I opened Nitrogen as per usual, made sure to select the Custom List prefab list and generated my map." completely solved my issue.

 

So would that mean we are able to fix it once the world has been launched on a dedicated server, or would we need to wipe to fix the issue?

Edited by Myro (see edit history)

Share this post


Link to post
Share on other sites
19 hours ago, h0tr0d said:

Not the output folder, just put the world folder in there. The preview not being generated may have something to do with not having a world generated correctly.

Make sure you have nothing that isn't supported selected when you generate the world; it overwrites if going into same folder etc.; it was something like that for me the first time.

Check the text at the bottom of the window in Nitrogen for anything indicating something was off.

The only errors i get is when it is about to start running world mapping and it says after ,Warning: prefab list does not contain POIs of type trader, oldwest, highway and highway clutter. I have A19 Vanilla selected for my prefab list, the rest is default. Sorry i didn't mean I put the whole output folder in i mean i am putting the world folder in the "worlds" folder in 7DTD and it is not showing up.

Share this post


Link to post
Share on other sites

Per Magoli post on the new ComboPack44

 

Quote

COMPOPACK_44(for Alpha19exp_built169) is available now !!!

 

to get it go to the openingpost

 

here is the Changelog:

CHANGELOG COMPOPACK 44 :

i asked Pille to do the whole conversation from A18 to A19 for all the CP-prefabs - and he did it inner minutes - thx Pille really appreciate your competent and good work
it was also needed to adjust the brightness of the lit lights for A19 to let them appear like they were in A18 - also thx for that Pille

in detail:

changed following blocks to air in all prefab:
1779   :  treasureChest cntMountainManChest
2250   :  cntBuriedStashChest cntBuriedWeaponChest
2119   :  cntBackpackDropped backpack03Prefab
2670   :  toiletBlockVariantHelper cntToilett01
2667   :  woodFurnitureBlockVariantHelper endTable


exchanged following prefab with newer versions
(thx to TopMinder for keeping his own prefabs always uptodate and also thx for working on some existing CP-prefabs) :

xcostum_4Apartments(by_TopMinder)
xcostum_7EndStore(by_Jackelmyer)
xcostum_Blue_House(by_TopMinder_and_Pille)
xcostum_CanucksCoffee(by_Genosis)
xcostum_Cave1(by_NAGGcommunity)
xcostum_celltower_2(by_axebeard)
xcostum_celltower_2_waste(by_axebeard)
xcostum_ColonyShip(by_NAGGcommunity)
xcostum_deerstand_1(by_axebeard)
xcostum_deerstand_2(by_axebeard)
xcostum_Dormerhouse(by_TopMinder)
xcostum_DriveIn(by_NAGG_Genosis)
xcostum_Experimentalhouse(by_TopMinder)
xcostum_hideout(by_axebeard)
xcostum_hideout(by_TopMinder_and_Pille)
xcostum_Hostel(by_TopMinder)
xcostum_InsaneAsylum(by_Genosis)
xcostum_MinderManor(by_TopMinder)
xcostum_ModernArtGallery(by_Pille_TopMinder)
xcostum_Paintballarena(by_Jackelmyer)
xcostum_PetStore(by_Jackelmyer)
xcostum_research_vessel(by_Pille)
xcostum_Villa(by_TopMinder)


REMOVED:
xvanilla_carlot_03_temp (not available anymore)
xvanilla_remnant_burnt_deco_01 (not available anymore)
xvanilla_remnant_burnt_deco_02 (not available anymore)
xvanilla_theatre_01 (not available anymore)
xvanilla_warehouse_01 (not available anymore)
xvanilla_settlement_trader_01 (renamed)
xvanilla_settlement_trader_02 (renamed)
xvanilla_settlement_trader_03 (renamed)
xvanilla_settlement_trader_04 (renamed)
xvanilla_settlement_trader_05 (renamed)
xvanilla_ranger_station1      (renamed)
xvanilla_theatre_01 (not available anymore)
xvanilla_warehouse_01 (not available anymore)
xvanilla_mp_waste_bldg_01_red (not available anymore)
xvanilla_mp_waste_bldg_02_red (not available anymore)
xvanilla_mp_waste_bldg_03_red (not available anymore)
xvanilla_mp_waste_bldg_04_red (not available anymore)
xvanilla_mp_waste_bldg_05_red (not available anymore)
xvanilla_mp_waste_bldg_06_red (not available anymore)
xvanilla_mp_waste_bldg_07_red (not available anymore)
xvanilla_mp_waste_bldg_08_red (not available anymore)
xvanilla_mp_waste_bldg_09_red (not available anymore)
courthouse_med_02 (not available anymore)
all A18 xvanilla-prefabs (exchanged them with the new A19 versions)


NEW PREFABS :
xcostum_Bookstore(by_Kayido)
xcostum_Bunker(by_Pille)
xcostum_ExcavatorMassGrave(by_Pille)
xcostum_HNHouse(by_Hernan)
xcostum_LazMans_church_01(by_LazMan)
xcostum_Modernhouse02(by_TopMinder)
xcostum_OrigamiGallery(by_Pille_TopMinder)
xcostum_Sawmill(by_Pille)
xcostum_SmallWoodhouse(by_TopMinder)
(all the new A19 vanilla-prefabs)


FIXED:

-added questRallyMarker to xcostum_Bavarian_Bowse_Shop(by_magoli)
-some block-repairs to xcostum_swimmingbath(by_magoli) (roof,water,cactee)
-some block-repairs to xcostum_timbershop(by_magoli) (misrotated bedrolls)
-set rotationvalue to 0 and metavalue to 0 on block256 terrWaterPOI (done to all xcostum_prefabs)


WORKS on PREFABLIST.TXT FOR NITROGEN :
-removed all entries for vanilla-prefabs that are deleted in A19
-added all new vanilla-prefabs to the prefabslist.txt
-renamed all vanilla-prefabs with new names (if needed)
-checked and fixed all sizes, rotations and yoffsets values for all prefabs


Magoli 2020-07-18

 

keep in mind that there is NO RWGMIXER.XML in this COMPOPACK44-Release

pls use the delivered examplemap or use Nitrogen to generate u a own map

 

have fun

 

Share this post


Link to post
Share on other sites

i installed the CompoPak44 as per the instructions there, and when i go to create a new map, the only options for the prefab lists are: A19 vanillia (default), A18 vanillia, A18 Compopak, and Custom. 

is there a file or something i need to add to the Nitrogen files in order to get the option for compoPak44? 

The only thing i have done is copy/paste the prefabs from the folder into my main 7days to die prefab folder. 

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, EpicSpire said:

i installed the CompoPak44 as per the instructions there, and when i go to create a new map, the only options for the prefab lists are: A19 vanillia (default), A18 vanillia, A18 Compopak, and Custom. 

is there a file or something i need to add to the Nitrogen files in order to get the option for compoPak44? 

The only thing i have done is copy/paste the prefabs from the folder into my main 7days to die prefab folder. 

then you missed something. the Nitrogen-Files folder has the new updates for Nitrogen installation

 

Edited by FastBurst (see edit history)

Share this post


Link to post
Share on other sites

ok, thanks.. where do i put them? I see a folder called Nitrogen files (i feel stupid that i overlooked that last night), but i dont see in the install instructions where i am suppose to put those.

Share this post


Link to post
Share on other sites

Resources folder where ever you have Nitrogen installed. Some rename the prefablist.txt file to like combopack44.txt so you have a new option.

 

Me personally I just replaced them as the A19 B169-173 released did change and remove some vanilla prefabs and the replacement txt file accounts for those changes. works perfectly for me no issues.

Share this post


Link to post
Share on other sites

ah ok... i see the txt files in that folder now. thanks. is this step listed anywhere that i missed or is it one of those "dumb people shouldnt play"

Share this post


Link to post
Share on other sites
Posted (edited)

I cant remember if I read it in the forums or just knew when I seen the folders from past installs to be honest. ComboPack43 was the same way.

Edited by FastBurst (see edit history)

Share this post


Link to post
Share on other sites
22 minutes ago, FastBurst said:

I cant remember if I read it in the forums or just knew when I seen the folders from past installs to be honest. ComboPack43 was the same way.

ok, thanks a ton. it seems to be working now. 

Share this post


Link to post
Share on other sites
1 minute ago, EpicSpire said:

ok, thanks a ton. it seems to be working now. 

Awesome glad its working for you.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

I saw someone have this issue earlier in the thread, but must have gotten their answer in DM. So, when I try to generate a map, I get this every time:

 

null

Total time taken: 0 min 0 sec

 

 

Fixed: run as admin

 

Edited by fabulux
fixed issue (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

I'm having continuously the problem that my server can't find the Map. 

--> ERR Error starting dedicated server: Gameworld "NitroGenMap15" not found!

See gist for complete log https://gist.github.com/Sh4mpo/2cb5d8d4c07ca1b9faf3e60118cb34a9

 

My server host is Nitrado

Map direction : /sevendaysexperimental/Saves/GeneratedWorlds

<property name="GameWorld" value="NitroGenMap15" />
 <property name="WorldGenSeed" value="NitroGenMap15" />
 <property name="WorldGenSize" value="8192" />

 <property name="SaveGameFolder" value="C:\SERVICES\ni1019986_1_SHARE\ftproot\sevendaysexperimental\Saves\GeneratedWorlds" />

 

Also tried /sevendaysexperimental/Saves

<property name="GameWorld" value="NitroGenMap15" />
 <property name="WorldGenSeed" value="NitroGenMap15" />
 <property name="WorldGenSize" value="8192" />

 <property name="SaveGameFolder" value="C:\SERVICES\ni1019986_1_SHARE\ftproot\sevendaysexperimental\Saves" />

 

So anyone who can help me and tell me what i'm doing wrong? 

If you need more information let me know.

 

Sh4mpo

 

 

 

FIX!

 

All right, So this is kind off funny.

The way to use a NitrogenMap on a Nitrado server: 

 

Serverconfig.xml

<property name="GameWorld" value="[map name]" />

<property name="WorldGenSeed" value="[map name]" />

<property name="WorldGenSize" value="8192" />

<property name="SaveGameFolder" value="C:\SERVICES\ni1019986_1_SHARE\ftproot\sevendaysexperimental\Saves" />

 

So according to the SaveGameFolder line you'll put them in the Saves folder that is located in the main folder, Well wrong! 

This is the actual place you need to put your map folder in;

C:\SERVICES\ni1019986_1_SHARE\ftproot/sevendaysexperimental/Data/Worlds

You do need to leave SaveGameFolder as: <property name="SaveGameFolder" value="C:\SERVICES\ni1019986_1_SHARE\ftproot\sevendaysexperimental\Saves" />

Do not change this or you'll probably be in trouble. It might work if you change it.

In the explanation from Nitrogen it says to put the folder in "sevendaysexperimental\Saves" That's why I totally forgot about the Worlds folder in Data.

 

This was not the only solution, this way I got it to load until I got an error:
IOException: Sharing violation on path C:\SERVICES\ni1019986_1_SHARE\ftproot\sevendaysexperimental\Data\Worlds\Custom1\dtm_processed.raw

About this I was able to find a solution on other forums. Simply put the map in your singleplayer folder. Start a new game with this new map. Log in, and when you're in game, exit and then copy the file from your singleplayer to your server as mentioned above.

Edited by Sh4mpo (see edit history)

Share this post


Link to post
Share on other sites
On 7/30/2020 at 4:17 PM, Nixstormz said:

The only errors i get is when it is about to start running world mapping and it says after ,Warning: prefab list does not contain POIs of type trader, oldwest, highway and highway clutter. I have A19 Vanilla selected for my prefab list, the rest is default. Sorry i didn't mean I put the whole output folder in i mean i am putting the world folder in the "worlds" folder in 7DTD and it is not showing up.

It goes in the GeneratedWorlds folder inside users/name/appdata/roaming/7daystodie/ I think is what it is

 

Share this post


Link to post
Share on other sites
4 hours ago, h0tr0d said:

It goes in the GeneratedWorlds folder inside users/name/appdata/roaming/7daystodie/ I think is what it is

 

turns out i wasn't even running alpha19 haha thanks however there still is no preview of the map for me

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...