Jump to content
Damocles

[A19] NITROGEN , a random world generator for 7DtD

Recommended Posts

I am running on current exp of 7d2d, with a nitrogen made map.  No issues at this time, so I do not think there is an issue or conflict on the new version of the game.

 

just my experiences.

Share this post


Link to post
Share on other sites
On 7/17/2020 at 6:29 AM, Slawa said:

 

 

Im not using Nitrogen actually but i have/had the same problem in a vanilla a19 map, running as dedicated server.

This is one possibility- I encountered this recently, on a Vanilla map (had this only very recently on an A18 Nitrogen- within the last several weeks only), and found that I can walk through these squares, which led me to believe these are graphic corruptions.  I checked my card temps, and I was at 65 degrees celcius.  The latest iteration of Radeon was not playing nice with the triple fans on my GPU.  No amount of tweaking could counter my cards desire to save energy by not running the fans.  I'm all for energy savings, but at what expense?  So I downloaded MSI's Afterburner and I'm now running a nice cool card, and no more graphic corruptions.  Hope this can be of help.

 

Regards

Share this post


Link to post
Share on other sites
23 minutes ago, LewZephyr said:

I am running on current exp of 7d2d, with a nitrogen made map.  No issues at this time, so I do not think there is an issue or conflict on the new version of the game.

 

just my experiences.

Game console was saying 'map generated in build 151" or something like this, I didn't go further after hearing after inventory breaking and players instadying.

Maybe it works, but I would wait.

Share this post


Link to post
Share on other sites
Posted (edited)

So running map generated with latest Nitrogen on the latest exp 169.  Pure Vanilla POI's

We started playing the map on the exp version prior (forget the number).  All seemed good on the exp prior.

 

In the latest exp, we have had some buildings collapse in spots, for no apparent reason.  In fact while riding our bikes through a city we started hearing some collapses in buildings we were passing by.  They did not seem to have issues in the previous exp. 

 

EDIT --  To be clear we did not start a new game, we continued with the previous save.

 

I am not saying this is a Nitrogen thing / issue.  Just seeing if any others have had similar experiences.

 

On a side note / question.

When playing the Nitrogen maps, we are noticing an excessive amount of the Shotgun Messiah and Shamway factory's.  In fact have had them show up  within a few blocks of each other.

 

What can I tweak to only have them spawn only in City's and only once per city?

 

We are running up a new Map for this exp just using TFP's generator to give it a go and check it out, but I am positive we will be running another Nitrogen map in the near future.

 

Thanks for the work you do.

 

 

Edited by LewZephyr (see edit history)

Share this post


Link to post
Share on other sites
7 hours ago, BeatKitano said:

From what I gathered b169 has difference with nitrogen's RWG and they don't like each other atm.

Waiting for an update to b169

I'm running b169 on my latest Let's Play, am on Day 3, using an edited CompoPack43 prefab list, and haven't had any issues.

 

This doesn't mean there can't BE an issue, just sharing that it does work, at least in my case.

Share this post


Link to post
Share on other sites

Don't get me wrong, I love NitroGen. I wouldn't have donated if I didn't.
 

There is just 1 thing that confuses me a little.

 

Why isn't there biome selections? Just have little radio buttons with the biomes and let us pick which biomes we want on the map.

There must be something in the code to prevent this??

Thanks for all your hard work Damocles!!

Share this post


Link to post
Share on other sites

Is it possible to add back the Boreal Forest and Plains biomes?

 

Those were my favorites and I'm really missing the variety of habitable biomes.

 

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, BadPlayer said:

Don't get me wrong, I love NitroGen. I wouldn't have donated if I didn't.
 

There is just 1 thing that confuses me a little.

 

Why isn't there biome selections? Just have little radio buttons with the biomes and let us pick which biomes we want on the map.

There must be something in the code to prevent this??

Thanks for all your hard work Damocles!!

The biomes and landscape are conceptually linked. Its based on stamps that define heightmaps and biomes for that landscape stamp.

So desert will have its own landscape (flat plains and eroded mesas) . And mountains are either forest, or have a snow top. The forest is kind of the base landscape.

There is the option to add north and south with snow and deserts. Those biomes are "painted" over the underlying landscape. (which can lead to some not good looking transitions)

Wasteland has its own crater landscape.

 

 

In summary: you control the "normal" biomes via the landscape sliders. And can add additional biomes after the normal landscape generated.

 

The simplest way to "mod" the biomes is to simply copy in a biomes.png from an RWG map into the world folder (of the same map size).

 

Edited by Damocles (see edit history)

Share this post


Link to post
Share on other sites

Hi, thanks I really like the generated maps.

So far they seem smoother and I have the feeling the roads arent all ending at a cliff.

 

I didnt test a lot of them so far, but all had something like the picture below. Do I have to turn off mountains to get rid of these canyons?

They are cool, but very annoying. :)

https://imgur.com/a/Iborq9k

Share this post


Link to post
Share on other sites

The generated examples here do look very good. I've been trying to get the program working, but it says that I don't have Java, having installed java using the link in the original post, the console of the program still says that;

#### WARNING #####
Cannot detect a 64 bit Java VM, you might run this program in 32 a bit Java VM. please make sure you run a 64 bit installation of Java to avoid out of memory errors
##############

The path and variables have been checked, pointing them to where I'm certain is correct, and Jave is recognised in the command prompt, but the warning message still occurs and no generation takes place, I'm not sure what to make of this, is there anything obviously wrong here?

Share this post


Link to post
Share on other sites
Posted (edited)

Fixed: Just ran the app as Admin and it's working fine. Doh!

 

I just did a fresh install of Nitrogen with the Compo pack (latest versions that supposedly work with A19), but I'm not getting anywhere when I generate a map. Whether I set everything to Default or change to the Compo prefab list, this is the only progress I get:

creating output directory: Test  C:\Program Files (x86)\NitroGen_WorldGenerator\output\Test
output directory created
... running terrain generation ...
null
Total time taken: 0 min 0 sec

 

 

Edited by silkwormxl
Fixed Issue (see edit history)

Share this post


Link to post
Share on other sites

hello! figured i would ask about the main highway system thats currently in place. i take it that this is a first itteration of it eh? its a very neat idea! a way to get around the map useing straight roads that may require some repair to make them fully functional. is there plans to take this idea further? 

Share this post


Link to post
Share on other sites
1 hour ago, morggin said:

@Damocles is there a way i can regenerate the map preview after replacing the biome.png ?

check under tools, there is a preview generator for exisitng maps.

You might want to replace the prefablist to get the updated A19 version there.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/30/2020 at 2:43 PM, Divinion said:

I got it working, thank you.

 

Next question is: Is there a way to create bigger sizes for biomes instead of just splotches of them across a mostly Grass biome?

 

So how did you get it to work?

 

Answer:

Make certain you download specifically, this file for java:

Windows Offline (64-bit)

(file will look something like this: jre-8u261-windows-x64.exe)

 

When you go to run Nitrogen, I did so from the command console like so;

java -d64 -jar nitrogen.jar

 

That forces the 64 bit version, if an error pops up, you don't have the "64-bit" version installed.

 

Edited by argenex (see edit history)

Share this post


Link to post
Share on other sites

@Damocles

 

Is there a way to tone back the number of the Factories that spawn.   In the last gen I did with Nitrogen, there were so many Shotgun Messiah and Shamway Factories.  In a few cases there were 2 Shotgun factories within blocks of each other.

 

Thanks for your time and insight.

Share this post


Link to post
Share on other sites

i have the 64bit java installed. How much ram can it have a max? i tired giving it 10gb but it wouldn't even use 8 hardly while i was gen a 16k map. which ended up taking alittle over 28mins 

Share this post


Link to post
Share on other sites

Got it working, thank you @argenex!

Have been playing with the program a lot, very good results.

Share this post


Link to post
Share on other sites
9 hours ago, LewZephyr said:

@Damocles

 

Is there a way to tone back the number of the Factories that spawn.   In the last gen I did with Nitrogen, there were so many Shotgun Messiah and Shamway Factories.  In a few cases there were 2 Shotgun factories within blocks of each other.

 

Thanks for your time and insight.

Not directly. What you can do is edit the resources/prefablist.txt and add the zone "industrial" to a bunch of houses for example.

This will increase the number of houses placed in the industrial "locations", and thus have less of the factories and other industrial/commercial type buildings.

Each city will spawn a certain number of POIs for each zone. So assigning POIs to that zone will change the mix.

 

You could also add the zonetype "unique" to the factories, which will make them only spawn once per map.

Share this post


Link to post
Share on other sites
On 7/9/2020 at 8:46 AM, sirwin44 said:

I create a map using NitroGen and using Compo pack, corrected for A19. Some POIs load correctly at first, then glitch out. Is there a fix to this? Pics attached to show what im experiencing.

 

 

before.png

after.jpg

That is a vanilla bug. Work arounds are exit the game fully and re enter game or possibly turn off vsync worked for another who had that issue.

Share this post


Link to post
Share on other sites

@Damocles, any chance that you could add an "add burnt forest option" without linking it to the wasteland? 

Share this post


Link to post
Share on other sites

Hello,

I've just installed this for A19 and everything works fine except when the find trader starter quest begins it says "No Trader" and provides no way point.

Is there a way to fix this? I've tried creating two different maps but both end up with the same issue.

Share this post


Link to post
Share on other sites
Posted (edited)
34 minutes ago, caatalyst said:

Hello,

I've just installed this for A19 and everything works fine except when the find trader starter quest begins it says "No Trader" and provides no way point.

Is there a way to fix this? I've tried creating two different maps but both end up with the same issue.

 

Hi caatalyst

 

It is a vanilla bug, it has nothing to do with nitrogen.

It is fixed upon finding another trader, at least that's how it happened to me.

Edited by Gouki (see edit history)

Share this post


Link to post
Share on other sites
8 hours ago, Gouki said:

 

Hi caatalyst

 

It is a vanilla bug, it has nothing to do with nitrogen.

It is fixed upon finding another trader, at least that's how it happened to me.

Ahh so i just need to find any trader on the map to complete the quest?

Share this post


Link to post
Share on other sites

house_modern_15 is added in b167.

prefablist.txt code is

 

house_modern_15,USED,2,-4,31,18,46,houses
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...