Jump to content
Damocles

[A19] NITROGEN , a random world generator for 7DtD

Recommended Posts

RWG places waterspawners every 8 meters (even denser) in a regular grid all over the map. (water_info.xml)

I suppose they know internally that the water "flood-filling" is buggy here.

In theory a few dozent water spawners would suffice. But I guess that would be a tricky problem to solve given the chunked nature of the world. (its generated parts at a time ingame, and the water is a complex volume spanning many chunks)

 

What I could do is making the water-grid even denser here.

 

--------------------

 

The dept of the water is controlled by the water-level (in the configs) and the stamps.

The stamps are not flexible enough to change the water level in the fly. It would require recalculating the final terrain map internally to change

those levels. (like raising or lowering the typical lake ground levels) Its possible, but not implemented.

 

--------------------

 

The other project is also game related, but in the very early stages, too early to show anything (and not related to 7DtD).

 

thanks for the info Danicles i'll take a look at the config file :) still editing the world itself and using your program to rebuild the main body (reusing final map) and its working good so far, i'll play with the water some more, and check the config file. thinking i may take and make the water area around it 'less' deep and see if that changes anything, some of the water area goes down to 2 from 32, so that shouldn't be too hard to test and see if less water down willl clear up some of the bugs as well. just mainly trying to get it cleared away from the shorelines, worse comes to worse I could always try building a few prefabs to go over the missing water spots, be abit time consuming but thats one way to fix it.

 

i donno if making it more dense would really help, as you pointed out before their RNG worlds have the same issues with missing water volumes, and their water info files weigh in at 20k vs. your 2k file, having larger bugs in them at times then yours with larger bodies of water.

 

would love to see the other project when it comes out, I play alot of different games and am always intrested in good working tools for customization :) being able to change things in the games is something thats always brought new life into them for me.

 

Cheers & thanks!

Share this post


Link to post
Share on other sites

I dont know if its nitrogen that is doing this or something else but some distant POI's look like spikes of blocks going way in the air, then as you get closer it turns into a sky scraper ?

 

I dont remember this happening in before. Im using the "Default" prefabs.

 

Thoughts? Thanks

Share this post


Link to post
Share on other sites
I dont know if its nitrogen that is doing this or something else but some distant POI's look like spikes of blocks going way in the air, then as you get closer it turns into a sky scraper ?

 

I dont remember this happening in before. Im using the "Default" prefabs.

 

Thoughts? Thanks

 

its normal with that skyscrapper, your seeing the LOD for it, i donno why it has large land mass for its LOD mesh but it does. I thought something wierd was going on too but it happens in the pregen worlds as well.

Share this post


Link to post
Share on other sites
I dont know if its nitrogen that is doing this or something else but some distant POI's look like spikes of blocks going way in the air, then as you get closer it turns into a sky scraper ?

 

I dont remember this happening in before. Im using the "Default" prefabs.

 

Thoughts? Thanks

 

Yeh doesn't just happen on skyscrapers to. Def nitrogen. Possibly a rwg and nitro issue but it see doesn't just happen with skyscrapers

Share this post


Link to post
Share on other sites
Yeh doesn't just happen on skyscrapers to. Def nitrogen. Possibly a rwg and nitro issue but it see doesn't just happen with skyscrapers

 

if its nitrogen causing it i'd like to know how, i didn't replace the default skyscraper and the LOD is loaded from the prefab itself not from the map. thinking it may be something related to the last update rather then nitrogen, I've only seen it with the one skyscraper, what have you seen it with?

Share this post


Link to post
Share on other sites
if its nitrogen causing it i'd like to know how, i didn't replace the default skyscraper and the LOD is loaded from the prefab itself not from the map. thinking it may be something related to the last update rather then nitrogen, I've only seen it with the one skyscraper, what have you seen it with?

 

Any prefab that is taller then a certain height. But it was there prior to recent release of 18.2 b5. It could be the game engine but with nitrogen creating the world I don't know which.

 

I have only just started another map yesterday all keep an eye if it happens again. I did notice it was when I was in god mode also and looking into the distance..

Share this post


Link to post
Share on other sites

Hi - I downloaded the most recent version of Nitrogen and installed 64-bit Java (the windows offline download; checking java version in powershell shows 64-bit VM machine listed in the results).

 

When I try any of the file options to start Nitrogen (the application, the jar file or the batch file), the window for the app loads up and then closes 1 second later. When I try running it manually from the command prompt, it runs through all the loading dialog but shows no errors. Any idea what I'm doing wrong here?

Share this post


Link to post
Share on other sites

I just tried nitrogen and flew over some maps.

 

In general it's really nice. Especially the towns are far better then the original RWG.

Just two points are imho not so good:

 

1. Generating POIS in hilly regions create these ugly cones around them. Would it be possible to not generate POIs in places where the land is sloping? Maybe just create them on top of a mountain but not on the mountains side?

E.g. i got huge cities almost on completely flat land. On the one side of the city the land kept flat, on the other side were mountains. Where was the really huge airport generated? Right in the flank of the mountain, half height of the mountain with a perpendicular wall on the city side and with perpendicular wall into the mountain on the other side.

 

2. Rivers... they are nice when you are on terrain near "sea level". But once the terrain becomes a higher level or even hilly/mountains, the rivers all become really thight valleys. I don't know how the engine with water works, but wouldn't it be possible to use an algorithm for rivers like for the roads, just inverted? So that they generate over different heights on ground level and look for ways with little slope down? Then even rivers would indeed flow from mountains down to lower ground.

 

And another point for little improvement: Streets. Haven't tested all options yet, but the small streets are just to small for citites. You're standing in a city with skyscrapers around you and the streets look like in a small village of the middle ages. The small streets seem fine for outer urban regions, like small villages, but for big towns they are to small. Maybe switch the streets similar to the poi-placing algorithm? Wide streets in a city center, narrow streets in the residential areas and smaller villages? Additionally even highways between cities would be really awesome.

Edited by Liesel Weppen (see edit history)

Share this post


Link to post
Share on other sites
RWG places waterspawners every 8 meters (even denser) in a regular grid all over the map. (water_info.xml)

I suppose they know internally that the water "flood-filling" is buggy here.

In theory a few dozent water spawners would suffice. But I guess that would be a tricky problem to solve given the chunked nature of the world. (its generated parts at a time ingame, and the water is a complex volume spanning many chunks)

 

What I could do is making the water-grid even denser here.

 

--------------------

 

The dept of the water is controlled by the water-level (in the configs) and the stamps.

The stamps are not flexible enough to change the water level in the fly. It would require recalculating the final terrain map internally to change

those levels. (like raising or lowering the typical lake ground levels) Its possible, but not implemented.

 

--------------------

 

Just touching bases back with you on the water bug I've been experiencing, leveling the sea level didn't help, the bugs still appear in the same area. Moving the 2700 block of water to the top of the file cleared up a lot of them, don't ask me why, but they vanished from along most the shore lines. I still have one large one out in the ocean that I can't seem to get to go away without producing new water bugs.

 

Earlier you mentioned a TGA I could edit for the clay shore lines, could you tell me which TGA I would edit for that? thanks.

Share this post


Link to post
Share on other sites

I'm having an issue with the 'output folder'. Default in NitroGen is C:Windows\system32/output/NitroGenMap/ but when i hit the Generate World button the program gives me an error 'wrong working directory, generation aborted'. Can't seem to change the default folder location either.

Share this post


Link to post
Share on other sites

Hallo there!

 

First: Absolutely great tool! I tinkered around a bit and eventually came up with the near perfect map I'm enjoying right now.

However I ran into a problem when I wanted to try out another map created via NG with my brother.

I simply cannot invite him to join via steam. Usually no problem: I just invite him into the lobby directly by rightclicking his username in my friendlist. Works perfectly fine when playing a standard map like navezgane or even a custom created map in 7DTD. But with any NG created map I just can invite him to observe (and yes: players are set to 2 ;) ). He has got the respective maps in his game folder too and they're build withe vanilla setting only. But he's running 7DTD on a Win8.1 PC while I created the maps with W10. Maybe this is the issue, but I don't know for sure. Is there any way to connect directly? Or does anyone have other ideas?

Any help would be aprreciated.

Share this post


Link to post
Share on other sites

So, I'm trying to get a NitroGen generated map to work on a pingperfect server, and I followed the A18 specific instructions listed here:

https://pingperfect.com/index.php/knowledgebase/60/7-Days-to-Die--Uploading-an-Existing-world.html

 

When I've got the Game World/World Gen Seed/Game Name all set to the same thing, which I think it should be based on how NitroGen creates maps, the server doesn't initialize at all. If I change the Game World to RWG then it does, but players cannot connect. Does anyone know how to make this work at all?

Share this post


Link to post
Share on other sites
So, I'm trying to get a NitroGen generated map to work on a pingperfect server, and I followed the A18 specific instructions listed here:

https://pingperfect.com/index.php/knowledgebase/60/7-Days-to-Die--Uploading-an-Existing-world.html

 

When I've got the Game World/World Gen Seed/Game Name all set to the same thing, which I think it should be based on how NitroGen creates maps, the server doesn't initialize at all. If I change the Game World to RWG then it does, but players cannot connect. Does anyone know how to make this work at all?

 

those instructions are for uploading your saved game from a existing 7 days to die world, i.e. default world or preinstalled worlds on the server.

 

to get the nitrogen map to be able to be accessed by the server I believe you'd have to do the same as on your pc and place them in the folder for c:\Users\{YOUR WINDOWS USERNAME}\Documents\7 Days to Die\Generated Worlds in order for you to be able to play it on the ping perfect server. If it only has a save file to work with, your not going to be able to play the world on the server.

Share this post


Link to post
Share on other sites

i absolutely love this tool.

 

i would like to make a suggestion, however, I'm not sure how easy it would be to implement. i would like to see an option, maybe a slider like the landscape section, but for biomes. so we can dictate how rare or common a specific biome is.

 

I love having the border set to wasteland, and that being the only area waste land is, but doing this removes burnt forest from my world because there is no choice to just have wasteland removed.

Share this post


Link to post
Share on other sites
I'm having an issue with the 'output folder'. Default in NitroGen is C:Windows\system32/output/NitroGenMap/ but when i hit the Generate World button the program gives me an error 'wrong working directory, generation aborted'. Can't seem to change the default folder location either.

 

Not sure but if an output folder with that name already exist, get sure that you set this option:

LUW6Gmd.png.f9c80743909437d57747537daa7086f7.png

 

Otherwise the generation will be aborted.

 

Or try to change the map name.

Share this post


Link to post
Share on other sites

Please tell me how to scatter the house on the map and not only that they were in the city, make them lonely as farmers.

 

sorry use translit.

Share this post


Link to post
Share on other sites

to get the nitrogen map to be able to be accessed by the server I believe you'd have to do the same as on your pc and place them in the folder for c:\Users\{YOUR WINDOWS USERNAME}\Documents\7 Days to Die\Generated Worlds

I was a little confused by this path recently, as a similar path is also mentioned in the OP...

 

I put the generated map first into %appdata%/7 days to die/Saves/, but that of course was wrong.

I could not find a "generated worlds" folder anywhere.

 

Finally i found out for dedicated server the generated files need to got to c:\[yourdeciatedserverpath]\data\worlds\[yourmapname].

Share this post


Link to post
Share on other sites
I was a little confused by this path recently, as a similar path is also mentioned in the OP...

 

I put the generated map first into %appdata%/7 days to die/Saves/, but that of course was wrong.

I could not find a "generated worlds" folder anywhere.

 

Finally i found out for dedicated server the generated files need to got to c:\[yourdeciatedserverpath]\data\worlds\[yourmapname].

 

You need to generate a world in the game to create Generated Worlds folder. Or make it yourself, like Mods folder for example.

Share this post


Link to post
Share on other sites
You need to generate a world in the game to create Generated Worlds folder. Or make it yourself, like Mods folder for example.

Nope, if i generate a world the dedicated server saves the raw world in the path i wrote.

If i copy the nitrogen files to this path it works also.

 

The files generated out of this, so the actual chunks, goto %appdata%\Roaming\7 days to die\Saves

Edited by Liesel Weppen (see edit history)

Share this post


Link to post
Share on other sites
Nope, if i generate a world the dedicated server saves the raw world in the path i wrote.

No, that's only if you have a very non-standard server configuration. Blazha is correct in that by default they go to %appdata%/7DaysToDie/GeneratedWorlds.

 

If i copy the nitrogen files to this path it works also.

Yes, not recommended though.

 

The files generated out of this, so the actual chunks, goto %appdata%\Roaming\7 days to die\Saves

Yes, that's save data, not worlds, and that of course goes to the saves folder :)

Share this post


Link to post
Share on other sites

For some reason the JAVA link in the OP directed me to the 32 bit version, even though I need the 64 bit. So if anyone else gets an error mentioning needing java, even after you have it installed, that might be why!

Share this post


Link to post
Share on other sites
No, that's only if you have a very non-standard server configuration. Blazha is correct in that by default they go to %appdata%/7DaysToDie/GeneratedWorlds.

That's the absolute default configuration as it gets downloaded with steamCMD. I haven't changed anything with paths. Still it does not create any "Generated Worlds"-folder even if i let the server generate a map himself, but does put the worlds where i said.

No idea what should be wrong with my or your installation, but they seam to work different. :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...