Jump to content

(A20/A19) bdubyah's modlets


bdubyah

Recommended Posts

10 hours ago, Nerhesi said:

Quick and perhaps noobish question:

 

I've been testing out A20 wasteland locally - getting a lot of issues with those null reference exception errors when I check out the specific Wasteland Mod POIs. It seems to be issues with spawning the wasteland NPCs.... Is this a mod thing or a general game thing? For example, I'll go the Remenant_wasteland poi, the consol will come up and scroll 7-15 errors instead of spawning actually super mutants. However, I'll notice that the animals were spawned fine (snakes, wolves, vultures, etc).

 

Is this an issue with Wasteland? Is it an issue with me zooming around in god mode? thanks

I tried to replicate this issue as follows:

1. Start the game with EAC off.
2. Join a dedicated server that also has EAC off to reflect the new trader .dll feature. Joining the dedicated server really puts The Wasteland to the test as the demands are typically higher.

3. Visit the remnant_wasteland_01 Prefab.

 

The result was a clean spawn of the Mutant type entities. And yet another swing at me showed responsiveness after I upset their slumber.

 

20220117142609_1.thumb.jpg.7693f884a56250bf86669fbe00c741f4.jpg

 

I checked the console and it was clean where it specifically related to The Wasteland mod. There was one warning though, but it was a Vanilla warning about the snake pain sound. It might have been suffering the same fate I was facing.

  • Thanks 1
Link to comment
Share on other sites

Hi Bdubyah, Thanks for always making great mods.
I've been waiting for The Wasteland mod to support A20. I'm really looking forward to playing it.

By the way, I found the 'PerkShotgunMessiahSlugs' line in progression.xml looked like this, and the same bundle recipe as the complete reward was unlocked.

    <append xpath="/progression/perks/perk[@name='perkShotgunMessiahSlugs']/effect_group">
        <passive_effect name="RecipeTagUnlocked" operation="base_set" level="1" value="1" tags="ammoBundleMagnumBuckshot"/>

I'll report back if I find anything else while playing.
 

Link to comment
Share on other sites

9 hours ago, arramus said:

I tried to replicate this issue as follows:

1. Start the game with EAC off.
2. Join a dedicated server that also has EAC off to reflect the new trader .dll feature. Joining the dedicated server really puts The Wasteland to the test as the demands are typically higher.

3. Visit the remnant_wasteland_01 Prefab.

 

The result was a clean spawn of the Mutant type entities. And yet another swing at me showed responsiveness after I upset their slumber.

 

20220117142609_1.thumb.jpg.7693f884a56250bf86669fbe00c741f4.jpg

 

I checked the console and it was clean where it specifically related to The Wasteland mod. There was one warning though, but it was a Vanilla warning about the snake pain sound. It might have been suffering the same fate I was facing.

 

Very cool and thank you. I wonder if it has something to do with a simple edit to the gamestages files:

 

I edited the gamestages files with a minimal change (and only realised this recently, sorry). I doubled the values of the sleeper spawns (num="1" and maxalive="1" were changed to 2). I dont know enough about the base game, but is it possible there is a conflict to the game trying to spawn "too many" mobs/mutants in this case?

 

It isn't 100% reproducible so I'll keep trying to narrow down the scenario.

Link to comment
Share on other sites

Hello Bdubyah,

i'm testing your mod now and found an mistake in progression.xml

<attribute name="attLuck" name_key="attLuckName" desc_key="attLuckDesc" icon="ui_game_symbol_loot_sack">
            <effect_group>
                    <passive_effect name="LootGamestage" operation="perc_add" level="2,8" value="5,35"/>
              		<passive_effect name="LootGamestage" operation="perc_add" level="9,10" value="40,50"/>


                    

Your values multiply the LootGamestage value from 5 to 35 times and then 40 and 50 times. 
I tested it on player lvl 300 and after LootGamestage 10k u can't find any loot. 

According to description it may just increase 5% - 35% - 40% - 50% 
Mb values schould be 5,35 - > .05, .035 — 40,50 -> .4, .5 ?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...