Jump to content

🧙 Sorcery Staff Weapons Now LIVE! (v0.96) 🔥❄️


Devrix

Recommended Posts

hi dev, Does the mod work on single or multiplayer? any discord group for lastest news?

 

i read here thatit should work on both:

Though I've tested the living hell out of Sorcery personally, there's only so much a single creature can do. Bug Reports of any and all kind are welcome and encouraged. Specific areas of interests, aside from general, atm are:

 

Server Multiplayer Testing

Existing World Integration (latest game version)

Mod / Modlet Integration

Link to comment
Share on other sites

hi dev, Does the mod work on single or multiplayer? any discord group for lastest news?

Sorcery works on both Single and Multiplayer. This should include dedicated servers with no problem.

 

The Sorcery Discord Channel can be found on Guppy Server:

https://discord.gg/75fkGTs

I'll be posting updates, news and support there alongside here.

 

Hi. Lightning is not available yet right? Because I don't see any lightning file inside the "Resources" folder.

That's correct. Lightning is next for major development, then Traps. Core features are in place, but for now you can just harvest the Lightning Essence... stocking up, if you'd like.

Link to comment
Share on other sites

The mod looks awesome, messed round with for a few mins. Couple questions.

 

Do you have a discord?

 

Also we have a whole new skill tree with TONS of perks. Have your raised the skills we get per level or found some other way to get us skills to compensate for this?

Link to comment
Share on other sites

The mod looks awesome, messed round with for a few mins. Couple questions.

 

Do you have a discord?

 

Also we have a whole new skill tree with TONS of perks. Have your raised the skills we get per level or found some other way to get us skills to compensate for this?

Hey Kage, using a dedicated Sorcery Channel on Guppy Server Discord to keep everything and everyone in one place:

 

The Sorcery Discord Channel can be found on Guppy Server:

https://discord.gg/75fkGTs

 

All initial spent skill points to unlock and attain Sorcery are reimbursed at the end of the Intro Quest. Beyond that, once a game bug with Buff Kills is resolved, you'll be able to complete Sorcery Mastery Quests that'll grant additional skill points. These are already locked and loaded into the crafting Conjures for Fire and Ice.

Link to comment
Share on other sites

rotfl I found a quirk! Got to the epic level crafting for the armor on the fire conjure and found that I can't craft the boots! [ATTACH=CONFIG]28070[/ATTACH]

Whoops, good find! I'll push out a hotfix when back at my computer tonight or first thing tomorrow.

Link to comment
Share on other sites

My nephew and I just found this mod on the mod launcher ~1 hour ago. I finished eating, got back to my computer, installed, and ran the mod without issue. My nephew keeps running into the same error every time he tries to run the mod on his computer.

 

POP: Build error at stage 2: Compiler executable file csc.exe cannot be found.

 

I have deleted the mod, verified the file integrity of the game files through steam, and downloaded the mod again on his computer and he's still getting the error. This is the first mod from the launcher that we've had an issue with, (other than right after 17.2 came out and mods weren't yet updated.)

 

Any clue what we might need to do to get my nephew's computer playing this mod?

Link to comment
Share on other sites

Hotfix Patch for v0.68

 

Hotfix Patch for v0.68

This hotfix patch properly enables Boot crafting recipes in Conjures for Epic and Legendary tiers.

Additionally, skill point rewards have been slightly increased for the Intro Quest to compensate for the yet to be implemented Sorcery Quests (pending game bug fix, affecting Buff Kill Recognition):

Quest Spawned Entities Killed by Buffs Fail to Reward Kills

Link to comment
Share on other sites

My nephew and I just found this mod on the mod launcher ~1 hour ago. I finished eating, got back to my computer, installed, and ran the mod without issue. My nephew keeps running into the same error every time he tries to run the mod on his computer.

 

POP: Build error at stage 2: Compiler executable file csc.exe cannot be found.

 

I have deleted the mod, verified the file integrity of the game files through steam, and downloaded the mod again on his computer and he's still getting the error. This is the first mod from the launcher that we've had an issue with, (other than right after 17.2 came out and mods weren't yet updated.)

 

Any clue what we might need to do to get my nephew's computer playing this mod?

 

Sorry about the trouble. It looks like he may be missing some .NET versions. I'm not sure exactly which one, maybe 4.0 or 4.5.

Link to comment
Share on other sites

Thanks Sphereii. It seems that Microsoft has finally gotten .NET to only need the current version, as 4.7.2 was installed and prior versions of 4.# wouldn't install because something more current was installed. However, Microsoft still has 3.5 SP1 still available for download. After installing that and restarting, Sorcery installed and ran without any issue. :)

Link to comment
Share on other sites

v0.68 Localization Sexification Patch

This Localization only patch adds elemental and rarity color coding throughout Localization (text/descriptions) and clarifies a lot of the previously confusing text that existed. To update manually, drop the new Localization.txt over the old one. Otherwise, Pre-Sync Mod within the Mod Launcher:

sorcery-localization-armor.png

 

sorcery-localization-skills.jpg

 

 

There's a loud thunder in the distance...

 

sorcery-localization-lightning.png

Link to comment
Share on other sites

Hey there, having some issues with the mod on my server. I have the Local.txt file changed and the mod loads on start up and Its in the console at the main menu but nothing shows up in perk menu of crafting menu. Any help testing let me know I can send my logs. Cheers, Murray

 

heres a pic of mod loaded https://steamcommunity.com/id/dmurrayyy/screenshot/927086512537208230

Edited by dmurrayyy (see edit history)
Link to comment
Share on other sites

Hey there, having some issues with the mod on my server. I have the Local.txt file changed and the mod loads on start up and Its in the console at the main menu but nothing shows up in perk menu of crafting menu. Any help testing let me know I can send my logs. Cheers, Murray

heres a pic of mod loaded https://steamcommunity.com/id/dmurrayyy/screenshot/927086512537208230

Hi Murray, from the log it's attempting to load from "Sorcery-master". It should just be "Sorcery", so it sounds like the directory is wrong.

 

Make sure to follow these steps verbatim, specifically step #4:

MANUAL: Modlet, Pure XML

You install Sorcery just as you would any other pure XML Modlet. However, I cannot stress enough how horrible your experience will be (no text in-game) if you do not follow these steps of adding the (Localization Text):

 

 

  1. Download: Sorcery-master.zip (latest version)
  2. Unzip: Sorcery-master.zip
  3. Drag-n-Drop: The Sorcery folder only, found within the unzipped Sorcery-master folder, directly into your Mods folder (\7 Days To Die\Mods). Create the Mods folder here if it doesn't already exist.
  4. Verify Mod Path: (\7 Days To Die\Mods\Sorcery)
  5. Open Localization: (\7 Days To Die\Mods\Sorcery\Localization.txt)
  6. Copy All Text: CTRL+A then CTRL+C (or right-click: Select All then Copy)
  7. Open Game Localization: (\7 Days To Die\Data\Config\Localization.txt)
  8. DELETE OLD SORCERY LOCALIZATION TEXT (if updating from older version): Found at the very bottom of the Localization file, you'll delete the OLD Sorcery Localization Text that you previously pasted in the last update. You can easily detect the start of the text as it is separated by many blank lines and starts with the following text: "SORCERY_START,,LOCALIZATION,,START,,,,,".
  9. Paste Localization: Scroll to the very bottom/end of the main game Localization.txt you just opened. Ensure there is no more text, just blank space. Now create one new blank line by pressing Enter. Then Paste the Sorcery Localization you Copied earlier: CTRL+V (or right-click blank space at the very bottom/end, then: Paste)
  10. Verify & Save: If everything looks good, Save the Localization.txt file: CTRL+S
  11. AWAKEN ESSENCE: You're ready to play as a post-apocalyptic harbinger of the elements... may your training commence!

 

Link to comment
Share on other sites

SORCERY (v0.69) - STABLE IS NOW LIVE!

 

Sorcery v0.69 - STABLE:

  • Stable: Playthrough Ready
  • Attaining Sorcery is much faster (Intro Quest)
  • Fire Essence Harvesting +300% (Intro Buff)
  • Conjure Crafting Time Reduced
  • Conjure Crafting Ingredients Reduced
  • Localization / Descriptions Greatly Clarified
  • Localization / Descriptions Color Coded

 

Update Sorcery

MANUAL

Follow the Manual: Modlet, Pure XML Download steps found below (overwriting old files).

 

MOD LAUNCHER

Select Sorcery and Pre-Sync Mod within the Mod Launcher... done!

 

 

Download Sorcery

MANUAL: Modlet, Pure XML

You install Sorcery just as you would any other pure XML Modlet. However, I cannot stress enough how horrible your experience will be (no text in-game) if you do not follow these steps of adding the (Localization Text):

 

 

  1. Download: Sorcery-master.zip (latest version)
  2. Unzip: Sorcery-master.zip
  3. Drag-n-Drop: The Sorcery folder only, found within the unzipped Sorcery-master folder, directly into your Mods folder (\7 Days To Die\Mods). Create the Mods folder here if it doesn't already exist.
  4. Verify Mod Path: (\7 Days To Die\Mods\Sorcery)
  5. Open Localization: (\7 Days To Die\Mods\Sorcery\Localization.txt)
  6. Copy All Text: CTRL+A then CTRL+C (or right-click: Select All then Copy)
  7. Open Game Localization: (\7 Days To Die\Data\Config\Localization.txt)
  8. DELETE OLD SORCERY LOCALIZATION TEXT (if updating from older version): Found at the very bottom of the Localization file, you'll delete the OLD Sorcery Localization Text that you previously pasted in the last update. You can easily detect the start of the text as it is separated by many blank lines and starts with the following text: "SORCERY_START,,LOCALIZATION,,START,,,,,".
  9. Paste Localization: Scroll to the very bottom/end of the main game Localization.txt you just opened. Ensure there is no more text, just blank space. Now create one new blank line by pressing Enter. Then Paste the Sorcery Localization you Copied earlier: CTRL+V (or right-click blank space at the very bottom/end, then: Paste)
  10. Verify & Save: If everything looks good, Save the Localization.txt file: CTRL+S
  11. AWAKEN ESSENCE: You're ready to play as a post-apocalyptic harbinger of the elements... may your training commence!

 

 

LAUNCHER: Mod, SDX

Sorcery is fully integrated into the 7D2D Mod Launcher, as an SDX Mod, with automatic Localization handling... praise The Gods (and @sphereii)! If you already have the latest version of the Mod Launcher, simply run it and install Sorcery there. Otherwise, follow these steps to get started:

 

 

  1. Steam Sync: Open Steam, right-click 7 Days to Die, select Properties, select Local Files, select Verify Integrity of Game Files. This will ensure you're using a clean version of the game, which is required for use with the Mod Launcher.
  2. Download Launcher: 7D2D Mod Launcher
  3. Install Launcher: Run the launcher installer SetupInstaller.msi
  4. Run Launcher: Locate and select Sorcery within the mods list.
  5. Install Sorcery: With Sorcery selected, click Install Game Copy.
  6. Delete Mods Folder: You may be prompted to delete a detected Mods Folder; I recommend selecting "Yes". You can install additional Mods with Sorcery later, if desired.
  7. Pre-Sync Mod: Finally, select Pre-Sync Mod, then "Yes" you would like to download it.
  8. AWAKEN ESSENCE: Play Mod and you're ready to play as a post-apocalyptic harbinger of the elements... may your training commence!

 

** Game Updates: You must Uninstall and Reinstall Sorcery through the launcher when new game updates are released. Don't worry, your saves are safe and will be retained. If you experience any errors, repeat step #1.

 

** Visit @sphereii's 7D2D Mod Launcher Thread for more info regarding it

Edited by Devrix (see edit history)
Link to comment
Share on other sites

Mod Launcher Error Resolution

 

Mod Launcher Error (Resolution)

Most Mod Launcher errors come from not having a specific version of Microsoft .NET Framework installed, as determined by @sphereii (the developer). It's been discovered by various users that installing .NET Framework 3.5 SP1 resolves their issues.

 

You can find the official versions of .NET at Microsoft:

Microsoft .NET Frameworks

 

7d2d-sorcery-wiki.png

Edited by Devrix
Added Wiki Link (see edit history)
Link to comment
Share on other sites

  • Devrix changed the title to 🧙 Sorcery Staff Weapons Now LIVE! (v0.96) 🔥❄️

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...