Jump to content

Trader quest corrupted in-game world chunk?


Recommended Posts

Hello Community!


First of all, sorry for my bad english... :D I want a little help if anyone can provide. I dont want to post this yet in bug report forum, because i dont know what causing this.


Some days ago i did a TIER V - Fetch / Clear quest in a APARTMENT_BRICK_6_FLR named apartment building, but the quest is bugged, i was unable to finish it and canceled it, i reported it on the bug report forum. Today one of my mates got a quest to the exact same building where i did that quest, and he started the quest with the "!" mark on the building garage ramp immediately when arrived the place. After he started the quest and entered the building he noticed there is no zombies spawned inside the building, only the containers respawned, otherwise the whole building is completely empty. Im at somewhere else in that time on the server but also i noticed when he entered that building the server stopped loading chunks around me and just dropped from the game world under the texture. After we noticed the problem he tried to leave his quest area but he also dropped under the game world when tried it. After we did a server restart and relog, he tried to enter the building again but its still totally empty and the whole chunk problem popped again. Since then anyone on the server going too close to that building, the server stops loading chunks. I get the quest from the trader to the exact same building so i thought the re-spawn mechanic of the quest will fix the problem but no, just still have the empty building and the chunk problems while we are in that area. I checked on the server logs, and i found the following error message spammed the log file:


2019-02-03T22:15:18 341.264 ERR GetBlock failed: _y = 0, len = 64 (chunk -88/12)

IndexOutOfRangeException: Array index is out of range.

at ChunkBlockLayer.GetAt (Int32 offs) [0x00000] in <filename unknown>:0

at ChunkBlockLayer.GetAt (Int32 _x, Int32 _y, Int32 _z) [0x00000] in <filename unknown>:0

at Chunk.GetBlock (Int32 _x, Int32 _y, Int32 _z) [0x00000] in <filename unknown>:0


(Filename: Line: -1)


The whole log file is here:



Any solution to fix the building so that does not freeze the server when someone gets nerby it?

Server log.txt

Link to comment
Share on other sites

Tier V quests are a known issue atm. It's in the Patch Notes.


I understand that. But in my case, there is a corrupted chunk on the server which can be fixable i think via resetting that chunk by deleting that region section file from the server, so the server maybe re-generating it when next time a player going into that area. The problem is i dont know which region file contains that house exactly. Our RWG map size is 6144, and the coordinates of the exact center of the problematic house on the map is: 191 N - 1416 W

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...