Jump to content

Local to server issues?


Recommended Posts

I posted this in Multiplayer, but I realize it will likely be answered here more so...


Copied over everything. Got it to load, start and when I log in, it puts where our base is out of the area and we die shortly after due to radiation. The whole city we were in is now out of the map.


Some things that I noticed were different:



The game won't start unless I use "Navezgane". So I copied the save game folder in there. It should be "New Batowo Valley" but it won't take that nor "Random Gen". The server fails to start with anything else.


The old directions on moving a local save to a server are broken. That would work easily for A16, but with A17, it's a bit more involved.


I made sure I had the right WorldGenSeed, WorldGenSize, GameName, etc.


Any tips to try and fix that so we don't have to just start over?

Link to comment
Share on other sites

<property name="GameWorld" value="New Batowo Valley"/> <!-- RWG (see WorldGenSeed and WorldGenSize options below) or any already existing world name in the Worlds folder (currently shipping with Navezgane) -->


2019-02-03T13:30:57 4.947 ERR Error starting dedicated server: GameWorld "New Batowo Valley" not found!


Tried Random Gen, etc. All get that same error. Navezgane is the only one that actually will get the server to start (my local game was saved in the "Saves\New Batowo Valley\Name" folder. While I don't think that's the only problem, I see that as a part of it, if it's trying to load a seed that doesn't fit that map profile. I mean, we can start over just the same, but everything will be Navegane based instead of Random.


Searches are coming up empty, maybe it's the way I'm searching for the keywords, but everything seems geared towards A16 serverconfig files..

Link to comment
Share on other sites

Did a whole bunch of testing with a buddy tonight.. He logged in and wasn't in radiation and it was just like the map we had. Whereas I'm always in radiation. I deleted all my saved games both in \Saves & \SavesLocal, tried again and it doesn't download the map from the server or anything, just launches me in and radiation right off the bat, as well as some weird graphic glitches I just noticed.


In the 'Data\Worlds\' folder, I took the contents of the 'New Batowo Valley' and put them into my 'Navezgane' and tried that. Spawned in, no radiation and I'm not out of the map. However, when I hit "M" for the map, it only shows about 1/2 of the map, even where I'm at is outside of where I can see.


So this just makes it fun... lol

Link to comment
Share on other sites

Yeah, I'm an idiot..


For future searches or people having issues with A17's config (the official wiki is not updated w/ the new fields)


<property name="GameWorld" value="RWG"/>


Those values are RWG or Navezgane. Nothing else. Not Random Gen, not any of the world names, nothing but those two options. That took care of it all on my end. Not sure how my buddy didn't end up with any of the issues I did, maybe because my saved game was the first ever map he connected to.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...