Jump to content

Help with my prefab editor please


Recommended Posts

Hi im having trouble geting into the prefab editor it keeps giving me an error when it trys to load my character in the loading screen and i cannot figure out how to fix it. i tryed deleting my custom character because the problem started when i made it and i also deleted the empty map in the files because i was told before that it was another way to fix it but still no luck. im really not sure what to do at this point to fix this.

Error code:



Link to comment
Share on other sites

not using mods at all just trying to make some bases and stuff in the prefab editor. i remember i got in when i first downloaded the update(A17) but after i made a custom character it seemed to go to sht and i couldnt even join regular games with the CC eather so i feel thats to blame so i deleted it but im still geting the error on loading the prefab editor

Link to comment
Share on other sites

Looks like you are being stopped from even entering the prefab world due to a messed up file.


Look in youruserdirectory > AppData > Romaing > 7DaysToDie > Saves > Worlds > Playtesting

If you have previously loaded prefabs and saved, you will have worlds in here.

When there is an update, these worlds can have problems just like regular saves.


Try deleting all of the folders in there, if any.


(Each of those worlds has a main.ttw file by the way. Problem is I have no idea which one has the bad one. In my opinion, the prefab editor should not save a world, just the prefab. I don't know why they do this. When I launch the prefab editor, I don't really care if it auto-loads the last prefab. I would much rather the world was always empty until I load a prefab. This way, when there is an update, I don't have to worry about these saved worlds too)


Now, if you don't have any worlds saved in there, then the main.ttw it is referring to is the one it grabs from the other 7D2D folder (found wherever your steam apps are saved) If that is the case, delete main.ttw from SteamApps > 7 Days To Die >Data > Worlds > Playtesting and possibly SteamApps > 7 Days To Die >Data > Worlds > Empty ... and then revalidate so fresh copies of these are installed.

Link to comment
Share on other sites

I just fixed this same issue myself. The editor would crash with an error in the console just after the player was created.


Go into your 7DTD Game folder . Mine was in


F:\Games\SteamLibrary\SteamApps\common\7 Days To Die\Data\Worlds


and delete the folder callled "Empty"


Now navigate to your save games. Mine was in.




and delete the folder called "Empty"


Go back to the steam portal and Right click on the 7DTD game and select properties.


Select LOCAL FILES Tab and click the "Verify integrity of Game Files.


Steam will check the files. Mine took about 5 minutes.


When finished it might say 5 files were found and will be downloaded at next game start.


Start game. Editor worked fine for me after that.


Regards AussieWombat



[EDIT] Mine didn't work when you just delete the Empty folder in your worlds folder. You have to delete both folders. [\EDIT]

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...