Jump to content

NEW ZOMBIE TEXTURES - Mumpfy


Mumpfy
 Share

Recommended Posts

1 hour ago, xyth said:

My understanding was no probability means probability = 1

 

 

Then what would be the purpose of having a probability = "1" setting? If  "0" is no chance and "1" is a 100% percent chance, that indicates that "1" is guaranteed to spawn.

 

So if you have 4 zeds listed and only one of them has the probability = "1" setting, which one will spawn if you only spawn one?

 

I am not saying you are wrong, just trying to understand how it works.

Link to comment
Share on other sites

The spawn probability of a zombie in a group is based on the total probability of that group.  So if there is 10 zombies in the group, each with a probability of 1, then the total probability of the group is 10.  Any one zombie with a probability of 1 has a 10% (1/10 of the total) chance of spawning if one zombie should spawn.  

  • Like 1
Link to comment
Share on other sites

I'm pretty sure Xyth is correct. I do know that it's not a simple probability where 0=no chance and 1=certainty.

 

Take a look at the animal groups in entitygroups.xml. They all use "prob" values in the double digits - for example, the prob value for a rabbit in "WildGameForest" is 48. I don't think there's a "4800% chance" of spawning a rabbit.

  • Like 1
Link to comment
Share on other sites

  • 4 months later...

thats cool. i just installed the game is good to know.

 

so there are new zombies and still checking which ones work with replace material and which ones need to be redone entirely.

will eventually release a new version. knowing that the old one still works idk yet what ill do.

 

feeling tempted to do a couple new skins for them all, but may get lazy and just do the new ones. who knows.

  • Like 1
Link to comment
Share on other sites

1 hour ago, Mumpfy said:

thats cool. i just installed the game is good to know.

 

so there are new zombies and still checking which ones work with replace material and which ones need to be redone entirely.

will eventually release a new version. knowing that the old one still works idk yet what ill do.

 

feeling tempted to do a couple new skins for them all, but may get lazy and just do the new ones. who knows.

Cool, you might want to wait for the stable release since the old version works out of the box. Who knows, maybe they'll change stuff.
One thing I noticed is that since there are 5 variations per ZM introduced, when playing with this you'll see the newer models a lot less often and Boe, Yo, big Mama and the others a lot more often. Maybe someone'll find that "immersion Shattering" but not me 😅

Link to comment
Share on other sites

The RAD version of each zed its calling a mesh on the xmls, Pimps changed that name/location whatever so each of those lines (just one line per zed really) needs to be modified on entity classes. Someone with a bit of xml skills can probably fix it in short time. if that happens please feel free to share the fix here.

 

Me? i hate xmls so i may look it up and fix it eventually but right now im focused on using the little free time i have till next year on checking and working on the new models.

 

I would say the easy way would be to comment my rad versions out for now until we got it sorted.

 

 

Edited by Mumpfy
404 english not found (see edit history)
Link to comment
Share on other sites

4 hours ago, Ozzland said:

Is the simple xlm fix for the A19 version something you can post here so we can update and use your mod in A20 while we are waiting for new version?

 

Or do you suggest disabling the radiated types for now?

If I'm not mistaken, taking a very superficial look I think that the change was that property 
ReplaceMaterial0 -> Mesh

So replacing those SHOULD fix it? maybe? who knows...

Edit: 

Nope, it wasn't that

 

Edited by Shino (see edit history)
Link to comment
Share on other sites

Also, idk if this has already been pointed out but your Radiated zombies lack the annoying Radiated hp regen. Which is weird because I remember them having it on a19. 

Edit: I did a quick dirty fix you can put before the closing config tag on entityclasses.xml
 

    <!-- Sugar's dirty fix for health and regen -->
    <insertAfter xpath="/entity_classes
    	/entity_class[contains(@name, 'HDVRadiated')]
    	/property[@value='buffGuppyRadiationLeak']">
    	<effect_group name="RadRegen">
    		<passive_effect name="HealthMax" operation="perc_add" value="4"/>
			<triggered_effect trigger="onOtherDamagedSelf" action="ModifyCVar" target="self" cvar="RadiatedRegenAmount" operation="set" value="4"/>
			<triggered_effect trigger="onOtherDamagedSelf" action="AddBuff" target="self" buff="buffRadiatedRegen"/>
		</effect_group>
    </insertAfter>


Originally there was a 5 instead of a 4 but 1700 health felt a little bit too much 

Edited by Shino (see edit history)
  • Thanks 1
Link to comment
Share on other sites

yes, im just starting to slowly work on the a20 zombies that wasnt in the original hd pack, so there will be an a20 mod update eventually.

s l o w l y. . .

 

mid time the old pack works with minor fixes that were posted here already by ozzland. (i did not checked, but im a man of faith)

 

Edited by Mumpfy
old man memory (see edit history)
Link to comment
Share on other sites

13 minutes ago, Mumpfy said:

yes, im just starting to slowly work on the a20 zombies that wasnt in the original hd pack, so there will be an a20 mod update eventually.

s l o w l y. . .

 

mid time the old pack works with minor fixes that were posted here already by ozzland. (i did not checked, but im a man of faith)

 

I'm also a man of faith, so I have faith you will eventually release the official version for A20 that'd be the real deal, thanks.

Link to comment
Share on other sites

  • 4 weeks later...
On 1/17/2022 at 2:35 PM, noname835 said:
Hello,
There are one or more special manipulations to perform to play with your Z?

the new pack for a20 is coming.... not soon. having a lot of personal issues so really little time to mod.

 

the OLD version mostly works, the rad models need a little xml fix that is posted by someone above in the thread. i have not checked it but that should work.

 

I will keep posting images of the new models until i got them all and then eventually launch the a20 new pack, that will be highlighted in the main page once ready.

  • Like 3
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...