Jump to content

7D2D Crash after Windows 10 Updates


Recommended Posts

OS - Windows 10

Game - Build Alpha 17 B240


Before the Windows update everything ran without problems. The game crashes right after the luncher.


Installed Windows Updates:

http://support.microsoft.com/?kbid=4480979 Security Update KB4480979 1/9/2019

http://support.microsoft.com/?kbid=4483234 Security Update KB4483234 1/9/2019


Error.txt : https://justpaste.it/23j09

output_log__2019-01-09__18-08-02: https://justpaste.it/4furf


Crash.dmp: https://file.io/Df9Fac

Link to comment
Share on other sites

You possibly got new display drivers with the update, it seems to be crashing when it's trying to load your GPU up.


Try deleting your video card drivers and reinstall the latest ones from AMD / NVIDIA. Stuff usually goes haywire when MSUpdate gives you GPU drivers.

Link to comment
Share on other sites

According to Eventlog the update did not touch the drivers. Anyway, I uninstalled the nvidia drivers and downloaded and installed them again directly from nvidia. Unfortunately this didn't work, the game still refuses to start (no matter if EAC or noEAC).


i also had the game checked for validity in the steam (everything was ok). I completely deleted the settings of 7D2 within %APPDATA%, just like everything before without success.


If i change in the Launcher options from DirectX 11 to GLCore it works.


Edit: after some research in the support forums of steam i came across the citrix, which has nothing to do with the topic and also not with the update, can create problems with unity? Now I have uninstalled Citrix Workspace, and the game starts again ?!?! Ok, now I have to think about how I can still use Citrix for my work and still play, maybe 2 user profiles.


Edit2: after looking deeper in the crash.dmp, this seems to be a (known) bug with unity in combination with the citrix display driver.

> UnityPlayer.dll!__crt_strtox::parse_integer<unsigned long,class __crt_strtox::c_string_character_source<wchar_t> >(struct __crt_locale_pointers * const,class __crt_strtox::c_string_character_source<wchar_t>,int,bool) Unbekannt

UnityPlayer.dll!wcstoul() Unbekannt

UnityPlayer.dll!GetDisplayAdapterPropertyWMI() Unbekannt

UnityPlayer.dll!windriverutils::GetDisplayDriverVersionString(int,class core::basic_string<char,class core::StringStorageDefault<char> > &) Unbekannt

UnityPlayer.dll!GraphicsCaps::InitD3D11(void) Unbekannt

UnityPlayer.dll!CreateD3D11GfxDevice(void) Unbekannt

UnityPlayer.dll!CreateClientGfxDevice(enum GfxDeviceRenderer,enum GfxCreateDeviceFlags) Unbekannt

UnityPlayer.dll!CreateGfxDevice(enum GfxDeviceRenderer,enum GfxCreateDeviceFlags) Unbekannt

UnityPlayer.dll!InitializeGfxDevice(void) Unbekannt

UnityPlayer.dll!InitializeEngineGraphics(bool) Unbekannt

UnityPlayer.dll!PlayerInitEngineGraphics(bool) Unbekannt

UnityPlayer.dll!UnityMainImpl(struct HINSTANCE__ *,struct HINSTANCE__ *,wchar_t *,int) Unbekannt

UnityPlayer.dll!UnityMain() Unbekannt

7DaysToDie.exe!__scrt_common_main_seh() Unbekannt

kernel32.dll!00007ffcbc7f3034() Unbekannt

ntdll.dll!00007ffcbd783691() Unbekannt

which is strange, as it worked without problems before and only appeared after the windows update.

Link to comment
Share on other sites

  • 8 months later...

same issue here.


uninstalled ctx workspace and it starts again --> according to https://forum.unity.com/threads/problem-with-citrix-workspace.589342/ there is a fix in (newer?) unity versions available.


disabling the ctx graphics driver did not help, but it worked instant when the software got uninstalled. not an optimal solution though, nobody uses ctx for fun. :D



edit: yay, seems to have fixed itself, however..!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...