Jump to content

Can anyone help with some recipe issues?


Recommended Posts

I'm making some custom food recipes, trying to test them out.


The recipes are recognised, but I can never click the Cook button.

Is this to do with progressions?


Here's my code:

<append xpath="/recipes">

<recipe name="StrawberryJamSandwich" count="50" craft_area="Campfire">

<ingredient name="StrawberryJam" count="50"/>

<ingredient name="Bread" count="50"/>




Laugh at me all you want! :-) It's just a test.

With all ingredients present and so on, I just can't figure out why the cook button is greyed out. All I can think is it must be something to do with the progressions XML.


Any help would be appreciated here.

And just so you know, I'm well aware that a Jam Sandwich isn't made in a campfire!!!!


Edit: this recipe works while crafting in backpack. This has to be to do with the progressions, right?

Link to comment
Share on other sites

I'm not sure if I understand what you mean, Darkaft. I'm wondering if a certain progression level must be reached before I can use the campfire to craft different foods. I have a feeling it must be that, seeing as the recipe crafts fine in my backpack.


Edit: Is there a line of code to specify which master chef progression level unlocks certain recipes?

Link to comment
Share on other sites

For example this is the original recipe of the Recog

I have marked you if you have to learn or not.


<recipe name="drugRecog" count="1" craft_area="chemistryStation" tags="learnable">

<ingredient name="resourceAcid" count="5"/>

<ingredient name="drinkJarGrainAlcohol" count="1"/>

<ingredient name="resourceScrapPolymers" count="5"/>

<ingredient name="drugVitamins" count="1"/>





This would be the same but put for my mod in this case, it is not learned but it is by time. The obvious recipe that is in xml recipes

<recipe name="drugRecog" count="2" craft_area="Set Barrels" craft_time="80" craft_tool="toolBeaker" >

<ingredient name="resourceAcid" count="2"/>

<ingredient name="drinkJarGrainAlcohol" count="2"/>

<ingredient name="resourceScrapPolymers" count="2"/>

<ingredient name="drugVitamins" count="2"/>



From what I've seen if you want it to be crafted in your backpack and not in the campfire you have to remove the field craft_area. That field if it is filled with a specific station or place is only done there.


Another example is the yucca, both the juice and the smoothie, both are made in the backpack


<recipe name="drinkJarYuccaJuice" count="1">

<ingredient name="foodCropYuccaFruit" count="2"/>

<ingredient name="drinkJarBoiledWater" count="1"/>



<recipe name="drinkYuccaJuiceSmoothie" count="1" tags="learnable">

<ingredient name="foodCropYuccaFruit" count="4"/>

<ingredient name="foodCropBlueberries" count="4"/>

<ingredient name="medicalSnowberryExtract" count="1"/>

<ingredient name="resourceSnowBall" count="1"/>

<ingredient name="drinkJarEmpty" count="1"/>


Link to comment
Share on other sites

Yes. I had to make a Mods folder in the local 7dtd folder. New folder in there with my mod name. From there, Data>Config>items.xml


There's no code for that. Just open your local 7 days to die folder, create a folder called Mods, create a folder inside that with the name of your Mod. Within that folder, create another one called Data, then another inside that one called Config, and there's where you'll be placing your modded XML's.

Link to comment
Share on other sites

I would quick test this change as well -> craft_area="campfire"


That worked! Thanks!

So I assume that the progression system for cooking is just when you need to use tools like the grill and everything?


Thanks again! Just spiritually sent you a beer.

Link to comment
Share on other sites

Awesome glad that worked. It’s confusing what things are case sensitive and what things aren’t lol


- - - Updated - - -


The learnable tag can gate the recipe. I haven’t dug into that system deeply yet so can’t say exactly how it works.

Link to comment
Share on other sites

I am creating new mutant crop so I can later create new mutant Super Stew, anyhow working on my first crop I also could not get the the craft button to highlight, I found I had to add the name of my new item into one of the tiered statements in the tag area in the progression file, so it is recognized when it can be crafted or cooked. For me the player needs to be at level 4,5 to craft the seeds from the plant see below. It looks like this is a similar set up for cooking


<passive_effect name="RecipeTagUnlocked" operation="base_set" value="1" level="4,5" tags="plantedGraceCorn1,Super Potato Seed"/>


So for your cooking if you want it to be level 5 try this

value="1" tags="drinkYuccaJuiceSmoothie,foodChiliDog,StrawberryJamSandwich"/>

<passive_effect name="RecipeTagUnlocked" operation="base_set" level="5,5".


Also where are you getting the Jam from, are you just custom making a recipe or are you growing something new? anyhow hope you get it to work

Link to comment
Share on other sites

I'm now trying to figure out where to specify how long the craft will take. Seems like the default is 25 seconds. Do you have any idea about that?


Edit: irrelevant. Sorted.



I believe most things have a built in weight based on the resource they use when crafted. You can simply add this and adjust to see fit. Check your item and see what resource it uses. Go to that resource and add this to adjust that resource or make a new resource and make it however you like. <property name="CraftingIngredientTime" value="10"/> Some will already have this line and you may need to just adjust the value


Edit: Derp didn't see that you already figured it out. Cheers!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...