Jump to content
sphereii

sphereii's DMT Mods

Recommended Posts

Guest belowzeros

sphereii can Legacy Distant Terrain be added and removed to a save without issue? I wanted to test the benefits on my rig but didn't want to break anything if I remove it.

Share this post


Link to post
Share on other sites
sphereii can Legacy Distant Terrain be added and removed to a save without issue? I wanted to test the benefits on my rig but didn't want to break anything if I remove it.

 

Yes it can. I haven't had a single report where it causes issues to be added or removed. Happy testing!

Share this post


Link to post
Share on other sites

Hoping maybe somebody here can help me. I downloaded & installed DMT, largely because I wanted to use some of Sphereii & Xyth's mods. However, I can not get it to work & since installing it, now non DMT mods won't work. Not sure what I am doing wrong. Been fighting with it for 5 hours now. Would be grateful for any advice.

Edit: I did another complete fresh install, removed all non DMT mods & it still won't run. This is the error I'm getting. Any ideas?

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,54): error CS1061: 'InControl.PlayerAction' does not contain a definition for 'GetBindingXuiMarkupString' and no extension method 'GetBindingXuiMarkupString' accepting a first argument of type 'InControl.PlayerAction' could be found (are you missing a using directive or an assembly reference?)

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,80): error CS0103: The name 'XUiUtils' does not exist in the current context

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,120): error CS0103: The name 'XUiUtils' does not exist in the current context

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,189): error CS1061: 'InControl.PlayerAction' does not contain a definition for 'GetBindingXuiMarkupString' and no extension method 'GetBindingXuiMarkupString' accepting a first argument of type 'InControl.PlayerAction' could be found (are you missing a using directive or an assembly reference?)

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,215): error CS0103: The name 'XUiUtils' does not exist in the current context

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,255): error CS0103: The name 'XUiUtils' does not exist in the current context

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\Blocks\BlockMortSpawner.cs(187,116): error CS0103: The name 'DestroyedResult' does not exist in the current context

Failed to compile Mods.dll

Build failed

 

process exited with error code -1

Edited by MandyCMoore (see edit history)

Share this post


Link to post
Share on other sites
Hoping maybe somebody here can help me. I downloaded & installed DMT, largely because I wanted to use some of Sphereii & Xyth's mods. However, I can not get it to work & since installing it, now non DMT mods won't work. Not sure what I am doing wrong. Been fighting with it for 5 hours now. Would be grateful for any advice.

Edit: I did another complete fresh install, removed all non DMT mods & it still won't run. This is the error I'm getting. Any ideas?

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,54): error CS1061: 'InControl.PlayerAction' does not contain a definition for 'GetBindingXuiMarkupString' and no extension method 'GetBindingXuiMarkupString' accepting a first argument of type 'InControl.PlayerAction' could be found (are you missing a using directive or an assembly reference?)

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,80): error CS0103: The name 'XUiUtils' does not exist in the current context

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,120): error CS0103: The name 'XUiUtils' does not exist in the current context

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,189): error CS1061: 'InControl.PlayerAction' does not contain a definition for 'GetBindingXuiMarkupString' and no extension method 'GetBindingXuiMarkupString' accepting a first argument of type 'InControl.PlayerAction' could be found (are you missing a using directive or an assembly reference?)

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,215): error CS0103: The name 'XUiUtils' does not exist in the current context

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\MusicBoxes\MusicBox.cs(121,255): error CS0103: The name 'XUiUtils' does not exist in the current context

c:\Program Files (x86)\Steam\steamapps\common\7DTD DMT Modded\Mods\0-SphereIICore\Scripts\Blocks\BlockMortSpawner.cs(187,116): error CS0103: The name 'DestroyedResult' does not exist in the current context

Failed to compile Mods.dll

Build failed

 

process exited with error code -1

 

where is your mods folder containing the dmt mods located.

 

your mods folder for dmt need to be for example on the desktop and dmt linked to it as well as dmt linked to your game folder.

Share this post


Link to post
Share on other sites
where is your mods folder containing the dmt mods located.

 

your mods folder for dmt need to be for example on the desktop and dmt linked to it as well as dmt linked to your game folder.

 

Thanks for responding. I have tried it that way among several others, but it keeps throwing up that error. Not sure how to fix it.

Share this post


Link to post
Share on other sites
Thanks for responding. I have tried it that way among several others, but it keeps throwing up that error. Not sure how to fix it.

 

Which version are you compiling against? The latest Core uses 18.3. I'd expect to see those errors if you were building against 18.2

Share this post


Link to post
Share on other sites
Which version are you compiling against? The latest Core uses 18.3. I'd expect to see those errors if you were building against 18.2

 

Yep, I feel like a dingle berry! Lol. I don't know why I didn't notice that. My brain wasn't cooperating. Lol. Where can I get a version for 18.2? And thanks so much for the response. I think some of you guys mods will add some major excitement to our server as well. All of us on it have been playing 7DTD for at least a few alphas now. I have been playing since A13 or A14 I believe. So for us, vanilla is great, but we want some extra challenges & quality of life elements. Now we do have one guy who is brand new to the game on pc so he has never played mods. This is a bit of a shock for him. Lol.

Share this post


Link to post
Share on other sites
Yep, I feel like a dingle berry! Lol. I don't know why I didn't notice that. My brain wasn't cooperating. Lol. Where can I get a version for 18.2? And thanks so much for the response. I think some of you guys mods will add some major excitement to our server as well. All of us on it have been playing 7DTD for at least a few alphas now. I have been playing since A13 or A14 I believe. So for us, vanilla is great, but we want some extra challenges & quality of life elements. Now we do have one guy who is brand new to the game on pc so he has never played mods. This is a bit of a shock for him. Lol.

 

Thank you for the kind words

 

You need 18.3, which is the latest stable. The error messages you posted gives a hint that you are currently using 18.2. Are you using your steam version? Are you in any betas on that?

Share this post


Link to post
Share on other sites
Thank you for the kind words

 

You need 18.3, which is the latest stable. The error messages you posted gives a hint that you are currently using 18.2. Are you using your steam version? Are you in any betas on that?

 

Is there a version that will work with 18.2? We have kept the server & such on 18.2 because some of the other things we are using haven't updated yet.

Share this post


Link to post
Share on other sites
Is there a version that will work with 18.2? We have kept the server & such on 18.2 because some of the other things we are using haven't updated yet.

 

https://github.com/SphereII/SphereII.Mods/tree/Alpha18.2

 

This version should work, but it's not being actively maintained. The only issue I see are the two files that are showing in the error.

 

You could grab the latest, then grab the two files it complains about, and copy and paste them from Alpha18.2 into it.

Share this post


Link to post
Share on other sites
https://github.com/SphereII/SphereII.Mods/tree/Alpha18.2

 

This version should work, but it's not being actively maintained. The only issue I see are the two files that are showing in the error.

 

You could grab the latest, then grab the two files it complains about, and copy and paste them from Alpha18.2 into it.

 

Thank you so very much! Got it all up & running on my client side, now I just have to figure out how to install DMT on a PingPerfect server. Lol. DMT is completely new to me, but I really want these mods on the server because I think the group I play with will have a ball with them. So going to work on that end now. :)

Edit: I found your post regarding this on another thread. Going to follow those instructions. Thank you!

Edited by MandyCMoore (see edit history)

Share this post


Link to post
Share on other sites

Quick question. I have been working on installing DMT onto my server. I followed the instructions from the other thread, but I keep getting the same errors.

ERR NCSimple Deserializtion (ch=0)

EndOfStreamException: Attempted to read past the end of the stream

Any ideas on what I can do?

Share this post


Link to post
Share on other sites
Quick question. I have been working on installing DMT onto my server. I followed the instructions from the other thread, but I keep getting the same errors.

ERR NCSimple Deserializtion (ch=0)

EndOfStreamException: Attempted to read past the end of the stream

Any ideas on what I can do?

 

Do you have a full log? Was this applied to a new world?

Share this post


Link to post
Share on other sites

 

Do you have a full log? Was this applied to a new world?

 

Yep applied to a new world & restarted the server. That popped up in the console during Creating Character & then just stayed stuck there. Everything else coming up in the console looked fine, but I can try connecting again & copy it all if that would help.

Share this post


Link to post
Share on other sites

Is the one block crouch feature removed? I just installed the Core mod on 18.3. I noticed the zombie transmog mod worked just fine, as well as Xyth's NPCs and the NPC dialogue, so I'm confident I installed it correctly. But I was never able to crouch under one block. Is it disabled by default?

Share this post


Link to post
Share on other sites
Is the one block crouch feature removed? I just installed the Core mod on 18.3. I noticed the zombie transmog mod worked just fine, as well as Xyth's NPCs and the NPC dialogue, so I'm confident I installed it correctly. But I was never able to crouch under one block. Is it disabled by default?

 

Yes, its disabled by default. Edit the blocks.xml in the Core:

 <property class="AdvancedPlayerFeatures" >
<property name="Logging" value="false"/>
<property name="AntiNerdPole" value="false" /> <!-- Player cannot jump and place a block under neath them-->
<property name="OneBlockCrouch" value="false" /> <!-- Allow you to fit through one block spaces -->
<property name="SoftHands" value="false" /> <!-- Damages the player if they hit something with their bare hands. -->
</property>

Share this post


Link to post
Share on other sites
Posted (edited)

On the husbandry works great on the cows and they do breed saw it can give milk but I have not been able to figure out how? played with chickens they disappear after logout I am figuring that will need to make a home block for them in the xml right? to make them stay? put out containers for the cows and chickens with food and water in them hay for the cows and corn on the cob for the chickens

update ok found out chickens did not disappear apparently they can open regular doors and just walk out them lol so that was good to know lol

Edited by Bluman (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

I am having this error with 0-SphereIICore at 7 Days To Die Server in Ubuntu Server 18.04.

 

Using this mods.

 

1926065977_Anotacin2020-03-26141046.png.5bd1ee5643e969525b640eda98deee8c.png

 

Edit: I have tried with only 0-SphereIICore and SMXHud and still not working.

Error.txt

137663626_Anotacin2020-03-26141046.png.8557312a1a612bc37dee6306a49e9a18.png

Edited by vinanrra (see edit history)

Share this post


Link to post
Share on other sites
I am having this error with 0-SphereIICore at 7 Days To Die Server in Ubuntu Server 18.04.

 

Using this mods.

 

[ATTACH=JSON]{"alt":"Click image for larger version Name:\tAnotaci\u00f3n 2020-03-26 141046.png Views:\t0 Size:\t4.1 KB ID:\t1722910","data-align":"none","data-attachmentid":"1722910","data-size":"full"}[/ATTACH]

 

Edit: I have tried with only 0-SphereIICore and SMXHud and still not working.

 

This type of error can happen when you add and remove mods from an existing save game. The error points at vanilla having trouble, and nothing in particular to the DMT mods.

Share this post


Link to post
Share on other sites

 

This type of error can happen when you add and remove mods from an existing save game. The error points at vanilla having trouble, and nothing in particular to the DMT mods.

 

If i am understanding well, if i would like to use your mod i would need to use a "fresh" server? Because i have never use DMT mods i just used modlets and didnt edit any server file.

Share this post


Link to post
Share on other sites

 

If i am understanding well, if i would like to use your mod i would need to use a "fresh" server? Because i have never use DMT mods i just used modlets and didnt edit any server file.

 

Yes, if you have just added 0-SphereII, you will need a new world. It changes things that are not vanilla compatible.

Share this post


Link to post
Share on other sites

 

Yes, if you have just added 0-SphereII, you will need a new world. It changes things that are not vanilla compatible.

 

Thanks for the info and sorry to bother.

Share this post


Link to post
Share on other sites

Hi Sphereii i am having an issue with DMT NPCs mod.I already told Xyth but he said your the person actively working on the AI packages so i thought i would let you know...im having issues with the NPCs once hired.

Telling them to "stay here" or "wander around" causes them to walk to the edges of the map,they usually take a SW direction and just walk there,i noticed NON HIRED npcs also showing this behaviour.

 

Im using Sphereii core ,NPC dialogue,creature human pack and NPC pack,all up to date,run by the launcher.

Im playing Alpha 18.4 and its single player.

 

Ai reacts fine when in follow mode,dismiss is ok too,nventory also ok. Just the stay here and wander commands are not working.Iv no other mods running. I spent alot of time testing on as many NPCs as i could they all have the issue.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...