Jump to content
sphereii

sphereii's DMT Mods

Recommended Posts

Updated again.

 

Music Boxes brought up to date from Winter Project tweaks; Quick Continue is moved out to its own modlet. Winter Project updated from latest. reduced the default spawn rate of herds of animals.

 

Also fixed GotoPOISDX on dedis for quest lines.

 

Oh, also fixed and enabled birds and fish in waterways.

Edited by sphereii (see edit history)

Share this post


Link to post
Share on other sites

I got this from SphereII A Better Life,

2020-01-29T09:07:08 61.658 ERR Model 'Plants/driftwood' not found on block with name terrWaterSpawner

 

It was fixed when I replaced the model with something else.:star:

Share this post


Link to post
Share on other sites
I tried out the Better Life on a Nitrogen map.

The fish spawned beautifully!

 

That's great! I was testing them but had trouble finding water in my worlds. I never thought of nitrogen.

 

I cleaned up some of the xml for A better Life. Some old stuff in there needed to go :)

Share this post


Link to post
Share on other sites

Well this looks fun. Sphereii, I've played ur most before. Thanks for the work. I have fun.

 

I would like to c a head shot multiplier as in the classic z by Romaro that was all that killed them with even zero damage elsewhere.

Share this post


Link to post
Share on other sites
Well this looks fun. Sphereii, I've played ur most before. Thanks for the work. I have fun.

 

I would like to c a head shot multiplier as in the classic z by Romaro that was all that killed them with even zero damage elsewhere.

 

Take a look in the 0-SphereIICore/Config/blocks.xml. There's an xml called HeadshotOnly and is by default to false. You could add a modlet to change that value to true, and enable its functionality.

 

With that method, the zombies's damage is reduced to something like 0.1. It's not 0, but it's close.

Share this post


Link to post
Share on other sites

hey there, so i recently installed the mod list together with the mod launcher and the npc mods, but whenever i try to load a new world i get the "object refrence not set to an instance of an object" error message when it gets to the "creating player" part. i've tried running the mods on different alpha versions (18.0 - 18.3) to no avail, i've also tried to dissable a few of the mods but that didn't work either.

Share this post


Link to post
Share on other sites
hey there, so i recently installed the mod list together with the mod launcher and the npc mods, but whenever i try to load a new world i get the "object refrence not set to an instance of an object" error message when it gets to the "creating player" part. i've tried running the mods on different alpha versions (18.0 - 18.3) to no avail, i've also tried to dissable a few of the mods but that didn't work either.

 

Do you have a player.log?

Share this post


Link to post
Share on other sites
where do i find the player log?

 

In Windows Explorer, copy and paste this: %APPDATA%..\LocalLow\The Fun Pimps\7 Days To Die

Share this post


Link to post
Share on other sites

okay so i managed to fix the error by dissabling the winter project mod, but now there are no wild trees nor grass, and zombies don't seem to spawn either

Share this post


Link to post
Share on other sites
okay so i managed to fix the error by dissabling the winter project mod, but now there are no wild trees nor grass, and zombies don't seem to spawn either

 

Okay, I think I understand how you have things set up. Here's how you can fix:

 

1) Delete the Mods folder from your 7 Days To Die folder

2) In the DMT, uncheck SphereII Winter Project, SphereII Clear UI, Syx Security Bots and Dishong Tower Challenge.

3) Rebuild

 

That should get you going.

Share this post


Link to post
Share on other sites

this seems to have fixed the problems, tho i still spawn with 20 water, 10 chili's 50 notes and 50 torches for some odd reason. And the security bots sounded hella interesting

Share this post


Link to post
Share on other sites
this seems to have fixed the problems, tho i still spawn with 20 water, 10 chili's 50 notes and 50 torches for some odd reason. And the security bots sounded hella interesting

 

I'll take a look at the waters and whatnot. I think the Syx bots have old xml; I'll take a look at them too. enjoy the water and chilli until then :)

Share this post


Link to post
Share on other sites

okay so, the problem persists with zombies. Now the only zombie type that spawns are crawlers. Also i managed to find the player.log but i have no idea how to upload it.

Share this post


Link to post
Share on other sites
okay so, the problem persists with zombies. Now the only zombie type that spawns are crawlers. Also i managed to find the player.log but i have no idea how to upload it.

 

Either attach it to the forums, and post the contents on a site like Pastebin.com, then send me the link.

Share this post


Link to post
Share on other sites
this seems to have fixed the problems, tho i still spawn with 20 water, 10 chili's 50 notes and 50 torches for some odd reason. And the security bots sounded hella interesting

 

I found the issue, and fixed. I pushed to the latest.

Share this post


Link to post
Share on other sites

the game finally works! tho the Dishong tower and winter project mods still have to be deactivated.

Share this post


Link to post
Share on other sites
the game finally works! tho the Dishong tower and winter project mods still have to be deactivated.

 

Yes. I should clean up the repository, because it is causing confusion. It's a place to put all my mods, but they are not meant to be all used at once.

Share this post


Link to post
Share on other sites

Hi! I want to play and test this out so much, but I have this problem.

 

7 Days To Die\Mods\0-SphereIICore\Scripts\Blocks\BlockMortSpawner.cs(187,116): error CS0103: The name DestroyedResult does not exist in the current context.

 

Failed to compile Mods.dll

Share this post


Link to post
Share on other sites
Hi! I want to play and test this out so much, but I have this problem.

 

The latest version of SphereII.Mods works against 18.3. Seems like you are either targetting 18.2 with the latest, or targetting 18.3 with out of date download.

Share this post


Link to post
Share on other sites
The latest version of SphereII.Mods works against 18.3. Seems like you are either targetting 18.2 with the latest, or targetting 18.3 with out of date download.

 

Ah thank you! Yes, I use A 18.2 cause my sister cannot run 18.3 without lag. Where is the 18.2 version? =)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...