Jump to content
sphereii

sphereii's DMT Mods

Recommended Posts

The breeding may not be fully fleshed out. However, if a Cow is an Adult, and has an Adult Bull, and they get close, the cow can get pregnant. Over time, a calf will be spawned.

 

Ah okay. What about taming them, or trapping? My players are still trying to figure out how to trap animals.

Share this post


Link to post
Share on other sites
Ah okay. What about taming them, or trapping? My players are still trying to figure out how to trap animals.

 

This can be found (and adjusted ) in the entityclasses.xml of bloom's:

 

     <property name="AITask-3" value="ApproachAndFollowTargetSDX, Mods" data="incentives=Mother,Leader,hayBaleBlock,foodCornOnTheCob"/>

 

The task is triggered by an incentive to follow you. Mother and Leader would be special cvar that can be set through a buff to an entityID. However, if you hold a block, or an item, that matches anything on that list, they'll follow you, until you stop holding it.

 

It's useful to lead them back to your base then place them in a fenced yard ( I don't think they jump ).

Share this post


Link to post
Share on other sites

Updated 0-SphereIICore and A Better Life.

 

The Core has fixes for NPCs on dedi, including them not following certain orders, or opening up their inventory. Still an issue with their melee animation and their Patrol points don't work yet.

 

A Better Life now has birds spawning; Fish are todo, as I need to figure out an alternative way to spawn them.

Share this post


Link to post
Share on other sites

Hey there, i just had an update of the Legacy Distant Terrain, through the mod launcher, and for some reason, I am getting this:

Harmony-0-SphereIICore.dll' could not be opened -- 'File is corrupt.'

 

I have looked for a manual download, but cannot find anything as of yet.

2nd thing now is, the core, showed an update as well, but doesn't seem to update per se, as the update button never changes to enabled.

 

Any help would be appreciated.

Share this post


Link to post
Share on other sites
Hey there, i just had an update of the Legacy Distant Terrain, through the mod launcher, and for some reason, I am getting this:

Harmony-0-SphereIICore.dll' could not be opened -- 'File is corrupt.'

 

I have looked for a manual download, but cannot find anything as of yet.

2nd thing now is, the core, showed an update as well, but doesn't seem to update per se, as the update button never changes to enabled.

 

Any help would be appreciated.

 

My guess is that an anti-virus program is scanning and corrupting the file. Do you know which one you are using?

Share this post


Link to post
Share on other sites
My guess is that an anti-virus program is scanning and corrupting the file. Do you know which one you are using?

 

Just Windows Defender.

 

Edit, is there a db I can get the core manually?

Edited by Pra3t0r 0f R0m3 (see edit history)

Share this post


Link to post
Share on other sites
Just Windows Defender.

 

Edit, is there a db I can get the core manually?

 

Ok, the log file shows this:

INFO 1 _7D2DLauncher.frmMain - Object reference not set to an instance of an object.

 

Which consistently fails. Additionally, I have already attempted to overwrite this with another install of the launcher.

I may have to try uninstalling it and re-install to see if that helps (good thing I don't have too many mods to re-install).

Share this post


Link to post
Share on other sites

Hi

 

Been having issues since recent update of mod launcher. It says I have version 18.1.1.19 of your core installed, and need to update to 18.0.1.1 . This is causing a Null Ref spam in-game now. I have removed and reinstalled it, with no luck.

 

 

Image+2019-11-14+at+6.40.47+AM.png?v=a7d3a833e1909e51603d46dc05a5f8f9

 

Edited by Marinxar (see edit history)

Share this post


Link to post
Share on other sites
Hi

 

Been having issues since recent update of mod launcher. It says I have version 18.1.1.19 of your core installed, and need to update to 18.0.1.1 . This is causing a Null Ref spam in-game now. I have removed and reinstalled it, with no luck.

 

 

Image+2019-11-14+at+6.40.47+AM.png?v=a7d3a833e1909e51603d46dc05a5f8f9

 

I'm probably generating an inconsistency when I work on different machines. The Version / Update method is to allow you to manually update. However, when you actually start your mod instance, it will re-download all the latest versions anyway, unless you have Refresh Mods Automatically checked off.

 

Do you know what the null ref you are getting? Do you have a log file you can send to me?

Share this post


Link to post
Share on other sites
I'm probably generating an inconsistency when I work on different machines. The Version / Update method is to allow you to manually update. However, when you actually start your mod instance, it will re-download all the latest versions anyway, unless you have Refresh Mods Automatically checked off.

 

Do you know what the null ref you are getting? Do you have a log file you can send to me?

 

Hi, thanks for the update. The new version (1.20) installed fine. I took a screenshot of the error, but in hinesight I don't know enough about these things to say it is because of that version mismatch. It might have been a coincidence as well. Either way, here is the SS of that error spam.

 

 

Image+2019-11-14+at+6.59.29+AM.png?v=b02a3b4aebea88c53d4cace0a6e8cc70

 

Share this post


Link to post
Share on other sites

I Installed "SphereII Food Spoilage",i want to change expiration date.

Can you suggest a solution to the problem?

Share this post


Link to post
Share on other sites
I Installed "SphereII Food Spoilage",i want to change expiration date.

Can you suggest a solution to the problem?

 

Take a look at the items.xml. There's two examples in there. The SpoilageMax is the total spoilage time. The SpoilagePerTick controls how often it goes down.

 

I would suggest lowering SpoilerPerTick. If you cannot find a compromise, try raising SpoilageMax. You can also apply different spoilage times on different food.

Share this post


Link to post
Share on other sites

Hey Spherii, I was just literally going to post on how my issue was fixed due to the updates to the mod launcher, and re-installing everything a few days ago, unfortunately with a few mod updates as of today, I am getting the:

 

"Compiling Harmony mod for SphereII Legacy Distant Terrain...

fatal error CS0009: Metadata file 'k:\7D2D\Alpha18\Sphereii-mental\Performance_Mod\Mods\SphereII Legacy Distant Terrain\Harmony\Harmony-SphereII Legacy Distant Terrain.dll' could not be opened -- 'File is corrupt.'

Failed to compile Harmony dll Harmony-SphereII Legacy Distant Terrain.dll

Build failed"

 

As well as the 'Badimageformatexception" in the console.

 

The worst part of the errors this time, is that when I do load into the game my character has been completely reset...on day 16, with an empty inventory, and zero points, or unlocked books, yet everything I had placed (including stored items) is intact.

So is my save game boned? Or will I be able to recover it?

Share this post


Link to post
Share on other sites
Hey Spherii, I was just literally going to post on how my issue was fixed due to the updates to the mod launcher, and re-installing everything a few days ago, unfortunately with a few mod updates as of today, I am getting the:

 

"Compiling Harmony mod for SphereII Legacy Distant Terrain...

fatal error CS0009: Metadata file 'k:\7D2D\Alpha18\Sphereii-mental\Performance_Mod\Mods\SphereII Legacy Distant Terrain\Harmony\Harmony-SphereII Legacy Distant Terrain.dll' could not be opened -- 'File is corrupt.'

Failed to compile Harmony dll Harmony-SphereII Legacy Distant Terrain.dll

Build failed"

 

As well as the 'Badimageformatexception" in the console.

 

The worst part of the errors this time, is that when I do load into the game my character has been completely reset...on day 16, with an empty inventory, and zero points, or unlocked books, yet everything I had placed (including stored items) is intact.

So is my save game boned? Or will I be able to recover it?

 

I doubt your saved game is damaged. Sounds like you have a corrupted DLL. You can delete the Mods folder, have the mod launcher start the game. It should download everything again.

 

Any anti-virus updates?

Share this post


Link to post
Share on other sites

A18.1_2019-11-25_22-16-28.thumb.jpg.476719c194fb8ee11b28103e726a5c35.jpg

 

 

bug report

 

Suddenly, cow was get an electrical shock.

After that she was died

A18.1_2019-11-25_21-11-53.thumb.jpg.ce7a69cfb288d701523ee5f59821be3f.jpg

Share this post


Link to post
Share on other sites
[ATTACH=CONFIG]30740[/ATTACH][ATTACH=CONFIG]30741[/ATTACH]

 

 

bug report

 

Suddenly, cow was get an electrical shock.

After that she was died

 

I am sorry, Mrs/Mr Cow. You have died.

 

I didn't have a lot of particles for testing, so I added electric buffs for when the cow got infected. It sounds like this got got infected, and died from its wounds.

Share this post


Link to post
Share on other sites

Thank you, I approve.

but cow was uninjured but she was infected who was died after that.

Share this post


Link to post
Share on other sites
Thank you, I approve.

but cow was uninjured but she was infected who was died after that.

 

Bloom's has a chance of random infection. It was an experiment using buff chains. The infection is supposed to grow worse as time goes by, with a chance of it beating the infection itself. The intention was to craft something to heal it, but that was never completed. They either fight it off naturally, or die trying. There's 3 stages of infection. The first, there is no indications. The second, there's supposed to be a fire particle. The final stage is electric particle.

 

Oh, and it's also supposed to be contagious.

Share this post


Link to post
Share on other sites

Thank you sphereii:smile-new:

I see, so that's what it was.

I hope that this problem is resolved quickly.

Share this post


Link to post
Share on other sites

Hm. Testing the legacy terrain mod, but not entirely sure i'm getting it working, I'm not using a launcher so doing it by hand with the DMT tool and copied the 'SphereII Legacy distant terrain' folder into it's modlet folder, checked it and build. not getting any errors or so.

 

After that I did the same on my server,

But I'm not entirely sure it's active :/ can't tell any visual difference, and gpu is still struggling outdoors.

Do I need to have the core compiled aswell? There is a bunch of blocks and other stuffs in that core folder that seems to be about other mods I'm not interested in using? (trying to keep as lightweight of mods as I can)

Share this post


Link to post
Share on other sites
Hm. Testing the legacy terrain mod, but not entirely sure i'm getting it working, I'm not using a launcher so doing it by hand with the DMT tool and copied the 'SphereII Legacy distant terrain' folder into it's modlet folder, checked it and build. not getting any errors or so.

 

After that I did the same on my server,

But I'm not entirely sure it's active :/ can't tell any visual difference, and gpu is still struggling outdoors.

Do I need to have the core compiled aswell? There is a bunch of blocks and other stuffs in that core folder that seems to be about other mods I'm not interested in using? (trying to keep as lightweight of mods as I can)

 

You should only need it on the client. Check you log file, it should say something about Creating Legacy Distant Terrain. Then you know its active.

 

You do not need 0-SphereIICore for this to work. In the Mod Launcher, there's also a sphereii-mental / Performance Mod, which only has the Distant Terrain mod in it, if you continue to struggle with it.

Share this post


Link to post
Share on other sites
You should only need it on the client. Check you log file, it should say something about Creating Legacy Distant Terrain. Then you know its active.

 

You do not need 0-SphereIICore for this to work. In the Mod Launcher, there's also a sphereii-mental / Performance Mod, which only has the Distant Terrain mod in it, if you continue to struggle with it.

 

Ah, Thanks!

It's not active it seems, that explains it :D Gonna mess around with it a bit, I'm oldschool and don't use the mod launcher and prefer to add the stuffs myself so I know what's happening :)

Share this post


Link to post
Share on other sites
Ah, Thanks!

It's not active it seems, that explains it :D Gonna mess around with it a bit, I'm oldschool and don't use the mod launcher and prefer to add the stuffs myself so I know what's happening :)

 

Nothing wrong with that. Good luck :)

 

You want The Legacy Distant Terrain mod in a separate folder than your build target's Mods folder, then have DMT point to that separate folder, with the target pointing to a vanilla version of the game. DMT will take care of copying all the files it needs to the target folder.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...