Jump to content

Improvements for the dedicated server


Recommended Posts

Should be fixed now.

 

nope, I pmed you with the logs as my post probably wont get approved.

 

Tiles are not showing up and I get this error:

 

 

2019-10-08 17:44:58 Exception MissingMethodException: int Vector2i.get_x()

AllocsFixes.MapRendering.MapRendering.RenderDirtyChunks () (at <4285e741502245dbba2f0a45fd3e5432>:0)AllocsFixes.MapRendering.MapRendering+c__Iterator0.MoveNext () (at <4285e741502245dbba2f0a45fd3e5432>:0)UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at :0)

 

Link to post
Share on other sites

Works fine for me. Please make sure you're on the latest version (short as 20_23_33):

2019-10-09T12:15:26 0.851 INF [MODS] Loaded Mod: Allocs command extensions (20)
2019-10-09T12:15:26 0.854 INF [MODS] Loaded Mod: Allocs server fixes (23)
2019-10-09T12:15:26 0.855 INF [MODS] Loaded Mod: Allocs MapRendering and Webinterface (33)

Link to post
Share on other sites
Has the 'exportitemicons' command been removed intentionally? It no longer appears in the command list under 'help' (and does not work in RAT either).

 

The icons are already in your data folder (ItemIcons folder). No need to export anymore.

 

Cheers

Link to post
Share on other sites

Anyone else have the web map day not progressing. Mine has been stuck at day 24 8:36, but in game we are on day 30.

 

Anything I should check, look at, reset to correct that? Its cosmetic really, Not a show stopper in any way, but something I noticed.

 

Thanks

 

EDIT: ----

 

Ran up another world, world map shows same day / time as before. On map rendering where does it pull that info from? What should I purge / delete to get it back on correct time for the server I am running?

 

Thanks.

Edited by LewZephyr
Update (see edit history)
Link to post
Share on other sites
  • 2 weeks later...

Are you saying you created a completely new save game and it still shows day 24?

Across multiple save games nothing is shared, within the same save at least a manual page reload should always give you the current time. If something broke so the page could not get the correct time (because the server / mod does not respond properly) it should at least give you something like day 0, 0:00 or nothing at all (would have to check the code what it shows if there's no proper response :D ), but not a specific time of one save game you ran at some point.

Server logs might show something, also looking at the network traffic when loading the page to see what the server returns.

Link to post
Share on other sites

Yeah with a completely new game, in fact several different saved games. The top left corner showed the right day / time, but the one in the bottom left shows day 24.

 

Weird thing is, it looks to have cleared itself up since the last update. I had not changed anything, besides patching so no idea.

 

Thanks for the response none the less.

Link to post
Share on other sites

I’m having an issue with this although it’s not the fault of the server tool.

 

I’m running an instance on a Windows 2016 server and the tool works fine. If I go to the ip, I can see the map. What I would like to do is have is render through a secure address. So instead of 000.000.000.000 you would access it via https://my site.com I could not figure out a way to redirect or otherwise. I’m sure I’m missing a way to do it but it’s been awhile since I’ve delved into this technical of an issue. Any suggestions or post/topic I could look at that anyone is aware of?

Link to post
Share on other sites
I use map.guppycur.com and use a redirect on my domain host (GoDaddy). You do it there.

 

The keyword is "reverse proxy". An example (for HTTP, but you can just replace it with HTTPS) for Apache can be found on the webpage: https://7dtd.illy.bz/wiki/Integrated%20Webserver#apacheandmod_proxy

 

PS: Heh, timing :D

 

Thank you gentlemen. I have some reading to do it seems. For now, I can't access the web map anymore so not sure whats up there yet. I hate servers lol. :playful:

 

Don't suppose either of you would have the time to walk me through things would you? Got the web map going again after a restart so that was easy at least.

Link to post
Share on other sites

Depends on your domain provider.

 

Look for sub domain redirects or some combo of those words, then just point it to your ip : port.

 

You likely can't test from your local network, so test from your phone (make sure you're off WiFi).

Link to post
Share on other sites
Depends on your domain provider.

 

Look for sub domain redirects or some combo of those words, then just point it to your ip : port.

 

You likely can't test from your local network, so test from your phone (make sure you're off WiFi).

 

So you're saying point the https:// My_Site toward the IP:port of the server?

Link to post
Share on other sites
Yep, but use a subdomain. map.yourdomainname.com or something.

 

So I’ve had limited success getting this working using mod rewrite in iis and it’s functional except for using the steam login option. That is also redirected so I have to figure out how to redirect just the map and not the login portion.

Link to post
Share on other sites

Missed some messages ... Well, "IIS" ... get a real server :p

No, seriously, think with rewriting this could be an issue. I *suppose* your rewrite part is fine but the server tells Steam's OpenID page to redirect to the wrong address afterwards. That's why I said reverse proxy: The mod will know about the original public address in that case and can properly instruct the OpenID page where to redirect to afterwards.

 

*If* that is the issue you run into you'd need a modified mod ( :D ) that has a hardcoded redirect target for OpenID. Or (can't stress this enough ;) ) look into using a reverse proxy. No idea if IIS supports this though.

Link to post
Share on other sites
Missed some messages ... Well, "IIS" ... get a real server :p

No, seriously, think with rewriting this could be an issue. I *suppose* your rewrite part is fine but the server tells Steam's OpenID page to redirect to the wrong address afterwards. That's why I said reverse proxy: The mod will know about the original public address in that case and can properly instruct the OpenID page where to redirect to afterwards.

 

*If* that is the issue you run into you'd need a modified mod ( :D ) that has a hardcoded redirect target for OpenID. Or (can't stress this enough ;) ) look into using a reverse proxy. No idea if IIS supports this though.

 

Believe me, if not for my Empyrion servers and a couple others without Linux support, I wouldn’t be bothering with Winblows...

 

I think I’m confusing terms as well. I don’t know much about the Apache version but from what I’ve read so far on Windows I’ll have to use Waamp or a similar package. As Guppy has said maybe just adjusting permissions would be the better option but I’d still would like to learn for later use.

 

Or alternatively, don't care about the steam login part at all, and set permissions for everyone to view.

 

The steam part is only handy if you want person a to see lcb's but person b not to, etc.

 

Think I might follow this suggestion if I end up not smart enough to configure properly. :fat:

Link to post
Share on other sites

From a quick check with google it sounds like what you're doing with the rewrite module from IIS actually is a reverse proxy setup? If so, sounds like setting preserveHostHeaders might help, though it also seems to have some drawbacks, depending on what else is running on your IIS: https://serverfault.com/questions/936922/setting-up-iis-reverse-proxy-to-preserve-host-headers

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...