Jump to content

Improvements for the dedicated server


Alloc
 Share

Recommended Posts

But also not logged on now? Or is that about people who haven't been playing for weeks but now came back and they did not show up?

 

Not logged on currently and have not been for a long time. Basically talking about inactive players but they have been online since last server wipe so there should be data about them. The weird thing to me is that at some point CSMM could get data for these players but not anymore. Hence why I thought about some time based deletion or corrupted data.

 

I've asked the server owner if he gets any errors on start up - no. He'd keep an eye out for any errors during runtime that might be related to this issue.

Link to comment
Share on other sites

  • 2 weeks later...

help

 

yes it's the only "bug" that I have found.

 

I have added some command like "heal" and others things. I must try it before sharing to you my suggestions ( If you want to have some suggestions of course)

 

can you assist me with installing alloc fixes to my dedicated? i know thats rather random

Link to comment
Share on other sites

  • 2 months later...

here it logs

 

2018-11-11T23:18:59 213.721 ERR Error validating login:

2018-11-11T23:18:59 213.723 EXC Error getting response stream (Write: The authentication or decryption has failed.): SendFailure

TlsException: The authentication or decryption has failed.

at Mono.Security.Protocol.Tls.RecordProtocol.ProcessAlert (AlertLevel alertLevel, AlertDescription alertDesc) [0x00000] in <filename unknown>:0

at Mono.Security.Protocol.Tls.RecordProtocol.InternalReceiveRecordCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0

Rethrow as IOException: The authentication or decryption has failed.

at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0

Rethrow as WebException: Error getting response stream (Write: The authentication or decryption has failed.): SendFailure

at System.Net.HttpWebRequest.EndGetRequestStream (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0

at System.Net.HttpWebRequest.GetRequestStream () [0x00000] in <filename unknown>:0

at AllocsFixes.NetConnections.Servers.Web.OpenID.Validate (System.Net.HttpListenerRequest _req) [0x00000] in <filename unknown>:0

at AllocsFixes.NetConnections.Servers.Web.Web.DoAuthentication (System.Net.HttpListenerRequest _req, AllocsFixes.NetConnections.Servers.Web.WebConnection& _con) [0x00000] in <filename unknown>:0

UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)

UnityEngine.DebugLogHandler:LogException(Exception, Object)

UnityEngine.Logger:LogException(Exception, Object)

UnityEngine.Debug:LogException(Exception)

Logger:masterLogException(Exception)

Logger:Exception(Exception)

Log:Exception(Exception)

AllocsFixes.NetConnections.Servers.Web.Web:DoAuthentication(HttpListenerRequest, WebConnection&)

AllocsFixes.NetConnections.Servers.Web.Web:HandleRequest(IAsyncResult)

System.Net.ListenerAsyncResult:InvokeCallback(Object)

 

(Filename: Line: -1)

Link to comment
Share on other sites

Sounds like your server has issues talking to Steam's OpenID authentication server. Like a proxy or firewall in between blocking/changing the connection. Wonder why it's a TLS exception and not a generic one but not sure what the .NET HTTP libraries do in that regard.

Link to comment
Share on other sites

Yeah, 16.1 requires 12_14_19, 13_15_20 requires A16.2 as stated in the release notes.

 

Error fetching density mismatch list

That line is not relevant for normal use.

 

i cant see the map,whats wrong?

Hard to tell with the amount of information given. Most likely though you aren't logged in as level 0 admin on the website *and* didn't change the permissions to accomodate for this if you don't want to / can't login.

Link to comment
Share on other sites

Yeah, 16.1 requires 12_14_19, 13_15_20 requires A16.2 as stated in the release notes.

 

 

That line is not relevant for normal use.

 

 

Hard to tell with the amount of information given. Most likely though you aren't logged in as level 0 admin on the website *and* didn't change the permissions to accomodate for this if you don't want to / can't login.

i change it to 2000 but just can see player,not map

Link to comment
Share on other sites

@alloc - now that A17 Experimental is out, any chance of getting the improvements mods working with it? I tried to use the A16.4 but it got rejected because of the new methods I'm guessing its looking for now "No ModAPI found in mod DLLs"

 

Seems like TFP are using this going forward now.

Link to comment
Share on other sites

Rendermap is not working

 

2018-11-20T15:24:29 7713.939 INF Executing command 'Rendermap' by ControlPanel
2018-11-20T15:24:29 7713.999 INF Error in RenderMap.Run: System.ArgumentException: An element with the same key already exists in the dictionary.
 at System.Collections.Generic.Dictionary`2[system.String,ThreadManager+ThreadInfo].Add (System.String key, .ThreadInfo value) [0x00000] in <filename unknown>:0 
 at ThreadManager.startThread (System.String _name, .ThreadFunctionDelegate _threadDelegate, .ThreadFunctionDelegate _threadInit, .ThreadFunctionLoopDelegate _threadLoop, .ThreadFunctionEndDelegate _threadEnd, ThreadPriority _threadPriority, System.Object _parameter, .ExitCallbackThread _exitCallback, Boolean _runInMainThread) [0x00000] in <filename unknown>:0 
 at ThreadManager.StartThread (System.String _name, .ThreadFunctionDelegate _threadInit, .ThreadFunctionLoopDelegate _threadLoop, .ThreadFunctionEndDelegate _threadEnd, ThreadPriority _threadPriority, System.Object _parameter, .ExitCallbackThread _exitCallback, Boolean _runInMainThread) [0x00000] in <filename unknown>:0 
 at RegionFileManager..ctor (System.String _loadDirectory, System.String _saveDirectory, Int32 _maxChunksInCache, Boolean _bSaveOnChunkDrop) [0x00000] in <filename unknown>:0 
 at AllocsFixes.MapRendering.MapRendering.RenderFullMap () [0x00000] in <filename unknown>:0 
 at AllocsFixes.CustomCommands.RenderMap.Execute (System.Collections.Generic.List`1 _params, CommandSenderInfo _senderInfo) [0x00000] in <filename unknown>:0 

Link to comment
Share on other sites

Should remove that one ... anyway, just use the game's visitmap command. Unless you really want to just have the webmap render only the parts that you already uncovered anyway. In this case though it only would do you any good if you installed the mod after starting the savegame. So unlikely to be of any help.

Link to comment
Share on other sites

It appears at least some have a problem with the web map not displaying all the admin options (player location, inventory, logs etc.) I updated to rev 336 but no go. webpermissions.xml and serveradmins.xml set correctly I think:

 

Level: Web function

2000: web.map

0: webapi.GetAnimalsLocation

0: webapi.GetHostileLocation

0: webapi.Null

0: webapi.GetPlayersOnline

0: webapi.GetPlayersLocation

0: webapi.GetPlayerInventory

0: webapi.GetLandClaims

2000: webapi.getstats

2000: webapi.executeconsolecommand

0: webapi.GetLog

2000: webapi.getwebuiupdates

0: webapi.GetServerInfo

0: webapi.GetPlayerList

2000: webapi.getallowedcommands

0: webapi.GetPlayerInventories

0: webapi.viewallclaims

0: webapi.viewallplayers

 

 

 

Level: SteamID (Player name if online)

0: 765611xxxxxxxxx07

Link to comment
Share on other sites

Should remove that one ... anyway, just use the game's visitmap command. Unless you really want to just have the webmap render only the parts that you already uncovered anyway. In this case though it only would do you any good if you installed the mod after starting the savegame. So unlikely to be of any help.

 

what are the arguments for visitmap?

Link to comment
Share on other sites

Its seems the persistent data isnt persistent anymore. As soon as server boots, data is lost.

 

Cheers

 

- - - Updated - - -

 

what are the arguments for visitmap?

 

*** Command: visitmap ***

Usage:

1. visitmap <x1> <z1> <x2> <z2> [check]

2. visitmap stop

1. Start visiting the map in the rectangle specified with the two edges defined by

coordinate pairs x1/z1 and x2/z2. If the parameter "check" is added each visited

chunk will be checked for density issues.

2. Stop the current visitmap run.

 

Cheers

Link to comment
Share on other sites

It appears at least some have a problem with the web map not displaying all the admin options (player location, inventory, logs etc.) I updated to rev 336 but no go. webpermissions.xml and serveradmins.xml set correctly I think:

I.e. not only you accessing it? And others have issues, you don't? If they don't have permission level 0 they won't be able to see everything as per your permission setup. So all fine.

 

 

what are the arguments for visitmap?

There's a help in the console for that specific purpose.

 

- - - Updated - - -

 

Its seems the persistent data isnt persistent anymore. As soon as server boots, data is lost.

 

Basically there's only one real reason: Errors. So any in your log?

Link to comment
Share on other sites

Basically there's only one real reason: Errors. So any in your log?

 

That the stange thing. No load or save errors on bin. Settings just default.

You can verify by going on server and leave again while server running. Then on webmap you can see yourself as offline player.

Then reboot server and check offline players. Always 0.

 

Cheers

 

-edit- i have exactly the same behaviour with my mod. As i use the same serialization and deserialization code you use

Edited by Prisma501 (see edit history)
Link to comment
Share on other sites

Does GameUtils.GetSaveGameDir () switch context during startup maybe?

 

Your map files are in /Saves/RWG/CSMM (CSMM is seedname), but persistentdata is in

/Saves/Mevozo Mountains/CSMM -> player and region files are in here too.

 

My bin is in both dirs :S.

 

Cheers

 

My serverconfig with names (dunno if i fukked it up there maybe?):

 

<property name="GameWorld" 				value="RWG"/>			<!-- Navezgane, RWG -->
 <property name="WorldGenSeed" 			value="CSMM"/>				<!-- If RWG this seed decides the map to load, if already generated, it will simply load it -->
 <property name="WorldGenSize" 			value="4096"/>				<!-- RWG map size, this is in width and height, this value will modify the seed as well providing a unique map name even if using the same GenSeed -->
 <property name="GameName" 				value="CSMM"/>			<!-- Whatever you want the game name to be THIS CONTROLS THE RANDOM GENERATION SEED -->

 

-edit- maybe there is no error because the File.Exists on bin returns false on loading it. So it just never gets read and all vars default to their initialisation values?

Edited by Prisma501 (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...