Jump to content

Improvements for the dedicated server


Alloc
 Share

Recommended Posts

Then what am I doing wrong? =/

 

Just connected to my Telenet and here's what the console said:

WRN Steam OpenID login result did not give a valid SteamID

 

I downloaded the server files from this link: http://illy.bz/fi/7dtd/server_fixes.tar.gz

 

I also tried this version: http://illy.bz/fi/7dtd/server_fixes_v14_17_24.tar.gz didn't help, same issue. (I did reboot the server after uploading the new files before trying)

 

My steam profile link: https://steamcommunity.com/id/voldzito/

 

My server map: http://176.57.153.46:8102/static/index.html

 

Is it because my steam profile uses a custom url with "voldzito" and not steam 64 id?

 

Looks like something isnt configured correctly on your setup. The place where it should display the time is stuck on 'Loading...' as well.

 

I just downloaded and tested the mods and had no issues logging in.

 

The call to getstats is returning 403... maybe check your webpermissions.xml file?

Edited by StompyNZ (see edit history)
Link to comment
Share on other sites

Looks like something isnt configured correctly on your setup. The place where it should display the time is stuck on 'Loading...' as well.

 

I just downloaded and tested the mods and had no issues logging in.

 

The call to getstats is returning 403... maybe check your webpermissions.xml file?

Deleted the file, then restarted the server so that it generates a new one. Now the time displays correctly and doesn't show Loading, but I still can't log in (same error). The server is modded, running Undead Legacy + ServerTools + MuratusMinibike (Lost Minibike) + the 3 Allocs mods.

 

Mind you it was working a few weeks ago. One of the server players noticed that it's no longer working now and that's why I'm here, trying to to solve the issue...

Edited by Subquake (see edit history)
Link to comment
Share on other sites

  • 1 month later...

At Catalysm: Will be in the next release.

 

Thanks Prisma, that way I didn't have to think about that stuff :D

Renamed it to GetPlayerInventories though and added SteamID and EntityID fields to the output so it's easier to connect the received data to whatever internal structures the receiving application might have :)

Link to comment
Share on other sites

At Catalysm: Will be in the next release.

 

Thanks Prisma, that way I didn't have to think about that stuff :D

Renamed it to GetPlayerInventories though and added SteamID and EntityID fields to the output so it's easier to connect the received data to whatever internal structures the receiving application might have :)

 

Awesome! And you're welcome :)

 

Cheers

Link to comment
Share on other sites

  • 2 weeks later...
A couple of questions...

So - console commands can work through the telnet connection?

Is there a complete list of commands (specifically for: Improvements for the dedicated server)?

 

You can do "help" in console/telnet to get all commands. Then get more detailed help per command by doing "help <command>".

 

Alloc has added the following commands:

give

listitems

listknownplayers (lkp)

listlandprotection (llp)

removelandprotection (rlp)

reply (re)

sayplayer (pm)

showinventory (si)

 

Cheers

Link to comment
Share on other sites

Player_Logs working incorrectly?

 

Hello everyone. Sorry for my bad english. I do not get the Extra data. Especially the players speed.

 

<Tool Name="Player_Logs" Enable="True" Interval="45" Position="False" Inventory="True" Extra="True" Days_Before_Log_Delete="5" />

 

Report in the Player_Log.

 

Belt:

Slot 0: 001 * stoneAxe - quality: 450,

Slot 1: 001 * pickaxeIron - quality: 555,

Slot 2: 001 * machete - quality: 420,

Slot 3: 001 * fireaxeIron - quality: 300,

Slot 4: 001 * gunAK47 - quality: 157,

- partsAK47_stock - quality: 284,

- partsAK47_receiver - quality: 194,

- partsAK47_parts - quality: 71,

- partsAK47_barrel - quality: 79,

Slot 5: 005 * woodFrameBlock,

Slot 6: 002 * shamSandwich,

Slot 7: 001 * wrench - quality: 496,

Backpack:

Equipment:

Slot head: leatherHood - quality: 350,

Slot eyes: nightvisionGoggles - quality: 77,

Slot face: bandana - quality: 500,

Slot armor: leatherJacket - quality: 350,

Slot jacket: animalHidePoncho - quality: 350,

Slot shirt: tshirtRed - quality: 194,

Slot legarmor: militaryLegArmor - quality: 81,

Slot pants: plantFiberPants - quality: 300,

Slot boots: dressShoesBlack - quality: 95,

Slot gloves: plantFiberGloves - quality: 300,

End of inventory

 

shanks stats: Health= 70 Stamina= 70 Level= 66 SkillPoints= 13 ZombieKills= 605 PlayerKills= 0

 

Any idea what happens? I am doing something wrong? Thx

Link to comment
Share on other sites

Hello everyone. Sorry for my bad english. I do not get the Extra data. Especially the players speed.

 

<Tool Name="Player_Logs" Enable="True" Interval="45" Position="False" Inventory="True" Extra="True" Days_Before_Log_Delete="5" />

 

shortened

 

Any idea what happens? I am doing something wrong? Thx

 

Heya Shanks,

 

This thread is for allocs mods. The one you use here is ServerTools made by ObsessiveCompulsive.

 

If you ask the question in his thread im sure he will shine a light.

 

https://7daystodie.com/forums/showthread.php?77267-Servertools-updated-to-5-5

 

Cheers

Link to comment
Share on other sites

  • 4 weeks later...

Is /api/getplayerinventories broken? I get no output from it. I'm using it like this..

 

http://127.0.0.1:1234/api/getplayerinventories?adminuser=smeg&admintoken=secritpass

 

Has the format of the API call changed?

 

[Edit] On the server I'm trying this on it has Alloc's previous update not the current version. On my other server I have the current version and also get nothing from that command.

 

[Edit 2] Hmm.. is the command new? I retested on my dev server which is current and it worked this time. I get nothing still on the other one which is 1 version behind.

 

[Final edit] Oh nevermind. I checked the update history and see it is new. Carry on then.

Edited by Smegzor (see edit history)
Link to comment
Share on other sites

  • 3 weeks later...

Hello!

 

I've been noticing a bug in CSMM where it cannot load player info, upon further investigation it seems the player profile does not show up in getplayerslocation (offline=true) or in getplayerlist (rowsperpage = 9999 :D) response. However, CSMM does have some (old) data about the players in question stored in database so at some point that info was in the response(s).

 

Any idea what might cause players to "disappear" from the API responses? I have not managed to reproduce on a dev server yet :/.

 

One of the users that has this problem posted this error a few days ago about the si command, not sure if it's related

 

2018-08-17T17:22:19 1487.068 INF Error in ShowInventory.Run: System.NullReferenceException: Object reference not set to an instance of an object

at AllocsFixes.CustomCommands.ShowInventory.Execute (System.Collections.Generic.List`1 _params, CommandSenderInfo _senderInfo) [0x00000] in <filename unknown>:0

 

My theory is some sort of bugged player profile in the persistent data bin? I'm hoping you can shed some light on this ^^

Link to comment
Share on other sites

Sorry for the late reply. Is the player logging in at some times and still not showing up or is it about one that hasn't recently logged in at all?

 

Of course it could be some kind of corrupted data in the bin, but without actually looking at it it's hard to find out. The error though is at least not directly related, it's only about executing another command. If the player entry was corrupted and does not load because of that there should be another error, most likely at the start of the server itself. Also depending on the kind of corruption I'd expect it to break all of the data.

 

Really hard to tell with these files, still want to get rid of that at some point (ideally by moving the game's own data to something that's more usable for this kind of stuff instead of duplicating the data). But this is probably a bit ahead, at least A18 I suppose.

Link to comment
Share on other sites

Sorry for the late reply. Is the player logging in at some times and still not showing up or is it about one that hasn't recently logged in at all?

 

Of course it could be some kind of corrupted data in the bin, but without actually looking at it it's hard to find out. The error though is at least not directly related, it's only about executing another command. If the player entry was corrupted and does not load because of that there should be another error, most likely at the start of the server itself. Also depending on the kind of corruption I'd expect it to break all of the data.

 

Really hard to tell with these files, still want to get rid of that at some point (ideally by moving the game's own data to something that's more usable for this kind of stuff instead of duplicating the data). But this is probably a bit ahead, at least A18 I suppose.

 

I asked and it is indeed only happening to players who have not logged in for a long time (talking weeks here). Does the API only keep data for x amount of time? Or only show data that is more recent than some timestamp? If that's the case, there's probably no corrupted/bugged profile at all.

 

The affected server owner decided it's not worth the trouble trying to fix this edge case for inactive players with A17 around the corner now, so #wontfix :D

 

Thanks for the info!

Link to comment
Share on other sites

I asked and it is indeed only happening to players who have not logged in for a long time (talking weeks here).

But also not logged on now? Or is that about people who haven't been playing for weeks but now came back and they did not show up?

 

Does the API only keep data for x amount of time? Or only show data that is more recent than some timestamp?

No, nothing like that. Theoretically it should keep just everything ;)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...