Jump to content
Alloc

Improvements for the dedicated server

Recommended Posts

You can write a batch file that you can rum from the scheduler, something like:

 

start telnet.exe 192.168.1.1

 

cscript SendKeys.vbs

 

Then have sendkeys.vbs say:

 

set OBJECT=WScript.CreateObject("WScript.Shell")

WScript.sleep 50

OBJECT.SendKeys "mylogin{ENTER}"

WScript.sleep 50

OBJECT.SendKeys "mypassword{ENTER}"

WScript.sleep 50

OBJECT.SendKeys " cd /folder/7dayserver{ENTER}"

WScript.sleep 50

OBJECT.SendKeys " shutdown command that 7 days uses"

 

...or something. I'm sure I'm missing something.

 

Kind of making it up as I google, but I still suggest using a server manager that supports this feature.

Edited by Guppycur (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
yes I can also do that on Windows Server 2012 but killing the process does not save the last game state like using the console shutdown command via Telnet. when I tried killing the process on a schedule players complained they lost items or progress because everything was lost between the last server save and the process kill.

 

Ah right.

On linux with Allocs management scripts, it doesn't kill the process, it gracefully shuts down the server (if possible).

I'm a winblows newb, so can't help with that.

Share this post


Link to post
Share on other sites

@Guppycur - cool idea I will research that, always wanted to script telnet.

@Zigstum so Alloc has a shutdown command that can be scripted? how is it exposed? maybe I can use Powershell to call it.

 

- - - Updated - - -

 

@Alloc - can your commands like shutdown be called from a Windows server (2012/R2) powershell?

 

I have not done a lot of development since I got dev neutered in the late 90s so not sure if 7DTD or your component exposes any interfaces.

 

that would be supper cool. @madmole does not seem to understand or care about server management and I don't know who on the dev team does.

Share this post


Link to post
Share on other sites

@Lonestarcanuck: As zigstum already pointed out that instance shutdown stuff is Linux Bash scripting, nothing within the game. You can definitely get something similar done on Windows, just don't ask *me* how ;)

 

@Guppy: I actually don't really feel like adding stuff for something that's not even (officially) in the game yet ;)

Share this post


Link to post
Share on other sites

Yeh, I get that; but if you gated it behind permissions, you wouldn't really be adding it as much as, allowing US to add it. Yeh, that's my rationalization and I'm sticking with it. :)

Share this post


Link to post
Share on other sites

Hi Alloc,

 

In the screenshot below, the red squares indicate where the players are. Why are there zombies showing biomes away? Is the map incorrect or is there a chance that left behind zombies are keeping map chunks active consuming unnecessary server resources (including "MaxSpawnedZombies")? I know with another thread I posted on collapsing blocks/physics issues that zombies do keep chunks active and things will keep collapsing even if the player is miles away.

 

The "le" command seems to only return "EntityZombie" close to me. There must be another command or your map must use some different mechanism because it'll show them regardless of player distance.

 

Would it be worthwhile to consider a command that'll remove all entities map wide further than a specified distance from the nearest player? Coppi created a "removeentity" command, so if you think this is going too far outside of Alloc's fixes I'll chase it up with him.

 

604TEqw.png

Share this post


Link to post
Share on other sites
Hi Alloc,

 

In the screenshot below, the red squares indicate where the players are. Why are there zombies showing biomes away? Is the map incorrect or is there a chance that left behind zombies are keeping map chunks active consuming unnecessary server resources (including "MaxSpawnedZombies")? I know with another thread I posted on collapsing blocks/physics issues that zombies do keep chunks active and things will keep collapsing even if the player is miles away.

 

The "le" command seems to only return "EntityZombie" close to me. There must be another command or your map must use some different mechanism because it'll show them regardless of player distance.

 

Would it be worthwhile to consider a command that'll remove all entities map wide further than a specified distance from the nearest player? Coppi created a "removeentity" command, so if you think this is going too far outside of Alloc's fixes I'll chase it up with him.

 

604TEqw.png

 

I've those pseudo zombies on my server too, had them in alphas before too but since A15 they are more often. I just checked with "le" too and they are on the list, even if no player is online. I killed them through telnet "kill id" and they disappeared from map too. So this seems to be an game issue not an issue from Allocs fixes.

Share this post


Link to post
Share on other sites
I use the "killall" command to clean up these persistent zombies before a horde night. I've pointed this out to Alloc a few times. What really gets me on this issue is when the zombies are in unexplored areas or way out in the radiation zone.

 

Hey schwanz9000, "help killall" command returns "kill all players". You *sure* that's the right one?

 

Edit: As in, is there a way to parameterise the command to kill zombies only?

Edited by mythan (see edit history)

Share this post


Link to post
Share on other sites

Anyone knows why the webmap works for me but not for my friends? They only see the map black.

 

I have permission lvl 0 and I see that they connect to the map with 1000. I guess that's the default.

But shouldn't default show them the map? They only see the text online/offline players, to the right.

Share this post


Link to post
Share on other sites

map view is not set by default as i know, you have to set it in webpermissions.xml file. (correct me if im wrong)

Share this post


Link to post
Share on other sites
Anyone knows why the webmap works for me but not for my friends? They only see the map black.

 

I have permission lvl 0 and I see that they connect to the map with 1000. I guess that's the default.

But shouldn't default show them the map? They only see the text online/offline players, to the right.

 

webpermission add <webfunction> <level>

webpermission add web.map 2000

 

Put the second line in console.

Share this post


Link to post
Share on other sites
Anyone knows why the webmap works for me but not for my friends? They only see the map black.

 

I have permission lvl 0 and I see that they connect to the map with 1000. I guess that's the default.

But shouldn't default show them the map? They only see the text online/offline players, to the right.

 

webpermission add <webfunction> <level>

webpermission add web.map 2000

 

Put the second line in console.

 

Yes. Just to clarify what zig is saying, to view the webmap without steam log in or admin privileges, the permission web.map needs to be set to 2000.

  • Like 1

Share this post


Link to post
Share on other sites

I am trying to find the easiest way for admins (mostly me) to remove LCB/Keystones. I have Allow and Server Tools installed.

 

right now what I do is use LLP nearby 10 to see what LCB I am looking at and then I use RLP and the X Y Z or the steamID if there are several in the same area by same person.

 

is there a way to automate that? it would be great if the RLP command had "nearby" and a radius option :)

 

PS: I moved my server off of CBSM - it was causing performance issues with all its telnet traffic and IMO not worth the down as much as up when it is using ALLOC tools anyway :)

Share this post


Link to post
Share on other sites
Yes. Just to clarify what zig is saying, to view the webmap without steam log in or admin privileges, the permission web.map needs to be set to 2000.

 

They are logging in through steam. But it's not working. I edited the permissions in the webmap setting but still not working. Here is the log:

Web:Static:FileNotFound: "/static/favicon.ico" @ "C:\Program Files (x86)\Steam\steamapps\common\7 Days to Die Dedicated Server\Mods\Allocs_WebAndMapRendering/webserver/favicon.ico"
2016-11-15 19:49:58	1634.092	Log	Steam certificate error: RemoteCertificateChainErrors
2016-11-15 19:49:59	1635.478	Log	Steam OpenID login from XXX.XXX.XXX.XXX:XXXX with ID XXXXXXXXXXXX, permission level 1000

Why does it say Steam certificate error? Doesn't do that with my account

Share this post


Link to post
Share on other sites
They are logging in through steam. But it's not working. I edited the permissions in the webmap setting but still not working.

 

Why does it say Steam certificate error? Doesn't do that with my account

 

That certificate error is something that just happens every once in a while. Not sure what it means.

 

Could you copy and paste the contents of webpermissions.xml in your root/saves folder so I can see what your settings are?

Share this post


Link to post
Share on other sites

Sorry! Noob warning. If I had opened it with Notepad++ from the beginning then I would have noticed that half of the lines were "edited out".

Thanks for the help! I think it should work now. Just need to get a friend to check it again

Share this post


Link to post
Share on other sites

As this is not at git hub i'll make a pull request here :D

 

@stats.js

		// 7 to 1 (days till next horde):   Number(7-data.gametime.days%7)
		// Week day 1 to 7: 				(data.gametime.days%7>0?data.gametime.days%7:7)
		var time = "Day " + data.gametime.days + ' (' + (data.gametime.days%7>0?data.gametime.days%7:7) + "), ";

Edited by Devidian
added other way 1 to 7 as requested (see edit history)

Share this post


Link to post
Share on other sites

Please tell me there is a better way to repair chunk density errors. We run a fairly busy server and I spend roughly 30 mins every night going around the map fixing chunk density errors that were reported by players... after months of doing this, it's killing me.

 

My current method:

 

  1. Go to the reported coordinate
  2. Walk to where I can see the problem and type "le" in console to get my current coordinates
  3. Type "rcd <x> <z>" (substituting x & z with the relevant coordinates)
  4. Remote into the server and check the log file, which is up to about 10mb for the day, scroll to the bottom and find the lines that say "2016-11-19T20:41:47 47091.502 WRN DENSITYMISMATCH;1830;114;174;6;114;14;-1;0;False"
  5. Go back into the game, type "rcd 1830 174 fix".

 

There can be up to 8 density mismatch warnings at a given coordinates. I fly around for a bit repeating steps 1-5 and finding more mismatches before moving on to another area that was alerted.

 

On a particularly bad night I can spend an hour going around just fixing these... it's too much. Hoping someone will tell me I've been silly and there is a much easier way to do this.

Share this post


Link to post
Share on other sites
Please tell me there is a better way to repair chunk density errors. We run a fairly busy server and I spend roughly 30 mins every night going around the map fixing chunk density errors that were reported by players... after months of doing this, it's killing me.

 

My current method:

 

  1. Go to the reported coordinate
  2. Walk to where I can see the problem and type "le" in console to get my current coordinates
  3. Type "rcd <x> <z>" (substituting x & z with the relevant coordinates)
  4. Remote into the server and check the log file, which is up to about 10mb for the day, scroll to the bottom and find the lines that say "2016-11-19T20:41:47 47091.502 WRN DENSITYMISMATCH;1830;114;174;6;114;14;-1;0;False"
  5. Go back into the game, type "rcd 1830 174 fix".

 

There can be up to 8 density mismatch warnings at a given coordinates. I fly around for a bit repeating steps 1-5 and finding more mismatches before moving on to another area that was alerted.

 

On a particularly bad night I can spend an hour going around just fixing these... it's too much. Hoping someone will tell me I've been silly and there is a much easier way to do this.

 

We re-enabled binimikes on our server with the release of A15 hoping they would not be so buggy and require constant admin hand-holding. Whilst the bike may be less buggy (within five minutes of someone having a bini it began "Admin!!"), the worst of it is that the whole map was pretty much uncovered after 300 days. Our server just gets laggier and laggier as the map gets uncovered - it was so bad after 350 days we had to do a wipe :/ We carried across playerfiles to ease the pain, disabled the bini chassis in XML, and re-opened on the modded tab. Now we are 650 days in and we are back to that place again - whereas A14 would get to day 1000 generally before it was wipe time.

Everytime the word 'wipe' is mentioned, the tears flow enough to make Noah nervous; fortunately with the new 'English Weather Mod', they are just crying in the rain.

 

I'd love to know how to keep a map running well, so that we could extend our wipe cycle, but am clueless other than flying in with a rocket launcher everytime i see some weird message about 'should be a parent but is not!' and blowing up anything i can find until the error stops it's 30 lines per second log filling mission. My latest favourite is some cryptic announcement about a 'shaggy_male_hair_hat' ^^

Share this post


Link to post
Share on other sites

Could you guys please stop randomly posting stuff in here? This thread is about the mod, not the game in general.

 

 

is there a way to automate that? it would be great if the RLP command had "nearby" and a radius option

Nope, nothing like that in yet, but that sounds like a good idea :)

 

 

 

@stats.js

		// 7 to 1 (days till next horde):   Number(7-data.gametime.days%7)
		// Week day 1 to 7: 				(data.gametime.days%7>0?data.gametime.days%7:7)
		var time = "Day " + data.gametime.days + ' (' + (data.gametime.days%7>0?data.gametime.days%7:7) + "), ";

For those silly people that can't do mod7 in their head? Not sure if I want to support those peasants ;P

Added it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...