Jump to content

Improvements for the dedicated server


Recommended Posts

That exception won't cause any problems, it's caught before it could do any harm. Can't look at the full log right now though.

 

I reinstalled the server today and loaded the mod from your site again. I started the server, logged me in at the webinterface, look in to a inventory and get this error:

 

2015-09-07T23:37:06 358.746 ERR GetRange: invalid end 49 (listOffset: 1102, count: 100)

2015-09-07T23:37:06 358.746 ERR Error in ApiHandler.HandleRequest(): Handler getlog threw an exception:

2015-09-07T23:37:06 358.746 EXC Object reference not set to an instance of an object

NullReferenceException: Object reference not set to an instance of an object
 at AllocsFixes.NetConnections.Servers.Web.API.GetLog.HandleRequest (System.Net.HttpListenerRequest req, System.Net.HttpListenerResponse resp, AllocsFixes.NetConnections.Servers.Web.WebConnection user, Int32 permissionLevel) [0x00000] in <filename unknown>:0 

 at AllocsFixes.NetConnections.Servers.Web.Handlers.ApiHandler.HandleRequest (System.Net.HttpListenerRequest req, System.Net.HttpListenerResponse resp, AllocsFixes.NetConnections.Servers.Web.WebConnection user, Int32 permissionLevel) [0x00000] in <filename unknown>:0 
UnityEngine.Debug:Internal_LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
Logger:masterLogException(Exception)
Logger:Exception(Exception)
Log:Exception(Exception)
AllocsFixes.NetConnections.Servers.Web.Handlers.ApiHandler:HandleRequest(HttpListenerRequest, HttpListenerResponse, WebConnection, Int32)
AllocsFixes.NetConnections.Servers.Web.Web:HandleRequest(IAsyncResult)
System.Net.ListenerAsyncResult:InvokeCallback(Object)

 

This error occours everytime i open a inventory in the webinterface.

Link to post
Share on other sites
How Do i install the files again on My Dedi Server? Been a While.... Sucks lol

 

Once downloaded unpack the archive to your server folder so you get a Mods folder in the server root folder.

https://7dtd.illy.bz/wiki/Server%20fixes#Download

 

-OR-

 

https://7dtd.illy.bz/wiki/Server%20fixes#Buildyourself

Edited by schwanz9000 (see edit history)
Link to post
Share on other sites
I reinstalled the server today and loaded the mod from your site again. I started the server, logged me in at the webinterface, look in to a inventory and get this error:

...

This error occours everytime i open a inventory in the webinterface.

 

You sure it's not another user accessing the page at the same time? As I said this should only pop up when someone tries to access the log page (but again: it won't hurt).

Link to post
Share on other sites

I noticed that 1st the other telnet connections will disconnect or the data comes slower and sometimes the webinterface goes down so that i have to restart the server. their is no other connection on the webinterface, because we dont post this to our players.

 

it's a bit crazy with your mod and a12.5.

Link to post
Share on other sites
I noticed that 1st the other telnet connections will disconnect or the data comes slower and sometimes the webinterface goes down so that i have to restart the server. their is no other connection on the webinterface, because we dont post this to our players.

 

it's a bit crazy with your mod and a12.5.

Not telling players about it doesn't mean they can't access it ;)

Those that do know about this mod might just try to guess the port.

 

If you do feel like it's caused by the mod ... try running the server without and see if it gets any better. As I said I doubt it's the mod that's causing the problems though.

 

alloc is it possible in the next version of the web map for admins to be able to kick/ban directly from the map?

Depends on when the next version will be released ... I just have to keep updates to myself long enough before I release it then such feature will be in the "next" version :p

User administration is of course planned but it probably won't become available for a bunch of weeks.

Link to post
Share on other sites

Hey guys,

 

I just rented myself a server and have put Alloc's fixes on there. All running fine, but just wanted to check with you guys whether these 2 errors I am getting are anything worth looking into?

 

 

This one pops up just once every now and again, highlighted in red in the log, seems to coincide roughly with me logging in;

Error A client which was not in the connected player list disconnected. ???

 

 

This one pops up more frequently, sometimes a few of them, sometimes a lot, sometimes dont see them for a while at all;

Log Error in Web.HandleRequest(): Remote host closed connection: An existing connection was forcibly closed by the remote host

 

 

I did have a search around, but couldent find anything specific to these. I'm thinking they aren't anything to worry about, they dont seem to be affecting anything at any rate, but wouldn't mind if someone in the know could confirm for me.

 

Cheers.

 

A.

Link to post
Share on other sites

Come up with another one, though more throwing this out there in case its a bug than because its a real issue for me;

 

Error in ApiHandler.HandleRequest(): Handler getlog threw an exception: NullReferenceException: Object reference not set to an instance of an object

 

Now I know this time its something between the web interface for the log and the server; the map still works perfectly, but if I click to view the log I get nothing showing, hence the getlog entry in the error.

 

Checking the log elsewhere I can see the above error repeated so long as I remain on the log page, if I switch back to map it will stop again.

 

This seems to clear its self for a while if I restart the server, but eventually will come back.

 

- - - Updated - - -

 

I've seen both of those and as far as I know they are harmless.

 

The first one might be a server manager connection or lost packets or both.

 

The second one happens every time just before a player logs on.

 

 

Thanks, good to know that first one is normal, its the one I thought may be worth looking at :)

Link to post
Share on other sites

Love the webserver thing you added to your server fixes. I noticed some of the inventory icons on the webserver inventory dialog are not exactly correct. My best guess is that it is returning the icon based on the item name, and not respecting the 'CustomIcon' and 'CustomIconTint' properties. Is that something that might get updated in a future version?

Link to post
Share on other sites

Hey Alloc, with your new map interface, is it possible to set it up in such a way that players can only see themselves and their own claim blocks on the map? This would be very useful for players and make it much easier to confirm if their claim blocks adequately cover their base.

Link to post
Share on other sites
Love the webserver thing you added to your server fixes. I noticed some of the inventory icons on the webserver inventory dialog are not exactly correct. My best guess is that it is returning the icon based on the item name, and not respecting the 'CustomIcon' and 'CustomIconTint' properties. Is that something that might get updated in a future version?

Yeah, that could be. Do you have a specific example of such an item?

 

 

Hey Alloc, with your new map interface, is it possible to set it up in such a way that players can only see themselves and their own claim blocks on the map? This would be very useful for players and make it much easier to confirm if their claim blocks adequately cover their base.

Yeah, that sounds like a really good idea, added to my list :)

Link to post
Share on other sites
Yeah, that could be. Do you have a specific example of such an item?

 

The shirts and tank tops are a good example.

 

<item id="708" name="plaidShirtRed">
       <property name="Meshfile" value="Items/Crafting/leather" />
       <property name="Material" value="cloth" />
       <property name="HoldType" value="21" />
       <property name="Stacknumber" value="1" />
       <property name="RepairTools" value="cloth" />
       <property name="EquipSlot" value="Chest" />
       <property name="FuelValue" value="3" />
       <property name="Weight" value="3" />
       [b]<property name="[color="#FFFFFF"]CustomIcon[/color]" value="plaidShirt" />
       <property name="[color="#FFFFFF"]CustomIconTint[/color]" value="AD0000" />[/b]

 

nuzVbWa.png

Link to post
Share on other sites
  • 2 weeks later...

Hi Alloc:

 

I want to script something that allows me to remove banned players from showing up on the web map as "known" players. If they're banned, I don't want a flag on my map showing a banned player as "offline." I tried deleting the player data from $SDTDHOME/instance/Random Gen/seed/Player, but that doesn't affect the web map.

 

Further investigation showed that the web map keeps a persistent data store in the seed directory called "AllocsPersistentData.bin". Looking at string data suggests this is where the players data is stored. Can you share a little info about this file? What format is it, how to access it safely, etc.?

 

Thanks!

Link to post
Share on other sites

What dmustanger said ;)

I plan to add more options to the map to filter out players so you don't see an endless list of players that aren't even active. So filtering banned or inactive users should become possible.

Link to post
Share on other sites
What dmustanger said ;)

I plan to add more options to the map to filter out players so you don't see an endless list of players that aren't even active. So filtering banned or inactive users should become possible.

 

Thanks dmustanger and Alloc.

 

I'll see what I can see with a hex editor. I have no real experience reverse engineering binary files, so I will probably delete the file as dmustanger suggests or just wait for your enhancements. I don't suppose I could talk you into using some kind of a lightweight database instead, like sqlite or nosql or something? Thanks!

Link to post
Share on other sites

I have a server (Linux dedicated 32-bit) that has been up now for 4 weeks but this morning it stopped allowing people to attach and I started getting errors in the output log to the effect "cannot open file such-and-such" and "too many open files." The user under which my server runs had a maximum of 8192 files open. I increased this to 32768 and the server is working again.

 

The troubling part of this is that "cat /proc/sys/fs/file-nr" gives the following output: 2528 0 3285628. This is while the server is running, which is well short of the 8192 max. Why was I getting those error messages? Does the server open a bazillion files during startup and then release them at some point?

 

I've opened a thread under "Support" already, but was hoping someone here knows what's going on. Pastebin with the log here:

 

http://pastebin.com/eJmC6JW1

 

Thanks for any insight!

Edited by blotavious (see edit history)
Link to post
Share on other sites
The shirts and tank tops are a good example.

 

<item id="708" name="plaidShirtRed">
       <property name="Meshfile" value="Items/Crafting/leather" />
       <property name="Material" value="cloth" />
       <property name="HoldType" value="21" />
       <property name="Stacknumber" value="1" />
       <property name="RepairTools" value="cloth" />
       <property name="EquipSlot" value="Chest" />
       <property name="FuelValue" value="3" />
       <property name="Weight" value="3" />
       [b]<property name="[color="#FFFFFF"]CustomIcon[/color]" value="plaidShirt" />
       <property name="[color="#FFFFFF"]CustomIconTint[/color]" value="AD0000" />[/b]

 

nuzVbWa.png

 

I'd throw in the armors. It would be nice to apply a CustomColor versus a tint. Iron armors appear to resist even tints; as with many things color and effect appear to be derived from the prefab/model/mesh and not independent colors.

 

Or...perhaps items could have the same default color and every version of that item be a tint.

 

As an example, the plaidshirt has a default color which is neutral and each shirt has a tint which establishes the color. Plaid shirts seem to do fine in this regards; other items such as the denim pants are ok, with the armors not doing as well (try making iron armor black, or any other color, for that matter).

 

Vote h0tr0d 2016 -- the "icon".

Link to post
Share on other sites
The shirts and tank tops are a good example.

 

<item id="708" name="plaidShirtRed">
       <property name="Meshfile" value="Items/Crafting/leather" />
       <property name="Material" value="cloth" />
       <property name="HoldType" value="21" />
       <property name="Stacknumber" value="1" />
       <property name="RepairTools" value="cloth" />
       <property name="EquipSlot" value="Chest" />
       <property name="FuelValue" value="3" />
       <property name="Weight" value="3" />
       [b]<property name="[color="#FFFFFF"]CustomIcon[/color]" value="plaidShirt" />
       <property name="[color="#FFFFFF"]CustomIconTint[/color]" value="AD0000" />[/b]

 

nuzVbWa.png

 

There is a solution to this. Please open the below link and check #229.

 

https://7daystodie.com/forums/showthread.php?14482-Inventory-item-Atlas-index-editor&p=274307&viewfull=1#post274307

 

Basically you just have to use some graphic software to create icons (.png) then drag into the folder Mods\ItemIconTest\ItemIcons

 

 

Here is an example

 

2.jpg.ea03bb0aaa9b0ecf0bfb2c43171d5732.jpg

1.jpg.4e0ef563593f35fda4da436e75a66f46.jpg

Link to post
Share on other sites
There is a solution to this. Please open the below link and check #229.

 

https://7daystodie.com/forums/showthread.php?14482-Inventory-item-Atlas-index-editor&p=274307&viewfull=1#post274307

 

Basically you just have to use some graphic software to create icons (.png) then drag into the folder Mods\ItemIconTest\ItemIcons

 

 

Here is an example

 

[ATTACH=CONFIG]11098[/ATTACH][ATTACH=CONFIG]11099[/ATTACH]

 

While that does achieve the desired end result its not as elegant (or automated) as just having the block/item property for CustomIcon be read and use that as the filename for the .png instead of the block/item name.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...