Jump to content

Crashing Issue


Recommended Posts

Been playing since Alpha 15 and I haven't had crashing issues but with the release of Alpha 17 I have constant crashing issues, mainly trying to enter buildings, with everything on the lowest settings and low resolution I'm getting 50-60 fps, so I'm not really having fps issues but constant crashes


I've tried verifying my files, deleting the game and re-downloading, disabling EAC, switching from 64-bit to 32-bit, switching from dx11 to glcore, lowering all my graphic settings.


CPU : Core i5 750 @ 2.66 Ghz

Memory : 4GB DDR3 @ 1333 Mhz

GPU : Radeon HD 5770 1GB (DX11)


I'm guessing my problem is my graphics card, I've heard some people on reddit saying the new unity engine uses a new version of dx11 (dx11.7?) which is causing crashes for my older graphic card. Is there any possibility of this being fixed or am I out of luck? I was so hyped for the release of A17 to play with friends but everyone is waiting for me until my crashing issue is fixed. The number one thing I wanted for Christmas was Alpha 17 stable, and I got it but I can't play without crashing :miserable:

Link to comment
Share on other sites

You only have 4GB RAM. Minimum requirement for the game has been 6GB for quite a while now. Might be ok playing a14 or earlier in 32-bit mode, but your system literally has no RAM to work with. Just having a few tabs open in Chrome with a couple of extensions will tax what little resources you have.

Link to comment
Share on other sites

It's actually surprising how well virtual memory works on a ssd, I've been playing other games such as Ark with mods installed, Path of Exile, Killing Floor 2 and haven't had any crashing issues, and sunk around 500 hours in alpha 16 without little to no crashes, I would be surprised if this is a memory issue.


Does the new unity engine have problems with low memory that the unreal engine (3.5+) doesn't have?

Link to comment
Share on other sites

Other games such as Ark, Path of Exile, Killing Floor, ect... Are not fully destructible 3D Voxel environments. They will tax your GPU a lot more than they will tax your CPU and RAM. As such, they really can't be compared to 7 Days at all by any performance standard or system requirement.


Virtual memory is only so fast, and even using an SSD, it's nowhere near as fast as actual RAM. You can't substitute it when it's slower by a magnitude of 10 at best when compared to basic DDR3.


Bottom line, you don't meet min specs for the client in a16. In a17 you're even further behind. The voxel terrain requires a lot of CPU calculations, and the data is stored in, and fetched from RAM. This data is accessed and updated constantly as you move around in the world.


It's not an issue with Unity. It's an issue on minimum system requirements for what the game engine requires to function properly.

Link to comment
Share on other sites

Alpha 16 ran so well even though my computer doesn't meet the requirements, even alpha 17 I'm getting 50 to 60 fps, it's running fine then suddenly it just crashes when entering buildings, I've never seen a game run well then suddenly crash like how 7 days is crashing.


Is it possible even if a game is running at 60 fps it's actually having problems running?

Link to comment
Share on other sites

Unity is not my favorite engine for many reasons, but as Sylen said, this new version gobbles up resources. I have no issues on my end now that I found a work-around for a bug which limited the exclusive mode to 60Hz (60fps). Still, it uses a good amount of system RAM and is very comparable to Ark in that aspect, but it seems to use more threads than Ark and thus uses more cores.


I disagree that Chrome can gobble four gigs with a few tabs open (we have 4GB PCs at the office that cruise all day with many things open), but 4GB is not enough for recent games, Ark included. In fact, you are probably running Ark with the parameter that tells it you have 4GB so it conserves memory. 7 Days does not have such an option.

Link to comment
Share on other sites

OS Name Microsoft Windows 10 Home

Version 10.0.17134 Build 17134

Processor Intel® Core i7-2600K CPU @ 3.40GHz, 3401 Mhz, 4 Core(s), 8 Logical Processor(s)

BIOS Version/Date Intel Corp. BGP6710J.86A.1900.2011.0210.1012, 2/10/2011

Hardware Abstraction Layer Version = "10.0.17134.471"

Installed Physical Memory (RAM) 8.00 GB

Total Physical Memory 7.98 GB

Available Physical Memory 5.72 GB

Total Virtual Memory 18.0 GB

Available Virtual Memory 15.2 GB

Page File Space 10.0 GB

AMD Radeon HD 5700 - 1.0 GB mem (tried with crossfire enabled as well - 2GB)

DirectX 12 - renderer set to DirectX 11

Total Disk Size 6 TB


- Did you start a new game and re-create the issue? Yes, several times.

- Have you validated your files through Steam? Yes, and I reinstalled the game several times

- After validation, did you re-try with a brand new game? Yes, multiple times


No matter how trivial the problem might be...

- List the seed name, and coordinates of the issue. Navezgane - Any tested POI and Trader

- State the size of server/host (how many players playing at the same time) This issue affects single player

- Is everyone else on the server (if applicable) experiencing the same issue? N/A


Game crashes when I get in LOS of traders; get on motorbike; or try to put motorbike down near a POI. get on gyrocopter.


I have tried:

run game with/wo EGC

run in 64 and 32 bit mode

Video settings multiple variations of Low and high

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...