Jump to content

DEAk0n

Members
  • Posts

    6
  • Joined

  • Last visited

DEAk0n's Achievements

Refugee

Refugee (1/15)

4

Reputation

  1. BUG REPORT: Functional regression - KinGen no longer generates maps using the Compo Pack I attempted to generate a map on a fresh install of 7D2D, only the Compo Pack installed, as per the instructions found on the above link. When using the supplied POI list, KingGen throws an error. Verison: KinGen 0.13.1 Platform: Linux x64 (Arch) Python: 3.9.6 (repo installed) The error message: Traceback (most recent call last): File "crash_log.py", line 19, in handle_crash_log File "gui_generation.py", line 27, in generate File "ntime.py", line 11, in ntime File "world.py", line 1301, in run File "world.py", line 272, in generate File "world.py", line 349, in gen_villages File "world.py", line 393, in gen_villages_forest File "hub_factory.py", line 79, in gen_hub File "city.py", line 46, in __init__ File "city.py", line 53, in generate File "city.py", line 125, in gen_grid IndexError: too many indices for array: array is 1-dimensional, but 2 were indexed Without any other error messages, I am at the end of my ability to troubleshoot without access to source. Thank you, and have a great day.
  2. Hi again. Trying out 0.12.2, on 64bit Linux, downloaded from the link on page 1. Command issued: ./KingGen gen MapName 4 Expected result: A map named "MapName" to be generated with default options, at a size of 4k x 4k. Actual result: > ./KingGen gen MapName 4 KingGen v0.12.2 for 7 Days to Die A19.6 Traceback (most recent call last): File "king_gen.py", line 43, in <module> File "king_gen.py", line 33, in main File "ntime.py", line 11, in ntime File "king_gen.py", line 24, in run File "arguments.py", line 207, in parse_args File "arguments.py", line 134, in gen_func File "world.py", line 37, in __init__ File "world.py", line 107, in handle_kwargs KeyError: 'poi_mode' [302974] Failed to execute script king_gen I have good news though. The bug that was keeping the GUI from launching appears to be patched up. EDIT: I had a hunch that I may have not re-installed the COMPO pack, or that it needed to be updated. So, I checked, and downloaded/installed the newest version for KingGen... No improvement. The error above remains.
  3. If I remember correctly, and don't quote me on this... Right click on KingGen.exe, and select "Run as Administrator"... That sounds right.
  4. Now that I have the KingGen CLI working (the GUI seems to be an issue with TKinter/TK... Maybe a QT5 front end? Anyway...), I have unsuccessfully looked for a rundown on the CLI's longopts, and their accepted values. Does anyone have a link to that? The -h option gives me a list of longopts, but without any accepted values. Thanks in advance.
  5. Ok! Yes. That works as expected. Uhh, that also implies KingGen was trying to create a... 4096000 x 4096000 map. Wow... No wonder it wanted 64TiB of memory! Still, the GUI option is throwing the same error... I think I remember that's a known issue though...
  6. Hi there, sorry to have to post a bug report... Version: KingGen v0.11.1 for 7 Days to Die A19.5 Platform: Linux 5.12.14 (Arch Linux x64) Command(s) Tested (all run from the folder where the program downlaoded): ./KingGen <no args>, and ./KingGen gen KingGenTestMap 4096 Result(s) - ./KingGen <no args>: X Error of failed request: BadIDChoice (invalid resource ID chosen for this connection) Major opcode of failed request: 1 (X_CreateWindow) Resource id in failed request: 0x9800094 Serial number of failed request: 894 Current serial number in output stream: 896 - ./KingGen gen KingGenTestMap 4096: KingGen v0.11.1 for 7 Days to Die A19.5 Generating heightmap. Traceback (most recent call last): File "king_gen.py", line 43, in <module> File "king_gen.py", line 33, in main File "ntime.py", line 11, in ntime File "king_gen.py", line 24, in run File "arguments.py", line 206, in parse_args File "arguments.py", line 133, in gen_func File "world.py", line 228, in generate File "world.py", line 912, in init_heightmap File "world.py", line 1006, in gen_heightmap File "world.py", line 1121, in noise File "pyfastnoisesimd/helpers.py", line 777, in genAsGrid File "pyfastnoisesimd/helpers.py", line 33, in empty_aligned numpy.core._exceptions.MemoryError: Unable to allocate 64.0 TiB for an array with shape (70368744177696,) and data type int8 [298398] Failed to execute script king_gen All that generates is the output folder, and one file: KingGenConfig.txt... _ ___ _____ | |/ (_) / ____| | ' / _ _ __ __ _| | __ ___ _ __ | < | | '_ \ / _` | | |_ |/ _ \ '_ \ | . \| | | | | (_| | |__| | __/ | | | |_|\_\_|_| |_|\__, |\_____|\___|_| |_| __/ | |___/ v0.11.1 - A19.5 7 Days to Die Random World Generator Find out more at https://community.7daystodie.com/topic/23988-kinggen-a-random-world-generator-for-7-days-to-die/ SETTINGS: border_size=medium border_type=water burnt_size=medium cities_grid_size=medium cities_level=60 cities_number=medium cities_size=medium default_biome=pine forest desert_size=medium heightmap_smoothing=none mountains_size=medium name=KingGenTestMap output_folder= png_heightmap=no pois_list=vanilla pois_number=medium seed=EgeLBqrsTZ size=4096 skip_preview=false snow_level=false snow_size=medium spacing=medium spawn_points=medium terrain_roughness=medium towns_grid_size=medium towns_number=medium towns_size=medium traders_location=cities traders_number=medium villages_grid_size=medium villages_number=medium villages_size=medium waste_size=medium water_level=43 water_size=medium Without any other output, I'm at a loss as to what could be the issue. Any, and all help will be appreciated.
×
×
  • Create New...