Jump to content

Chairkicker

Members
  • Posts

    24
  • Joined

Posts posted by Chairkicker

  1. Hi Damocles, great work on the sliders feature. That said, I'm encountering an issue that I haven't seen since 467; sometimes a world gen will fail and all that'll be generated is biomes.png, genHM.png, radiation.png, and main.ttw; a preview subfolder is generated but is empty. I've been trying to debug and pinpoint what setting or combination of settings causes this, but so far it's been inconsistent. I'll attach the last config I tried. I've replaced my prefabslist with a compopack 40 one, but that doesn't seem to be the issue as with default settings worldgen works fine. Good luck.

     

    Edit: finally found it! Seems to be related to the "no POIs in biome" setting. That seems to break it in conjunction with some other settings, unsure which precisely.

     

    idVHhoV.png

  2. Ok, I will add a flat world option. Currently you can easily make one with an imported hightmap as described by Gamida.

     

    -----

     

    New version online 0.432

     

    -dark Theme (makes you 150% cooler!)

    -saving selection state of the dropdowns

    -font size in configs

     

    you can set the theme back to the old one by setting DARK_THEME = 0 in the config.txt

     

    Thank you so much! Now I think all I'd like is, as others have requested, better granularity in biome selection; the option to have traditional wide swaths of wasteland generate, per-biome checkbox (for instance, excluding biomes instead of using the 'only X' option), option to generate biomes not based on heightmaps (so we can have relatively flat, hilly terrain but with variety of biomes), and so on.

×
×
  • Create New...