Jump to content
  • Cant load save. NullReferenceException

    • Version: A21 b313

    Summary: When trying to load a world this error keeps flooding the console and prevents the game from loading when "Creating Player".

    Game Version: A21 b313

    OS/Version: Windows 10  (10.0.19045) 64bit

    CPU Model: Intel(R) Xeon(R) CPU X3470 @ 2.93GHz (cores: 8)

    System Memory: 12gb

    GPU Model and VRAM: NVIDIA GeForce GTX 1050 Ti 4gb

    Screen Resolution: 1336x768

    Video Settings: Low-Medium custom settings.

    Game mode: SP and RWG


    Did you wipe old saves? Yes


    Did you start a new game? Yes


    Did you validate your files? Yes


    Are you using any mods? No


    EAC on or off? Off


    Status: NEW


    Bug Description: NullReferenceException: Object reference not set to an instance of an object

    INF Loading players.xml
    IndexOutOfRangeException: Index was outside the bounds of the array.
      at Archetypes.BuildUMA (Archetype _archetype, UMA.UMAData _umaData, SlotLibrary _slotLib, OverlayLibrary _overlayLib, Entity _entity, System.String _profileName, System.Boolean _showPreviewSlots, System.Boolean _useCustomColors, UnityEngine.Color hair, UnityEngine.Color eye, UnityEngine.Color skin, PlayerProfile _playerProfile) [0x00398] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at EModelUMA.fullyBuildUMA () [0x00008] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at EModelUMA.GenerateOneUMA (EntityClass _ec) [0x000f2] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at EModelUMA.createModel (World _world, EntityClass _ec) [0x00048] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at EModelUMA.Init (World _world, Entity _entity) [0x000ca] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at Entity.InitEModel () [0x00061] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at Entity.Init (System.Int32 _entityClass) [0x0000d] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at EntityAlive.Init (System.Int32 _entityClass) [0x00000] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at EntityPlayer.Init (System.Int32 _entityClass) [0x0002e] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at EntityPlayerLocal.Init (System.Int32 _entityClass) [0x00000] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at EntityFactory.CreateEntity (EntityCreationData _ecd) [0x0017c] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at GameManager+<StartAsServer>d__143.MoveNext () [0x00532] in <6e84410da6af456b89dc5c9197d3182b>:0 
      at UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) [0x00026] in <4bba812690714c578170328b4ec178d0>:0 


    Detailed steps to reproduce the bug:

    1) Try to load the save of a RWG world

    2) Bug happens when "Creating Player"

    Actual result: The game save dont load.

    Expected result: The game to load and run.


    Here is the pastebin link to the log file.



    <?xml version="1.0" encoding="UTF-8"?>
      <property name="Scale" value="1" />
      <property name="HeightMapSize" value="8192,8192" />
      <property name="Modes" value="Survival,SurvivalSP,SurvivalMP,Creative" />
      <property name="FixedWaterLevel" value="false" />
      <property name="RandomGeneratedWorld" value="true" />
      <property name="GameVersion" value="Alpha.21.0.313" />
      <property name="Generation.Seed" value="131093" />
      <property name="Generation.Towns" value="Default" />
      <property name="Generation.Wilderness" value="Default" />
      <property name="Generation.Lakes" value="Default" />
      <property name="Generation.Rivers" value="Default" />
      <property name="Generation.Cracks" value="Default" />
      <property name="Generation.Craters" value="Default" />
      <property name="Generation.Plains" value="4" />
      <property name="Generation.Hills" value="4" />
      <property name="Generation.Mountains" value="4" />
      <property name="Generation.Snow" value="4" />
      <property name="Generation.Forest" value="7" />
      <property name="Generation.Desert" value="4" />
      <property name="Generation.Wasteland" value="3" />

    User Feedback

    Recommended Comments

    Its a Profile issue, looking on another threads with same problem i tryed deleting the Profiles from the launcher, it didnt worked.

    Fixed after deleting the registry key HKEY_CURRENT_USER\SOFTWARE\The Fun Pimps

    Link to comment
    Share on other sites

    I had the same problem and I solved it as follows:


    You will open %appdata%>Roaming and save the folder "7 Days To Die". This will serve as your backup.

    Now, you will navigate to the location where the game is saved and open the game launcher. Proceed to the "Tools" section and select "Clean Game Data." Activate all the available options. After completing this step, launch the game and create a new save in the same world as your previous one.

    Once the new world you create finishes loading, log out, and open %appdata%>Roaming>7 Days To Die>Saves. Here, you will replace the <Navezgane> folder (which represents the map you play on) with the <Navezgane> folder from the backup you previously made.


    And the best part is, you won't lose anything at all.


    I resolved my issue by replacing only that folder, so I'm not aware if there's any other way to solve it.

    Good luck dude


    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...