Jump to content
  • INF Discarding NetPackagePlayerStats entity id=171

    • Version: A21


    Summary: Can not load into game, client side shows above error, server side shows they are in game in the player list but they don't generate in the world. Level and game stage seems to have been reset.
    Another, possibly related error occured when entering the "options-> player" section. Posting the log from that (it loops until crash, so it was a seperate launch, if that matters)
    Possibly related, this did occur after the client side computer upgraded their GPU from a 1030 to a 1660 (6Gb)

    Game Version: A21

    OS/Version: Windows 10


    CPU Model:  
    Client side: AMD Ryzen 5 3600 6 core

    Server Side: AMD Ryzen 7 1700X (8 core)


    System Memory: (4 GB / 8 GB / 16 GB / etc)


    Client Side: 32 GB
    Server Side: 16 GB

    GPU Model and VRAM: 


    Client Side: Nvidia GeForce GTX 1660 (6Gb)
    Server Side: Nvidia GeForce GTX 1060 (6 Gb)

    Screen Resolution: (Width and Height such as 1920x1080)

    Client Side: 1920 x 1080
    Server Side: 1920 x 1080

    Video Settings: (Low / Medium / High / Ultra / Custom(Custom has many combinations, so just list the settings you think are relevant to the bug if any))


    Client Side: Mix of low/medium)
    Server Side: Mostly high I think

    Game mode: (MP host / MP client / SP / Client on Dedi, RWG or NAV)

    Client Side: MP Client
    Server Side: MP Host

    Did you wipe old saves? (Yes/No)


    Did you start a new game? (Yes/No)


    Did you validate your files? (Yes/No)

    Yes (on both client and server side)

    Are you using any mods? (Yes/No)


    EAC on or off?


    Status: NEW


    Bug Description:

    Can not load game, indefinite loop of the error above (creating a 1000+ Kb log, it's in 3 different pastebins..)

    Detailed steps to reproduce the bug:

    1) All attempts to join the server

    Actual result: (description of what is occurring)


    Expected result: (what you expect to occur)
    Join the server

    Link to Pastebin Output Log:
    Client Side 
    Joining the server



    Server Side
    This is the log from my computer (I am hosting the server)

    Unable to get screenshot on the client side (They would not save)
    Server side https://imgur.com/a/5urx9Dz
    We had all logged off in the same room, I had been staring at the location they were in. You can see their level and game stage has been reset.


    User Feedback

    Recommended Comments

    Well, was hoping for some help but gonna log my troubleshooting with this just to have a written record if nothing else. So I just deleted the player file from the 7d2d folder in app data>roaming, and am going to see if that fixes it.

    Shame to lose all that progress but...

    Problem persist after doing so.

    Ah before I move on, the exact file I deleted was the app data>roaming>7days>saveslocal>player

    now I'm deleting appdata>roaming>7days>saves>profile.sdf

    Link to comment
    Share on other sites

    Deleting the profile.sdf did ask the player on the client side to make a new character. Upon clicking a character, the game froze, the CMD popped up, and it created a 2000+kb log file. Given Pastebins 500Kb limit, I'm not going ot try and upload this (seems useless since I'm basically talking to myself..) gonna do a clean install, and see if that works..


    Link to comment
    Share on other sites

    The problem persists after a clean install.

    It's worth noting, the issue appears to be client side, as it not only prohibits them from joining my game but also from entering the settings>player menu. We're attempting to launch a new game now and see if the client is able to play single player or not. Kind of just grasping at straws right now.. The same error occurs when launching in single player, though.

    Launching the 7days launcher> tools > clean game, cleaning:
    -Generated random worlds
    -Discovered map of remote games
    -Player profiles
    -Serveradmin configuration.

    Problem persists.

    Link to comment
    Share on other sites

    2 hours ago, Serenity557 said:

     Given Pastebins 500Kb limit, I'm not going ot try and upload this


    You can try https://justpaste.it/ and see if it allows you to paste

    Based on the client logs though

    IndexOutOfRangeException: Index was outside the bounds of the array.

    at Archetypes.BuildUMA (Archetype _archetype, UMA.UMAData _umaData, SlotLibrary _slotLib, OverlayLibrary _overlayLib, Entity _entity, System.String _profileName, System.Boolean _showPreviewSlots, System.Boolean _useCustomColors, UnityEngine.Color hair, UnityEngine.Color eye, UnityEngine.Color skin, PlayerProfile _playerProfile) [0x00398] in <d7dcfa4979674f179c13273f8b30b551>:0

    it sounds like they are having the problem with their profiles, they can try this fix described here:


    Link to comment
    Share on other sites

    32 minutes ago, NekoPawtato said:

    You can try https://justpaste.it/ and see if it allows you to paste

    Based on the client logs though

    it sounds like they are having the problem with their profiles, they can try this fix described here:


    Yes, that seems to have fixed it, thanks! They're able to make a new profile, at the least. I had looked on their for specifically problems with profiles and totally overlooked the red error on start up!
    I'll update with verification that it worked or didn't in a few moments!

    So that did not fix it, but I'm going to attempt to delete the player data server side as well, as they are able to access the settings>player area after getting the 171 error

    Link to comment
    Share on other sites

    Deleted their information from the folder  and they still cannot join the server. C:\Users\[username]\AppData\Roaming\7DaysToDie\Saves\Navezgane\[servername]\players.xml

    The client is able to load into a single player game now, though.

    it is late, so I will continue in the morning.

    Link to comment
    Share on other sites

    2023-09-18T18:19:45 37.991 INF NET: LiteNetLib trying to connect to:
    2023-09-18T18:19:46 38.721 WRN NET: Requesting rules from TCP ( timed out
    2023-09-18T18:19:51 43.672 INF NET: LiteNetLib: Connection failed: ConnectionFailed
    2023-09-18T18:19:51 43.672 INF NET: Steam NW trying to connect to:


    Hey, if you're still troubleshooting this, your client logs are showing they're failing to connect via LiteNetLib, there's either or both a firewall/port forwarding issue. That isn't exactly a cause for the save corruption, but it adds a large latency between communications, so if there's enough instability then the data can just crap out, leaving to too much bad data. Things are being worked on as we speak, but solving the failure to connect via LiteNetLib and maybe having clients that are afflicted to use the Network Workaround option in the General settings can help.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...