Jump to content
  • WebPanel and API not working.

    • Version: 21.1(b16)

    I have this problem. If you enable web panel for dedicated server on ubuntu 20.04. When connecting by ip:port it does not allow authorization. Authorization works if you go to the domain, configured, through the same nginx.
    But the main problem is different. When requesting through the console or API, I get an error "ERROR_PROCESSING".
    Here is the whole response that the server gives to the request through the web console:

      "data": [],
      "meta": {
        "serverTime": "2023-09-09T16:33:10.2309460+03:00",
        "requestMethod": "POST",
        "requestSubpath": null,
        "requestBody": {
          "command": "help"
        "errorCode": "ERROR_PROCESSING",
        "exceptionMessage": "Chunked encoding upload is not supported on the HTTP/1.0 protocol.",
        "exceptionTrace": "  at SpaceWizards.HttpListener.HttpListenerResponse.set_EntitySendFormat (SpaceWizards.HttpListener.EntitySendFormat value) [0x00038] in <0d5103423bc945a6a7675d41c1abc410>:0 \n  at SpaceWizards.HttpListener.HttpListenerResponse.set_SendChunked (System.Boolean value) [0x00000] in <0d5103423bc945a6a7675d41c1abc410>:0 \n  at Webserver.WebAPI.APIs.Command.HandleRestPost (Webserver.RequestContext _context, System.Collections.Generic.IDictionary`2[TKey,TValue] _jsonInput, System.Byte[] _jsonInputData) [0x0011c] in <4d14e2b1665c4390984805cd68d2b859>:0 \n  at Webserver.WebAPI.AbsRestApi.HandleRequest (Webserver.RequestContext _context) [0x00127] in <4d14e2b1665c4390984805cd68d2b859>:0 "

    I am running a server with the Overhall mod Darkness Falls. But I also noticed this problem on a clean server, but for version 21.0 Build I don't remember, but it was the first build for stable version 21.0
    Have searched this forum, similar problems, but haven't found it. Either I'm searching with the wrong keywords, or other people don't have this problem. I can't check for Windows OS.

    I also tried to get responses from the server through API using my java application with Spring Boot 2.7.3.
    I sent requests via standard RestTemplate, which works via HTTP/1.1 protocol.
    On Post requests, also gives an error.
    I also tried standard java methods to address the protocol HTTP/1.0, but still get an error.

    User Feedback

    Recommended Comments

    There are no comments to display.

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...