Jump to content
  • NullReferenceException: Object reference not set to an instance of an object error prevents joining the server

       (0 reviews)

    Flar
     Share

    Summary: erroring out on joining a dedicated server ive previously played on. 

     

    Game Version: A20 B233

    Platform: PC

    OS/Version: Windows 10 21H1

    CPU Model: AMD Ryzen 5 2600

    System Memory: 16 GB

    GPU Model and VRAM: AMD RX 580 8 GB

    Screen Resolution: 1080p

    Video Settings: low \ medium

    Game mode: MP Client

     

    Did you wipe old saves? YES 

    Did you start a new game? YES 

    Did you validate your files? YES

    Are you using any mods? NO

    EAC on or off? ON

     

    Status: NEW

     

    Bug Description:
    After my client updated from b231 to b233, i can no longer join a dedicated server that i was playing approxh 10+ hours since A20 went to Experimental. 
    When joining the server, at the stage of Creating Character, console shows me NullReferenceException: Object reference not set to an instance of an object
     

    In the log file more detailed 
     NullReferenceException: Object reference not set to an instance of an object
      at GameManager.PlayerId (System.Int32 _playerId, System.Int32 _teamNumber, PlayerDataFile _playerDataFile, System.Int32 _chunkViewDim) [0x0005d] in <e905376b19ea4fabb0377334749ef142>:0 
      at NetPackagePlayerId.ProcessPackage (World _world, GameManager _callbacks) [0x00000] in <e905376b19ea4fabb0377334749ef142>:0 
      at ConnectionManager.ProcessPackages (INetConnection _connection, NetPackageDirection _disallowedDirection, ClientInfo _clientInfo) [0x000c8] in <e905376b19ea4fabb0377334749ef142>:0 
      at ConnectionManager.Update () [0x000f6] in <e905376b19ea4fabb0377334749ef142>:0 
     

    Detailed steps to reproduce the bug:
    Unknown.
    Validated the server and client. Same error on joining. Re-downloaded client and server files from scratch. Same error. 
    Checked same map file locally - works fine. Loaded into several other dedicated servers - works fine. 
    Changed Player Profile to a new, empty one. Same error on joining.
    Cleared game data trough launcher (before updating to Experimental AND after seeing this issue). Same error.
    Manually removed 7DTD folder from my Windows profile so the game would recreate it. Same error. 

    Other player (using Proton on Linux) can join server without an issue. Will attempt to check if another Windows player can join the server. 
     
    Actual result: loading to dedicated server stops with an error above

     

    Expected result: load to this specific dedicated server. 

    No GenerationInfo.txt found within the GeneratedWorlds corresponding folder. 

     

     Share


    User Feedback

    There are no reviews to display.


×
×
  • Create New...